Package Base Details: python-scipy-mkl

Git Clone URL: https://aur.archlinux.org/python-scipy-mkl.git (read-only)
Submitter: bred
Maintainer: bred
Last Packager: bred
Votes: 23
Popularity: 1.540576
First Submitted: 2012-09-06 19:34
Last Updated: 2018-07-06 18:06

Latest Comments

1 2 3 4 Next › Last »

aoowweenn commented on 2018-09-07 17:57

Since setuptools changed a lot, please update the gcc part:

line 63, python3 setup.py build --fcompiler=gnu95 --compiler=unix

line 80, python2 setup.py build --fcompiler=gnu95 --compiler=unix

line 122, python3 setup.py config --compiler=unix config_fc --fcompiler=gnu95 install --prefix=/usr --root="${pkgdir}/" --optimize=1

line 145, python2 setup.py config --compiler=unix config_fc --fcompiler=gnu95 install --prefix=/usr --root="${pkgdir}/" --optimize=1

petronny commented on 2018-08-20 05:25

AFAIK, Python 3.7 works fine. The problem is the new version of numpy is not compatible with scipy when using python 2.7. I'm trying to solve this.

bred commented on 2018-08-16 18:41

Somebody has figure out how to compile scipy-mkl with python 3.7 ????

petronny commented on 2018-07-19 04:15

python-scipy-mkl has a literal $pkgver in its provides. This happens because you have enclosed these variables in strong quotes.

Forwarded from https://github.com/arch4edu/arch4edu/issues/17

L0ric0 commented on 2018-07-06 18:02

Hi, the build_python.sh fails the sha256sums check.

Please update the checksums.

bred commented on 2018-07-06 17:46

@petronny TNX !!! :)

petronny commented on 2018-07-04 04:46

Hi, after intel-parallel-studio-xe has been updated to 2018.3.222, I finally figured out how to build this package and update it to 1.1.0.

Here is my PKGBUILD and please update it.

PS. I think we should use a patch rather than the sed command in this case. Please update my PKGBUILD.

alleut commented on 2018-02-08 19:15

How to tell builder what compiler to use?

Found executable /opt/intel/compilers_and_libraries_2018.1.163/linux/bin/intel64/icc customize IntelEM64TFCompiler
Found executable /opt/intel/compilers_and_libraries_2018.1.163/linux/bin/intel64/ifort
Traceback (most recent call last):
File "setup.py", line 418, in <module>setup_package()
File "setup.py", line 414, in setup_packagesetup(**metadata)
File "/usr/lib/python3.6/site-packages/numpy/distutils/core.py", line 169, in setupreturn old_setup(**new_attr)
File "/usr/lib/python3.6/site-packages/setuptools/__init__.py", line 129, in setupreturn distutils.core.setup(**attrs)
File "/usr/lib/python3.6/distutils/core.py", line 148, in setupdist.run_commands()
File "/usr/lib/python3.6/distutils/dist.py", line 955, in run_commandsself.run_command(cmd)
File "/usr/lib/python3.6/distutils/dist.py", line 974, in run_commandcmd_obj.run()
File "/usr/lib/python3.6/site-packages/numpy/distutils/command/build_clib.py", line 75, in runself.run_command('build_src')
File "/usr/lib/python3.6/distutils/cmd.py", line 313, in run_commandself.distribution.run_command(command)
File "/usr/lib/python3.6/distutils/dist.py", line 974, in run_commandcmd_obj.run()
File "/usr/lib/python3.6/site-packages/numpy/distutils/command/build_src.py", line 148, in runself.build_sources()
File "/usr/lib/python3.6/site-packages/numpy/distutils/command/build_src.py", line 165, in build_sourcesself.build_extension_sources(ext)
File "/usr/lib/python3.6/site-packages/numpy/distutils/command/build_src.py", line 324, in build_extension_sourcessources = self.generate_sources(sources, ext)
File "/usr/lib/python3.6/site-packages/numpy/distutils/command/build_src.py", line 377, in generate_sourcessource = func(extension, build_dir)
File "scipy/_lib/setup.py", line 32, in get_messagestream_configif config_cmd.check_func('open_memstream', decl=True, call=True):
File "/usr/lib/python3.6/site-packages/numpy/distutils/command/config.py", line 312, in check_funcself._check_compiler()
File "/usr/lib/python3.6/site-packages/numpy/distutils/command/config.py", line 83, in _check_compilerself.fcompiler.customize(self.distribution)
File "/usr/lib/python3.6/site-packages/numpy/distutils/fcompiler/__init__.py", line 499, in customizeget_flags('opt', oflags)
File "/usr/lib/python3.6/site-packages/numpy/distutils/fcompiler/__init__.py", line 490, in get_flagsflags.extend(getattr(self.flag_vars, tag))
File "/usr/lib/python3.6/site-packages/numpy/distutils/environment.py", line 39, in __getattr__return self._get_var(name, conf_desc)
File "/usr/lib/python3.6/site-packages/numpy/distutils/environment.py", line 53, in _get_varvar = self._hook_handler(name, hook)
File "/usr/lib/python3.6/site-packages/numpy/distutils/fcompiler/__init__.py", line 697, in _environment_hookreturn hook()
File "/usr/lib/python3.6/site-packages/numpy/distutils/fcompiler/intel.py", line 125, in get_flags_optv = self.get_version()
File "/usr/lib/python3.6/site-packages/numpy/distutils/fcompiler/__init__.py", line 430, in get_versionraise CompilerNotFound()
numpy.distutils.fcompiler.CompilerNotFound

bred commented on 2017-12-26 11:40

The bug in icc 18.0.0 has been fixed in the icc 18.0.1.

If you are still using the icc 18.0.0 uncomment the lines 62 and 79. and comment out the lines 61 and 78.

hcb commented on 2017-12-04 09:57

Replacing .. with ${srcdir} worked for me:

# copy python3 build files
cp ${srcdir}/build_python3.sh scipy-${pkgver}

# copy python2 build files
cp -r scipy-${pkgver} scipy-${pkgver}-py2
cp ${srcdir}/build_python2.sh scipy-${pkgver}-py2