Package Base Details: wps-office

Git Clone URL: https://aur.archlinux.org/wps-office.git (read-only, click to copy)
Submitter: felixonmars
Maintainer: Universebenzene
Last Packager: Universebenzene
Votes: 467
Popularity: 2.14
First Submitted: 2014-08-17 11:57
Last Updated: 2021-09-08 09:41

Pinned Comments

Universebenzene commented on 2020-10-22 02:25

If you have the "ERROR: One or more files failed the validity check!" problem, try cleaning your AUR cache first, and try again.

Universebenzene commented on 2020-01-10 04:48

[ATTENTION] The new international version (11.1.0.9080) removed zh_CN support, login, and some other functions. If you still want full functions, or you want aarch64 support, you may need the Chinese version from https://linux.wps.cn here: https://aur.archlinux.org/pkgbase/wps-office-cn

Universebenzene commented on 2019-10-26 05:46

I split the /usr/share/mime/packages/wps-office-*.xml files to the wps-office-mime package to avoid mime issues. If you still want the mime files provided by wps-office itself, you can install the new mime package.

Universebenzene commented on 2019-07-05 17:08

There is no official 32-bit package for version 11.1.0.8722, so I drop the support for i686 arch. For archlinux32 users you can create another wps-office package for 32-bit system yourself.

Universebenzene commented on 2019-04-16 13:34

When you shut down wps-office, the wpsoffice process may still exist. You can do sudo chmod -x /usr/lib/office6/wpsoffice to fix it. But this might bring you problem with signing in.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

guiodic commented on 2021-11-23 16:11

has anyone had success for font rendering?

jesusdc commented on 2021-11-01 22:01

@tornad099, yes, I'm using KDE. It doesn't work, though. BTW, I found another user who reported the same problem 5 years ago, and his screen resolution was 1920x1080, which has the same proportion as mine (1366x768). Also, looking at the changelog of the latest official Linux build it says "introduced HIDPI support"; perhaps, that's what screwed everything up. Because as I mentioned in my first post, it doesn't happen on the previous build I tested (11.1.0.9719-1 version).

I also tried on a VM, and everything's fine with the touchpad scrolling there. ¿Any other thoughts? I'm willing to try anything just to see if we can get that sorted.

Edit: I've just tried with a mouse and the scrolling is perfectly fine, it seems the problem relies on the touchpad. I still think the "System DPI is asymmetric" warning has to do with it.

tornado99 commented on 2021-11-01 10:47

@jesusdc, could you try putting env QT_SCREEN_SCALE_FACTORS=1 in the .desktop file (assuming you are using KDE)?

or you can try just going back to an older build. i think they are still on the server if you know the filename.

jesusdc commented on 2021-10-29 23:28

Hey there guys, I'm getting the following error, "system DPI is asymmetric. WPS Office may have display issues", and what it causes is the touchpad scrolling to be unbearably fast. So I tested with older builds in descendant order, and it doesn't happen on 11.1.0.9719-1 version. Specifically this one: https://aur.archlinux.org/cgit/aur.git/commit/?h=wps-office&id=7782cc07de0d1b222759886491939a7f010c39d8.

I've googled in every possible way, but can't seem to find an answer. I would stick to the build mentioned above that works for me, but it has the dark theme glitch, and it also crashes when trying to open external links from a document.

I'd appreciate any clue, I don't want to give up on WPS as it's the only office suite I can use due to its compatibility.

Edit: Just in case, the warning is shown in the system check box that appears in the first launch, usually with the other warning if ttf-wps-fonts are not installed. Heres's a screenshot: https://i.imgur.com/t8wz2fw.png

MegaTH1RT3EN commented on 2021-10-29 14:40

How can I change the variable to start my wps in pt-br? I'm very new in the Arch community and I have no idea how to do.

Universebenzene commented on 2021-10-19 13:46

@kem1o Just install ttf-wps-fonts

kem1o commented on 2021-10-19 13:14

@Universebenzene Ok I got it. Do you know how to solve this symbol problem instead? Thanks.

https://paste.pics/25c931d42aae1327e6fb96e29c77cd2d

Universebenzene commented on 2021-10-18 18:49

@kem1o Actually although you can set locale outside, there aren't any Italian support inside wps software. Sorry for that

kem1o commented on 2021-10-18 18:42

Hi @Universebenzene, which local variable should I set to start it in Italian? Can you give me an example? Thanks.

zenfas commented on 2021-10-09 15:24

I can't see ibus input during typing if "Embed preedit text in application window" is enable (by default), all other applications work fine with this, only WPS 11.1.0.10702 has this error. Please support better Preedit and Surrounding text, ForwardKeyEvent... in Ibus and Fcitx, these input methods are very import for non-English typing.