Package Base Details: wps-office

Git Clone URL: https://aur.archlinux.org/wps-office.git (read-only, click to copy)
Submitter: felixonmars
Maintainer: Universebenzene
Last Packager: Universebenzene
Votes: 441
Popularity: 4.34
First Submitted: 2014-08-17 11:57
Last Updated: 2020-06-09 15:39

Pinned Comments

Universebenzene commented on 2020-01-10 04:48

[ATTENTION] The new international version (11.1.0.9080) removed zh_CN support, login, and some other functions. If you still want full functions, or you want aarch64 support, you may need the Chinese version from https://linux.wps.cn here: https://aur.archlinux.org/pkgbase/wps-office-cn

Universebenzene commented on 2019-10-26 05:46

I split the /usr/share/mime/packages/wps-office-*.xml files to the wps-office-mime package to avoid mime issues. If you still want the mime files provided by wps-office itself, you can install the new mime package.

Universebenzene commented on 2019-07-05 17:08

There is no official 32-bit package for version 11.1.0.8722, so I drop the support for i686 arch. For archlinux32 users you can create another wps-office package for 32-bit system yourself.

Universebenzene commented on 2019-04-16 13:34

When you shut down wps-office, the wpsoffice process may still exist. You can do sudo chmod -x /usr/lib/office6/wpsoffice to fix it. But this might bring you problem with signing in.

attenuation commented on 2017-11-29 14:16

About the software issues, you can go to the official feedback problem. I'm just a packager, I can not solve the software problem.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

bpint commented on 2020-03-08 13:51

@Universebenzene [POSSIBLE BUG & WORKAROUND] WPS takes 25 seconds to start on Manjaro.

When WPS starts, it talks to dbus-daemon and fails for some reason, so that it will only start after a 25-second dbus AT bridge timeout.

I myself add the following line, as a workaround, to /usr/bin/wps, /usr/bin/wpp, /usr/bin/et, and /usr/bin/wpspdf,

export DBUS_SESSION_BUS_ADDRESS=""

How does this happen?

STRACE for /usr/lib/office6/wps (note the 25-second gap),

21:45:55.701316 connect(10, {sa_family=AF_UNIX, sun_path="/run/user/1000/bus"}, 110) = 0
...
21:45:55.709173 sendto(8, "BEGIN\r\n", 7, MSG_NOSIGNAL, NULL, 0) = 7
21:45:55.709218 write(11, "\1\0\0\0\0\0\0\0", 8) = 8
21:45:55.709260 eventfd2(0, EFD_CLOEXEC|EFD_NONBLOCK) = 10
21:45:55.709293 write(10, "\1\0\0\0\0\0\0\0", 8) = 8
21:45:55.709350 write(11, "\1\0\0\0\0\0\0\0", 8) = 8
21:45:55.709392 poll([{fd=10, events=POLLIN}], 1, 25000) = 1 ([{fd=10, revents=POLLIN}])
21:45:55.709429 read(10, "\1\0\0\0\0\0\0\0", 16) = 8
21:45:55.709463 poll([{fd=10, events=POLLIN}], 1, 25000) = ? ERESTART_RESTARTBLOCK (Interrupted by signal)
...
21:46:20.723912 write(10, "\1\0\0\0\0\0\0\0", 8) = 8
21:46:20.724318 futex(0x1021e10, FUTEX_WAKE_PRIVATE, 2147483647) = 0
21:46:20.724590 close(10)               = 0
...

Universebenzene commented on 2020-03-02 08:57

@core00077 既然是中文用户的话可以加archlinuxcn软件仓库嘛,那有现成的(

core00077 commented on 2020-03-02 08:29

@Universebenzene Sorry, the moment I published that comment, I notice your pinned comment and realize what I said was wrong. So I edit my comment and when I publish my comment again, then I notice your reply.

core00077 commented on 2020-03-02 08:03

As the author metions in Jan, this package has another version that is designed for zh_cn users due to some decisions made by wps. So there are two version, the international one which don't support login zh_CN and other functions, and the other one maintains such functions, it's called wps-office-cn, which is also maintained by this author.

作者在一月份提过了,现在这个包(wps-office)有另一个版本,这个版本是为中国用户定制的(wps决定的)。所以现在有俩版本,国际版不支持中文、登录以及其他功能(比如云同步),另一个版本保留了这些功能,包的名字叫wps-office-cn,这个包也是该作者维护的。

Neros commented on 2020-02-10 20:33

Is there a mirror to download the package? Because the one inside the PKGBUILD is very slow...

demolisher commented on 2020-02-07 13:33

@Universebenzene

Thanks. It worked.

Universebenzene commented on 2020-02-05 13:49

@demolisher Delete the existed deb source first

demolisher commented on 2020-02-05 12:24

Getting this error running makepkg:

==> Making package: wps-office 11.1.0.9080-2 (Wed 05 Feb 2020 09:16:16 AM UTC) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Found wps-office_11.1.0.9080.XA_amd64.deb ==> Validating source files with sha1sums... wps-office_11.1.0.9080.XA_amd64.deb ... FAILED ==> ERROR: One or more files did not pass the validity check!

Disabled md5 checksums with makepkg --skipchecksums. Now I got this output:

==> Making package: wps-office 11.1.0.9080-2 (Wed 05 Feb 2020 09:15:52 AM UTC) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Found wps-office_11.1.0.9080.XA_amd64.deb ==> WARNING: Skipping verification of source file checksums. ==> Extracting sources... ==> Starting prepare()... bsdtar: Error opening archive: Failed to open 'data.tar.xz' ==> ERROR: A failure occurred in prepare(). Aborting...

Where is this data.tar.xz located? Can't find it anywhere.

Serial commented on 2020-01-11 21:35

Hello team Archlinux

Out of curiosity I was installing wps-office on another machine here that has Manjaro-Deepin 18.1.5 at home and to surprise the updated wps-office installed and worked normally.

Following are some installation images:

https://i.imgur.com/yBeffEl.png

https://i.imgur.com/hfpYeh1.png

For ArcoLinuxB-Deepin version 20.1.4 continues with installation errors

Your Considerations

Serial

adamzyg commented on 2020-01-10 15:18

国际版果然把涉嫌隐私的功能去掉了。这功能会影响它的推广。