summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbipin kumar2023-05-09 15:21:05 +0530
committerbipin kumar2023-05-09 15:21:05 +0530
commit11eae05a54f958e240d9725937a0d59a6c1021c8 (patch)
tree59d52964ab0cad9321606f13136ff54b3aa76963
downloadaur-allelecount.tar.gz
allelecount: initial upload
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
-rw-r--r--harden.patch24
-rw-r--r--series1
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40bc34efefde
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = allelecount
+ pkgdesc = program for estimating the NGS copy number
+ pkgver = 4.3.0
+ pkgrel = 1
+ url = http://cancerit.github.io/alleleCount/
+ arch = x86_64
+ license = AGPL3
+ makedepends = quilt
+ makedepends = perl
+ depends = glibc
+ depends = htslib
+ depends = bzip2
+ depends = xz
+ depends = zlib
+ source = allelecount-4.3.0.tar.gz::https://github.com/cancerit/alleleCount/archive/refs/tags/v4.3.0.tar.gz
+ source = series
+ source = harden.patch
+ b2sums = f0f2077d0efed1a9f4db76648ae375ea30989909d255917b5b280e32187a27aaf1e1844bccae8b659c34081d34592d3782b7d6df926ece79dcea62cb966b4539
+ b2sums = 55807c3d06f035d18040248d272bb150bc84ef44c4e01ae984f3abe27fd34d6f18abe5bc1cbb2945435725d2344a5b5209b37ac322cc1ff5fae1612c265c1b9b
+ b2sums = 9de3b1c44db6e8b0e2321450d19d741ad233eabb00d32c6f951e78177ee1bd36d150c3685eb7c373f806c694d3c84b94e7e4fd5683387f85587de35a646c7066
+
+pkgname = allelecount
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ff846dd253c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Bipin Kumar <kbipinkumar@pm.me>
+
+pkgname=allelecount
+_pkgname=alleleCount
+pkgver=4.3.0
+pkgrel=1
+pkgdesc="program for estimating the NGS copy number"
+arch=('x86_64')
+url="http://cancerit.github.io/alleleCount/"
+license=('AGPL3')
+depends=('glibc' 'htslib' 'bzip2' 'xz' 'zlib')
+makedepends=('quilt' 'perl')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/cancerit/alleleCount/archive/refs/tags/v${pkgver}.tar.gz"
+ 'series'
+ 'harden.patch')
+b2sums=('f0f2077d0efed1a9f4db76648ae375ea30989909d255917b5b280e32187a27aaf1e1844bccae8b659c34081d34592d3782b7d6df926ece79dcea62cb966b4539'
+ '55807c3d06f035d18040248d272bb150bc84ef44c4e01ae984f3abe27fd34d6f18abe5bc1cbb2945435725d2344a5b5209b37ac322cc1ff5fae1612c265c1b9b'
+ '9de3b1c44db6e8b0e2321450d19d741ad233eabb00d32c6f951e78177ee1bd36d150c3685eb7c373f806c694d3c84b94e7e4fd5683387f85587de35a646c7066')
+
+prepare(){
+ mkdir -p ${_pkgname}-${pkgver}/patches
+ cp *.patch ${_pkgname}-${pkgver}/patches
+ cp series ${_pkgname}-${pkgver}/patches
+ # Apply Patches
+ cd ${_pkgname}-${pkgver}/patches
+ quilt push -a
+}
+
+build() {
+ cd ${_pkgname}-${pkgver}/c
+ export HTSLIB=/usr/lib
+ make prefix=/usr
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}/c/bin
+ install -Dm755 alleleCounter ${pkgdir}/usr/bin/alleleCounter
+}
diff --git a/harden.patch b/harden.patch
new file mode 100644
index 000000000000..9a13e5dace0d
--- /dev/null
+++ b/harden.patch
@@ -0,0 +1,24 @@
+Author: Andreas Tille <tille@debian.org>
+Last-Update: Mon, 11 May 2020 16:16:46 +0200
+Description: Propagate hardening flags
+
+--- a/c/Makefile
++++ b/c/Makefile
+@@ -6,7 +6,7 @@ CC = gcc -O3 -DALLELECOUNTER_VERSION='"$
+ #compiler flags
+ # -g adds debug info to the executable file
+ # -Wall turns on most warnings from compiler
+-CFLAGS = -g -Wall
++CFLAGS += -g -Wall
+
+ #Location of samtools/htslib libraries
+ HTSLOC?=$(HTSLIB)
+@@ -67,7 +67,7 @@ all: clean make_bin make_htslib_tmp $(CO
+ @echo Binaries have been compiled.
+
+ $(COUNTER_TARGET): $(OBJS)
+- $(CC) $(JOIN_INCLUDES) $(INCLUDES) $(CFLAGS) -o $(COUNTER_TARGET) $(OBJS) $(LFLAGS) $(CAT_LFLAGS) $(LIBS) ./src/alleleCounter.c
++ $(CC) $(JOIN_INCLUDES) $(INCLUDES) $(CFLAGS) -o $(COUNTER_TARGET) $(OBJS) $(LFLAGS) $(CAT_LFLAGS) $(LIBS) ./src/alleleCounter.c $(LDFLAGS)
+
+ #Unit Tests
+ test: $(COUNTER_TARGET) \ No newline at end of file
diff --git a/series b/series
new file mode 100644
index 000000000000..a2f2d63243ea
--- /dev/null
+++ b/series
@@ -0,0 +1 @@
+harden.patch \ No newline at end of file