summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormox2019-03-02 20:03:27 +0100
committermox2019-03-02 20:03:27 +0100
commit37fde7254854d85b19e33b96c2605696684c40c1 (patch)
tree890d0f7a2943d662348bb8f556493fc2aa768df2
downloadaur-cocotb.tar.gz
Adding working PKGBUILD. Installs to /usr/local as that is where the makefile wants to install to.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
-rw-r--r--cocotb.install18
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3b31d404b14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cocotb
+ pkgdesc = Coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python
+ pkgver = 1.1
+ pkgrel = 1
+ epoch = 0
+ url = http://potential.ventures/cocotb/
+ install = cocotb.install
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = python
+ depends = swig
+ optdepends = iverilog: for simulating verilog designs
+ optdepends = ghdl: for simulating VHDL designs
+ source = https://github.com/potentialventures/cocotb/archive/v1.1.tar.gz
+ md5sums = 94483fb042f9b645acecdfab20d460a4
+
+pkgname = cocotb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f6107ae62b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: mox <demox@lavabit.com>
+pkgname=cocotb
+pkgver=1.1
+pkgrel=1
+epoch=0
+pkgdesc="Coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python"
+arch=('x86_64') # Can probably support other architectures as well, try your luck?
+url="http://potential.ventures/cocotb/"
+license=('BSD')
+#groups=()
+depends=('python' 'swig')
+makedepends=('git')
+#checkdepends=()
+optdepends=('iverilog: for simulating verilog designs' 'ghdl: for simulating VHDL designs')
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+#options=()
+install=${pkgname}.install
+#changelog=
+source=("https://github.com/potentialventures/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('94483fb042f9b645acecdfab20d460a4')
+#validpgpkeys=()
+
+
+#check() {
+# cd "$pkgname-$pkgver"
+# make test # currently fails, see https://github.com/potentialventures/cocotb/issues/833
+#}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make INSTALL_DIR="$pkgdir/usr/local" install
+ rm -r "$pkgdir/usr/local/cocotb-1.1.0/bin"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
diff --git a/cocotb.install b/cocotb.install
new file mode 100644
index 000000000000..7ffdc15635bf
--- /dev/null
+++ b/cocotb.install
@@ -0,0 +1,18 @@
+post_install() {
+ echo ''
+ echo ''
+ echo 'cocotb relies on some environment variables.'
+ echo ' You need to set COCOTB="/usr/local/cocotb-1.1.0"'
+ echo ''
+ echo 'A simple Makefile could look like this:'
+ echo '--------------------------------------------------------------------------------'
+ echo 'export USER_DIR:=$(shell pwd) # Without this cocotb will try to build in /usr/local...'
+ echo 'include $(COCOTB)/makefiles/Makefile.inc'
+ echo 'include $(COCOTB)/makefiles/Makefile.sim'
+ echo 'VERILOG_SOURCES = my_example.sv'
+ echo 'TOPLEVEL = my_example'
+ echo 'MODULE=test_my_example'
+ echo '--------------------------------------------------------------------------------'
+ echo ''
+ echo ''
+}