summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkarel2025-01-01 07:58:47 +0200
committerkarel2025-01-01 07:58:47 +0200
commit86e19bd5291108acb1eab5472ff06aa6f5470142 (patch)
treebb82e1113c855132c06a112669c848896e95651c
parentb6dc81aaa35722252fcdb49f5fec074db09af18a (diff)
downloadaur-gnuradio-git.tar.gz
Python 3.13
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c70cbca739b..535b528651a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnuradio-git
pkgdesc = General purpose DSP and SDR toolkit, with drivers for usrp and fcd.
- pkgver = v3.11.0.0git.717.g72e21b54c
+ pkgver = v3.11.0.0git.861.gd6bd59e94
pkgrel = 1
url = https://github.com/gnuradio/gnuradio
arch = i686
@@ -21,7 +21,6 @@ pkgbase = gnuradio-git
depends = python-numpy
depends = python-mako
depends = python-click
- depends = python-click-plugins
depends = python-pyqt5
depends = python-gobject
depends = python-packaging
@@ -38,10 +37,12 @@ pkgbase = gnuradio-git
depends = libvolk
depends = spdlog
depends = gtk3
+ depends = libsndfile
optdepends = python-lxml: Some GRC modules use lxml optionally for improved performance
optdepends = python-qtpy: GNU Radio Companion requires this for the Qt-based front end
- provides = gnuradio=v3.11.0.0git.717.g72e21b54c
- provides = gnuradio-companion=v3.11.0.0git.717.g72e21b54c
+ optdepends = python-pygccxml: Required by blocktool
+ provides = gnuradio=v3.11.0.0git.861.gd6bd59e94
+ provides = gnuradio-companion=v3.11.0.0git.861.gd6bd59e94
conflicts = gnuradio
conflicts = gnuradio-companion
source = git+https://github.com/gnuradio/gnuradio.git
diff --git a/PKGBUILD b/PKGBUILD
index d118d8646e7c..5357323a04d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,17 @@
pkgname=gnuradio-git
_gitname=gnuradio
-pkgver=v3.11.0.0git.717.g72e21b54c
+pkgver=v3.11.0.0git.861.gd6bd59e94
pkgrel=1
pkgdesc="General purpose DSP and SDR toolkit, with drivers for usrp and fcd."
arch=('i686' 'x86_64')
url="https://github.com/gnuradio/gnuradio"
license=('GPL')
-depends=('fftw' 'python' 'python-numpy' 'python-mako' 'python-click' 'python-click-plugins' 'python-pyqt5' 'python-gobject' 'python-packaging' 'python-jsonschema' 'cppunit' 'gsl' 'blas' 'guile' 'boost-libs>=1.54' 'libusb' 'portaudio' 'libuhd' 'zeromq' 'libvolk' 'spdlog' 'gtk3')
+depends=('fftw' 'python' 'python-numpy' 'python-mako' 'python-click' 'python-pyqt5' 'python-gobject' 'python-packaging' 'python-jsonschema' 'cppunit' 'gsl' 'blas' 'guile' 'boost-libs>=1.54' 'libusb' 'portaudio' 'libuhd' 'zeromq' 'libvolk' 'spdlog' 'gtk3' 'libsndfile')
makedepends=('git' 'boost' 'cmake' 'python-cairo' 'python-yaml' 'python-cheetah3' 'glu' 'pybind11' 'qwt' 'python-sphinx')
optdepends=('python-lxml: Some GRC modules use lxml optionally for improved performance'
- 'python-qtpy: GNU Radio Companion requires this for the Qt-based front end')
+ 'python-qtpy: GNU Radio Companion requires this for the Qt-based front end'
+ 'python-pygccxml: Required by blocktool')
source=("git+https://github.com/gnuradio/gnuradio.git")
md5sums=('SKIP')
conflicts=('gnuradio' 'gnuradio-companion')
@@ -38,7 +39,7 @@ build() {
-DENABLE_INTERNAL_VOLK=OFF \
-DENABLE_GR_CTRLPORT=OFF \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DGR_PYTHON_DIR=/usr/lib/python3.12/site-packages \
+ -DGR_PYTHON_DIR=/usr/lib/python3.13/site-packages \
-DQWT_LIBRARIES=/usr/lib/libqwt.so -Wno-dev ../
make
}