summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Dewar2021-11-30 17:27:25 +0000
committerAlex Dewar2021-11-30 17:27:25 +0000
commitfefc95f626653ddd538d7112ef6ea80e68ec1251 (patch)
tree31177d6374db81124b367d0b9e3f5471a44bfff1 /PKGBUILD
parentdbb6c032ee4003dbbc24490c1b87849df7566a1b (diff)
downloadaur-arsdk3.tar.gz
Use python2 for scripts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 709d818013f3..b165d167421e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,21 @@ license=('custom')
source=('git+https://github.com/Parrot-Developers/arsdk_manifests')
options=(!emptydirs staticlibs)
md5sums=('SKIP')
-makedepends=('repo' 'python' 'python2')
+makedepends=('repo' 'python2')
prepare() {
cd "$srcdir"
- repo init -u arsdk_manifests -b 4b50e865427e6f2f2f19be1d4c55ab87a03b804a \
+ yes|repo init -u arsdk_manifests -b 4b50e865427e6f2f2f19be1d4c55ab87a03b804a \
--no-clone-bundle --depth=1
repo sync
}
build() {
+ # Make sure to use python 2 with scripts: they fail with v3.6+
+ mkdir "$srcdir/bin" || true
+ ln -s /usr/bin/python2 "$srcdir/bin/python"
+ export PATH="$srcdir/bin":$PATH
+
"$srcdir"/build.sh -p arsdk-native -t build-sdk -j
}