summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp Joram2020-06-20 23:03:26 +0200
committerPhilipp Joram2020-06-20 23:03:26 +0200
commit11eb1ef19f8a9a49690038218cb6c40d82f5e616 (patch)
treef479ae0c477fea421654b094e1f12b4981444e56 /PKGBUILD
parentd68245d4955556a215b2baca03628fafadd8cd8a (diff)
downloadaur-eontimer-git.tar.gz
Fix package version
Technically, version 3.0 is in development at the time of writing, but the earlier 2.*-tags are not reachable anymore. Since `git describe` won't work, we fall back to counting revisions. This is forward compatible with future versions `v3.*.*`. Hopefully no one notices that this version change is not backwards compatible, so I won't have to bump the package epoch literally 5 minutes after creating the package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e91c7423318..e0576371ca81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=EonTimer
pkgname=eontimer-git
-pkgver=2.0.1
+pkgver=r55.d53e42a
pkgrel=1
pkgdesc='A Pokemon RNG timer'
arch=(x86_64)
@@ -23,6 +23,15 @@ provides=('eontimer')
source=("$pkgname-$pkgver::git+https://github.com/dylmeadows/EonTimer.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "$pkgname-$pkgver"
+ # Technically, version 3.0 is in development at the time of writing, but the
+ # earlier 2.*-tags are not reachable anymore. Since `git describe` won't
+ # work, we fall back to counting revisions. This is forward compatible with
+ # future versions `v3.*.*`.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
prepare() {
cd $pkgname-$pkgver
python3 -m qtsass -o resources/styles resources/styles