summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel M. Capella2024-03-18 20:35:00 -0400
committerDaniel M. Capella2024-03-18 20:35:00 -0400
commitd09db5466d50aaceb3a55309336025c7efe29eca (patch)
treeaba1fb8baf85a0e8d3cb4aba3b5dcf986de80f25 /PKGBUILD
parentd6125be6b53f3b84e39e884712c848a5d842654b (diff)
downloadaur-rofimoji-git.tar.gz
Bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 32 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1c22ab58a3d..793885a82411 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,66 @@
# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
pkgname=rofimoji-git
-pkgver=6.0.0.r0.gc5c9f05
+_name=${pkgname%-git}
+pkgver=6.2.0.r15.g473196a
pkgrel=1
-pkgdesc='Character picker for rofi'
+pkgdesc='Emoji, unicode and general character picker for rofi and rofi-likes'
arch=('any')
url=https://github.com/fdw/rofimoji
license=('MIT')
depends=('python-configargparse')
makedepends=('git' 'python-build' 'python-installer' 'python-poetry-core')
-optdepends=('emoji-font: for the emojis character file'
- 'nerd-fonts: for the nerd_font character file'
- 'rofi: for the X.Org selector'
- 'xclip: for one of the X.Org clipboarders'
- 'xsel: for one of the X.Org clipboarders'
- 'xdotool: for the X.Org typer'
- 'wofi: for the Wayland selector'
- 'wl-clipboard: for the Wayland clipboarder'
- 'wtype: for the Wayland typer')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-install=$pkgname.install
+optdepends=(
+ 'emoji-font: for the emojis character file'
+ 'nerd-fonts: for the nerd_font character file'
+ 'otf-font-awesome: for the fontawesome6 character file'
+ 'ttf-font-awesome: for the fontawesome6 character file'
+
+ 'bemenu: for a generic selector'
+
+ 'dmenu: for one of the X.Org selectors'
+ 'rofi: for one of the X.Org selectors'
+ 'xclip: for one of the X.Org clipboarders'
+ 'xsel: for one of the X.Org clipboarders'
+ 'xdotool: for the X.Org typer'
+
+ 'fuzzel: for one of the Wayland selectors'
+ 'tofi: for one of the Wayland selectors'
+ 'wmenu: for one of the Wayland selectors'
+ 'wofi: for one of the Wayland selectors'
+ 'wl-clipboard: for the Wayland clipboarder'
+ 'wtype: for the Wayland typer'
+)
+provides=("$_name")
+conflicts=("$_name")
source=("git+$url.git")
b2sums=('SKIP')
pkgver() {
- cd ${pkgname%-git}
+ cd "$_name"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd ${pkgname%-git}
+ cd "$_name"
# Remove include list https://github.com/pypa/wheel/issues/92
sed -i '/^include =/,/]/d' pyproject.toml
}
build() {
- cd ${pkgname%-git}
+ cd "$_name"
python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
- cd ${pkgname%-git}
+ cd "$_name"
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 -t "$pkgdir"/usr/share/man/man1 \
- src/picker/docs/${pkgname%-git}.1
+ src/picker/docs/"$_name".1
# Symlink license file
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
install -d "$pkgdir"/usr/share/licenses/$pkgname
- ln -s "$site_packages"/${pkgname%-git}-${pkgver%%.r*}.dist-info/LICENSE \
+ ln -s "$site_packages"/"$_name"-${pkgver%%.r*}.dist-info/LICENSE \
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}