summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122024-02-26 12:47:11 +0100
committerwillemw122024-02-26 12:47:11 +0100
commit12ea81d2bb44d7313c37236a8f6ffb9c50534cc6 (patch)
treeca08577c4252e124eeccfc638fcbbb98f02fd581 /PKGBUILD
parent7ad964ae766cc19fd72393aa4a72a947e55d2601 (diff)
downloadaur-sparky-tube-git.tar.gz
Upgrade to 0.2.0
Change from youtube-dl to yt-dlp. Remove kmplayer. Remove gmplayer comment. Minor edits.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 984cef293083..c04bc723fc89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,15 @@
# Maintainer: willemw <willemw12@gmail.com>
pkgname=sparky-tube-git
-pkgver=r35.ec3a763
-pkgrel=2
-pkgdesc="Download a video file from a web site and convert it to audio or video output file"
-arch=('any')
-url="https://github.com/sparkylinux/sparky-tube"
-license=('GPL3')
-depends=('ffmpeg' 'xdg-user-dirs' 'yad' 'youtube-dl')
-makedepends=('git')
-# 'gmplayer: play files'
+pkgver=r38.64f7cf9
+pkgrel=1
+pkgdesc='Download a video file from a web site and convert it to audio or video output file'
+arch=(any)
+url=https://github.com/sparkylinux/sparky-tube
+license=(GPL3)
+depends=(ffmpeg xdg-user-dirs yad yt-dlp)
+makedepends=(git)
optdepends=('vlc: play files'
- 'kmplayer: play files'
'mpv: play files'
'smplayer: play files'
'totem: play files'
@@ -30,12 +28,12 @@ pkgver() {
}
prepare() {
- sed -i 's|\(/usr\)|'"$pkgdir"'\1|g' $pkgname/install.sh
+ sed -i 's|\(/usr\)|'"$pkgdir"'\1|g' $pkgname/7/install.sh
}
package() {
- cd $pkgname
install -d "$pkgdir/usr/"{bin,share/{applications,pixmaps}}
+
+ cd $pkgname/7
./install.sh
}
-