summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAllen Wild2019-10-27 21:32:41 -0400
committerAllen Wild2019-10-27 21:32:41 -0400
commitdd402d88627b38ad1c281b7a91cb781453b3893e (patch)
treee33de98923d8421891338a5b13e1aa8c59cfaf9c /PKGBUILD
parent379b9d63e361c1006d3147b23f2dac249e9f3c5d (diff)
downloadaur-the_silver_searcher_wild-git.tar.gz
bump to 2.2.0.r195.gab8bbc3, enable libarchive
Add support for reading text files compressed with any method readable by libarchive (but not searching inside tarballs and other archives yet).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d1d665b2050..ffa91f050f17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgdesc="Allen Wild's fork of ag, which supports pcre2 and .agrc user config"
url='https://github.com/aswild/the_silver_searcher'
pkgname=the_silver_searcher_wild-git
-pkgver=2.2.0.r190.gc2e20d7
+pkgver=2.2.0.r195.gab8bbc3
pkgrel=1
provides=('the_silver_searcher')
conflicts=('the_silver_searcher')
@@ -12,7 +12,7 @@ conflicts=('the_silver_searcher')
arch=('x86_64' 'i686')
license=('Apache')
-depends=('pcre2' 'xz' 'zlib')
+depends=('pcre2' 'xz' 'zlib' 'libarchive')
makedepends=('git')
checkdepends=('python-cram')
@@ -28,7 +28,10 @@ pkgver() {
build() {
cd "$srcdir/$_srcname"
./autogen.sh
- ./configure --prefix=/usr --enable-zlib --enable-lzma \
+ ./configure --prefix=/usr \
+ --enable-zlib \
+ --enable-lzma \
+ --enable-libarchive \
ac_cv_prog_CLANG_FORMAT=no
make
}