summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--reproducible-build.patch8
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72c773e5ea1d..dd5a30cc2f9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luxtorpeda-git
pkgdesc = Steam Play compatibility tool to run games using native Linux engines
- pkgver = 60.0.0.r370.2c040cd
- pkgrel = 3
+ pkgver = 61.0.0.r373.e192991
+ pkgrel = 1
url = https://github.com/luxtorpeda-dev/luxtorpeda
arch = x86_64
arch = i686
@@ -19,7 +19,7 @@ pkgbase = luxtorpeda-git
source = size-optimisations.patch
source = install-fix.patch
sha256sums = SKIP
- sha256sums = 38a0cc7ec879a2f2dec10adf98d9d76ad7ea9a66a097122031f1759a2c4761d1
+ sha256sums = 445877f799295c8aca62fecd5679de9fbd08dd7d1dc11d8dd960cb14e0e6bda5
sha256sums = 02fe3f63b7ff6e3f020c61ce02b2f91a8129668bc06aa16ba37709ed755b9334
sha256sums = 40c1cca6675266cef790fed9db66f963b310ddec952e452674a318d02b088700
diff --git a/PKGBUILD b/PKGBUILD
index e7330bb1002b..b1a3069a3638 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: MikoĊ‚aj "D1SoveR" Banasik <d1sover@gmail.com>
pkgname='luxtorpeda-git'
-pkgver=60.0.0.r370.2c040cd
-pkgrel=3
+pkgver=61.0.0.r373.e192991
+pkgrel=1
pkgdesc='Steam Play compatibility tool to run games using native Linux engines'
arch=('x86_64' 'i686')
url='https://github.com/luxtorpeda-dev/luxtorpeda'
@@ -36,7 +36,7 @@ source=("git+${url}.git"
'size-optimisations.patch'
'install-fix.patch')
sha256sums=('SKIP'
- '38a0cc7ec879a2f2dec10adf98d9d76ad7ea9a66a097122031f1759a2c4761d1'
+ '445877f799295c8aca62fecd5679de9fbd08dd7d1dc11d8dd960cb14e0e6bda5'
'02fe3f63b7ff6e3f020c61ce02b2f91a8129668bc06aa16ba37709ed755b9334'
'40c1cca6675266cef790fed9db66f963b310ddec952e452674a318d02b088700')
diff --git a/reproducible-build.patch b/reproducible-build.patch
index cfa4f0d0e5a1..dbdcfea8b70d 100644
--- a/reproducible-build.patch
+++ b/reproducible-build.patch
@@ -1,17 +1,17 @@
diff --git a/Makefile b/Makefile
-index 268c112..87873dc 100644
+index 9e22942..faaa9dd 100644
--- a/Makefile
+++ b/Makefile
-@@ -43,7 +43,7 @@ build:
+@@ -45,7 +45,7 @@ build:
$(GODOT) --path . --export "Linux/X11" target/debug/luxtorpeda.x86_64 --no-window
release:
- cargo build --release
+ cargo build --release --locked
+ touch target/.gdignore
mkdir -p target/debug
cp -r target/release/* target/debug
- $(GODOT) --path . --export "Linux/X11" target/release/luxtorpeda.x86_64 --no-window
-@@ -52,7 +52,7 @@ lint:
+@@ -55,7 +55,7 @@ lint:
cargo clippy -- -D warnings
test: