Package Details: activinspire 2.19.69200-2

Git Clone URL: https://aur.archlinux.org/activinspire.git (read-only, click to copy)
Package Base: activinspire
Description: Presentation Software for use with Promethean Hardware products.
Upstream URL: https://support.prometheanworld.com/product/activinspire
Licenses: unknown
Submitter: jose1711
Maintainer: Malstrond
Last Packager: Malstrond
Votes: 5
Popularity: 0.000000
First Submitted: 2016-05-13 11:39
Last Updated: 2020-08-09 10:59

Latest Comments

1 2 Next › Last »

Malstrond commented on 2020-11-24 16:07

As I said in this post [ https://aur.archlinux.org/packages/activinspire/#comment-759471 ], I am aware.

However I haven't been able to figure out a solution yet.

If you trace the Inspire binary you can see that it's actually searching /usr/lib/jvm/*, but then it doesn't load the runtime.

wuesti commented on 2020-11-04 15:23

The Equation editor causes this error:

"Equation editor error occured : 
Failed to load the Java runtime environment, please install the latest Java Runtime Environment to its default location. The Java Runtime Environment can be downloaded from : http://www.java.com"

Java is installed:

#archlinux-java status
Available Java environments:
  java-14-openjdk (default)

# env | grep PATH
...
PATH=...:/usr/lib/jvm/default/bin:...

neric commented on 2020-08-12 16:01

Hi ! Big THANKS !!! it works ! sounds, videos operate very well. Only "print" don't work. I have got the same message than tvr. (printing works with wine but no sound, no video) Maybe you will fix it... Thanks again !

Malstrond commented on 2020-08-09 11:02

icu60 was indeed a missing dependency. Thanks!

Printing doesn't work for me either. I just hadn't noticed it yet because I never print. So far I don't have an idea on how to debug this either, but I'll try. As a workaround you can export to PDF and then print the PDF.

On the upside, playing imported media (audio/video) works better now because the previous version required some 32-bit gstreamer dependencies I wasn't able to find.

tvr commented on 2020-08-06 11:25

Thank you for this package, @Malstrond! Since the update to version 2.19 I have two problems:

First, I'm unable to print from activinspire. Using File -> Print... only opens a window stating "No printers installed on this computer" even though printing worked with 2.18. Any idea what's wrong here or how to debug the problem?

Second, without the optional dependency activtools, inspire doesn't start. It only prints

./Inspire: error while loading shared libraries: libicuuc.so.60: cannot open shared object file: No such file or directory

activtools depends on icu60 which resolves the problem. Should icu60 be a direct dependency of activinspire as well?

micwoj92 commented on 2020-08-04 12:26

pkgrel should be 1

Malstrond commented on 2020-08-04 12:11

The reason the source URL doesn't work anymore is because there was an update of ActivInspire. But when Promethean updates their software, they'll delete the old version, they also don't publish direct download URLs and their mirror doesn't do directory listing, so you have to scrape the mirror.

Just mark the package out of date if the source isn't found anymore, then I'll notice it sooner.

Changelog:

-Updated

-This is the first 64-bit version of ActivInspire. Promethean welcomes you to the future of yesterday!

--Because of the change in architecture, there might be some superfluous or missing dependencies at first.

-Promethean removed lots of their included libs (even though they still reference them in their own launch script), but the ones in the main program directory (e.g. some proprietary libs like libatlascomms or their QT 5.12.3) are still required, so the LD_PRELOAD stays.

-Promehtean now only includes one version of ActivInspire in the upstream package and not three redundant ones (see previous PKGBUILDs for explantation), so the download got much smaller.

Known bugs:

-I can't get ActivInspire to load Java for the equation editor. It correctly searches in the directory set by archlinux-java (e.g. /usr/lib/jvm/java-14-openjdk) but then errors out because it didn't find Java. Also tried Oracle JRE8, same problem.

I'll have to think about implementing qqqqqqqqq9's unexplanied suggestions:

-Creating directories in ~ seems to be intended by upstream (it does so on Windows too), even if it's bad form.

-Does wmctrl work with all WMs/DEs?

-I don't get using the horst variable to open files. You can open files directly if your DE uses the /usr/share/applications/activsoftware.desktop file to do it.

basti0001 commented on 2020-08-01 04:25

Hi, today I found out that the original src path@PKGBUILD

"http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activinspire/activinspire_${pkgver}-1.amd64_amd64.deb"

no longer exists. However it's possible to use http://migasfree.educa.aragon.es/pdis/Promethean/bionic/promethean64_bionic/ At least it worked for me. How can we/I change the aur package? I cloned

https://aur.archlinux.org/activinspire.git

already but did not find any hint how to proceed if a package is out of date/or not working. @Malstrond: Can you give a hint? I want to help, but in archlinux.org wiki I did not find any page to request an update of a package. A kernel bug seemed not the right place for this issue ;-) Shall I simple commit the suggested, currently working src url? Am I allowed simply to change the package? Is there any review procedure? Is it even a good idea to use this currently working url since I don't no anything about the intentions of the guys maintaining the file and any future plans.

qqqqqqqqq9 commented on 2020-07-08 15:40

#!/bin/bash
# prevent creation of multiple folders in $HOME
HOME=~/.inspire
horst=()
# set path, so that a file can be opened.
for var in "$@"
do
if [ -e "$var" ]; then horst+=("$PWD/$var") ; else horst+=("$var") ;fi
done
# This script launches ActivInspire. It is partially based on the upstream launch script, with obsolete and Ubuntu-specific stuff fixed or removed.

cd /opt/activsoftware

# Promethean software has a bug that often causes it to hang when attempting to close it using the GUI. So we need to kill those instances before launching a new one.
# kill only when no active window exits
if [ $(wmctrl -l | grep ActivInspire | wc -l) -gt 0 ] ; then : ; else killall -q Inspire ; fi

# ActivInspire needs 32-bit Java for the equation editor (see optional dependencies).
export JAVA_HOME=/usr/lib32/jvm/java32-8-jre/jre

# Promethean ships ActivInspire with a bunch of libraries. We can't recompile it and there are less problems when using this library versions.
export LD_LIBRARY_PATH="/opt/activsoftware:/opt/activsoftware/workbench:/opt/activsoftware/workbench/lib:/opt/activsoftware/32bit_libs_for_64bit_OS:$LD_LIBRARY_PATH"
export GST_PLUGIN_PATH="/opt/activsoftware/32bit_libs_for_64bit_OS:$GST_PLUGIN_PATH"
export QTWEBKIT_PLUGIN_PATH="/opt/activsoftware/32bit_libs_for_64bit_OS:$QTWEBKIT_PLUGIN_PATH"

# Launch and open the file if one was given as an argument.
./Inspire "${horst[@]}"

# This is a lock file. Since ActivInspire hangs when attempting to close it, it never gets deleted, causing problems.
# remove only, when no windows exists
if [ $(wmctrl -l | grep ActivInspire | wc -l) -gt 0 ] ; then : ; else rm -f /dev/shm/sem.promethean ; fi

Malstrond commented on 2019-09-24 18:37

-Updated

-Some new dependencies in this version

-Added the file com.ubuntu.user-interface.gschema.xml due to user feedback. According to a user ActivInspire doesn't start without that file, for me it does, but I added it anyway.