Package Details: amarok 2.9.0.r367.fc370bbebf-1

Git Clone URL: https://aur.archlinux.org/amarok.git (read-only)
Package Base: amarok
Description: The powerful music player for KDE
Upstream URL: http://amarok.kde.org/
Licenses: GPL2, FDL, LGPL2.1
Submitter: arojas
Maintainer: frealgagu
Last Packager: frealgagu
Votes: 26
Popularity: 1.898209
First Submitted: 2018-08-28 13:52
Last Updated: 2019-05-10 15:57

Pinned Comments

frealgagu commented on 2019-01-27 21:13

I've removed the dependency with libssh-gnutls and included a patch to found the mariadb database. Thanks to @ideal for this. Please let me know if you continue having issues with this package.

Latest Comments

« First ‹ Previous 1 2 3

kifuna commented on 2018-09-22 14:56

This error is most likely related to this: https://bugs.archlinux.org/task/59719. I tried to compile libssh with DWITH_GCRYPT=ON (as was the case for version 0.8.2) and amarok starts normally again. Is there maybe another option to circumvent this issue?

Behem0th commented on 2018-09-22 12:32

After arch update 22.09.18 old version amarok show error on start.

Message: "The Amarok database reported the following errors: MySQLe something failed! on library initialization failed, return code 1 In most cases you will need to resolve these errors before Amarok will run properly."

I build this version but still see error.

List updated pkg: https://pastebin.com/0RRQ94we

holunder commented on 2018-09-22 12:32

Am I the only one getting "MySQLe something failed! on library initialization failed, return code 1" since today’s updates?

Rhinoceros commented on 2018-09-09 03:59

Yeah fair enough. That all makes sense. Thanks for the update!

frealgagu commented on 2018-09-09 03:50

Yes, I was divided also, however to build the stable version you need the qt4 dependencies which have conflicts which their qt5 counterpart, so if you want to build the build the amarok 2.9 (qt4) you will need to downgrade the qt5 packages to qt4 to work. I guess that once amarok release the new version it will be included again in community or extra repository, but until the dependencies are in qt4 is not viable.

If you found a way to build it without conflicts with the last releases of qt5 or installing qt4 without issues, please let me know and I'll fix the package.

With the current version of qt5 you are not able to install amarok 2.9.0 or earlier, and if you have installed amarok surely is the version 2.9.0.git20180816 which already includes the support to qt5 but is still in pre-alpha.

https://community.kde.org/Amarok/Development/KF5port https://community.kde.org/Amarok/Development/KF5port/Status

For now, I prefer to use the development version which has already ported a lot to KF5 instead of downgrade a lot of libraries.

Rhinoceros commented on 2018-09-09 03:38

Hey frealgagu, I see that you updated the PKGBUILD to the next, pre-alpha version of amarok. I had some issues when the official repos updated it to this version too [a]. Basically, I'm not sure that this is the best idea, because several things are broken in this version. It's not the stable version, so perhaps this should be left for amarok-git. However, I get that the stable version is difficult to build because of it needs qca-qt4 to make, so I'm partially divided. Is there an easy way to build the current stable version instead?

[a] https://bbs.archlinux.org/viewtopic.php?pid=1804753#p1804753

frealgagu commented on 2018-09-02 15:28

A lot of dependencies (qt4) were removed from official repositories and amarok need them to compile successfully. I'm currently without access to a computer, so I hope returns in a week to fix the package.

The last git commits of the project uses qt5 so I guess amarok will release one soon.

Rhinoceros commented on 2018-09-02 11:27

Package amarok is in official repo

I don't think so? It got removed from the official repos.

This from AUR cannot be build

Agreed, but I don't think it should be renamed on that basis.

pavbaranov commented on 2018-09-02 11:23

This package should be rename to amarok-old, amarok2 or something like this. Package amarok is in official repo and in AUR. This from AUR cannot be build because of missing dependency in repos and in AUR.

Rhinoceros commented on 2018-08-28 23:53

Thanks for picking this up @frealgagu. You probably already know, but this package depends on qtscriptgenerator, which is missing in the repos/AUR, but also kdebase-runtime > kdelibs > polkit-qt4, which is also missing.

==EDIT== Eep, I just realised this also needs qca-qt4 as makedepends. This conflicts with qca, which is required by a whole bunch of kde things.