Package Details: apostrophe 2.6.3-6

Git Clone URL: (read-only, click to copy)
Package Base: apostrophe
Description: A distraction free Markdown editor for GNU/Linux made with GTK+
Upstream URL:
Licenses: GPL3
Submitter: yochananmarqos
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 31
Popularity: 0.084162
First Submitted: 2020-04-18 14:55 (UTC)
Last Updated: 2023-06-18 16:03 (UTC)

Latest Comments

1 2 3 4 5 Next › Last »

rafaelff commented on 2022-09-27 13:44 (UTC)

Please add python-chardet to depends array. imports chardet but no other current dependency satisfy it.

yochananmarqos commented on 2022-07-15 18:29 (UTC)

@q234rty: It really doesn't matter as it's pulled in, anyway.

❯ pactree -r lua-lpeg

q234rty commented on 2022-07-15 08:38 (UTC)

haskell-lpeg was fixed and the lua-lpeg dependency is probably no longer needed.

sly commented on 2022-07-13 15:00 (UTC)

@yochananmarqos: Wow, thanks for the fast reaction!

yochananmarqos commented on 2022-07-11 16:02 (UTC)

@sly: Aha! pandoc depends on haskell-lpeg that still depends on lua53-lpeg. I suppose I'll have to add lua-lpeg as a dependency for now.

sly commented on 2022-07-11 15:15 (UTC)

I get an error when opening apostrophe's preview:

RuntimeError: Pandoc died with exitcode "83" during conversion: Error running filter /usr/share/apostrophe/lua/relative_to_absolute.lua: module 'lpeg' not found:

It works after installing lua-lpeg manually; maybe that's missing as a dependency?

yochananmarqos commented on 2022-05-27 15:10 (UTC)

@bricewge: Oops. It's fixed now.

bricewge commented on 2022-05-27 14:52 (UTC) (edited on 2022-05-27 14:52 (UTC) by bricewge)

@yochananmarqos The bugfix 1953395 from Fedora, never worked in Arch Linux as Fira fonts are installed in /usr/share/fonts/OTF/, not /usr/share/fonts/mozilla-fira/ as it is done in Fedora. It would be nice if you fix it.

yochananmarqos commented on 2022-03-24 17:39 (UTC)

@sardaukar: Using the AUR expects one to be fully up to date with Arch stable.

sardaukar commented on 2022-03-24 16:27 (UTC)

new version is broken

could not satisfy dependencies:
- unable to satisfy dependency 'libhandy>=1.6' required by apostrophe