Package Details: audacious-plugins-git 1:4.2.beta1.r5.gf0c055546-1

Git Clone URL: (read-only, click to copy)
Package Base: audacious-plugins-git
Description: Plugins for Audacious (git version)
Upstream URL:
Licenses: GPL, BSD
Conflicts: audacious-plugins
Provides: audacious-plugins
Submitter: Radioactiveman
Maintainer: Radioactiveman
Last Packager: Radioactiveman
Votes: 20
Popularity: 0.000000
First Submitted: 2011-06-02 19:15 (UTC)
Last Updated: 2022-03-16 17:18 (UTC)

Latest Comments

CasualUser commented on 2022-02-27 20:45 (UTC)

@Radioactiveman : thanks.

Radioactiveman commented on 2022-02-27 20:27 (UTC) (edited on 2022-02-27 20:52 (UTC) by Radioactiveman)

@CasualUser: Fixed, thanks for reporting. Forwarded to upstream bug tracker:

CasualUser commented on 2022-02-27 13:20 (UTC) (edited on 2022-02-27 13:30 (UTC) by CasualUser)

Compilation fails on manjaro. Got this: In function ‘AVInputFormat get_format_by_content(const char, VFSFile&)’: error: invalid conversion from ‘const AVInputFormat’ to ‘AVInputFormat’ [-fpermissive]

291 | f = av_probe_input_format2 (& d, true, & score);

  |                       |
  |                       const AVInputFormat* In function ‘bool find_codec(AVFormatContext, CodecInfo)’: error: invalid conversion from ‘const AVCodec’ to ‘AVCodec’ [-fpermissive]

364 | AVCodec * codec = avcodec_find_decoder (stream->codecpar->codec_id);

  |                               ~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~
  |                                                    |

  |                                                    const AVCodec*

FFmpeg just got updated to 5.0.4, can be this the cause?

Radioactiveman commented on 2021-10-16 16:00 (UTC)

@katt: Sure thing, I have added the libopenmpt dependency.

katt commented on 2021-10-16 13:37 (UTC)

Well, the day has finally come, the package in the official repos now builds with libopenmpt, could this be added to this package as well? :D

Radioactiveman commented on 2020-05-11 17:26 (UTC) (edited on 2020-05-11 17:26 (UTC) by Radioactiveman)

@katt: Thanks for the suggestion. But I want to stick to packages in the official repositories. And since libopenmpt provides libmodplug the proper dependency is libmodplug anyway, so you have the choice.

katt commented on 2020-05-08 15:56 (UTC) (edited on 2020-05-08 15:57 (UTC) by katt)

Could this be built with libopenmpt? The official package doesn't have it as libopenmpt is only in AUR, but I don't see why this package can't have it.

Just needs to be a makedepend and then optional dependency. (I already build it with libopenmpt by just having it installed).

Thanks in advance :)

Radioactiveman commented on 2020-04-14 22:46 (UTC)

@dvzrv: The official audacious-plugins package from [extra] requires jack2 as well. Feel free to file a bug report for this. If they adapt it, I will update the AUR package accordingly.

Radioactiveman commented on 2020-02-07 16:36 (UTC)

@ax34: The plugins now depend on Audacious. Thanks for the suggestion.

ax34 commented on 2020-02-05 18:13 (UTC)

@Radioactiveman, when i install both audacious-git and audacious-plugins-git with yay and then choose to remove makedepends after install yay removes audacious-git, so i believe one of them should depend on another.

Radioactiveman commented on 2020-02-05 18:06 (UTC)

@ax34: Good question. Audacious from [extra] depends on audacious-plugins, but this approach is not possible for the AUR package because of circular dependencies. But the other direction (audacious-plugins depend on audacious) could work.

ax34 commented on 2020-02-04 14:06 (UTC)

Shouldn't it depend (not only makedepend) on audacious-git ?

dvzrv commented on 2019-02-13 11:52 (UTC)

@Radioactiveman: in case this package is still relevant at all, please change the dependency to jack, as jack2 provides jack.

Radioactiveman commented on 2015-04-25 11:35 (UTC)

Do you try to build a Qt only version but GTK is installed? Please report that upstream ( and attach the config.log file.

sparse commented on 2015-04-25 11:00 (UTC)

I have to set ${GLIB_CFLAGS}, ${GLIB_LIBS}, ${GTK_CFLAGS}, ${GTK_LIBS} and install/reinstall audacious/audacious-git to solve missing headers problem and finally sucessfuly compiled. seems works but i have errors when opening it (sorry for shitty english): ERROR [plugin_load]: /usr/lib/audacious/Input/ could not be loaded: cannot open shared object file: No such file or directory ERROR [plugin_load]: /usr/lib/audacious/Effect/ could not be loaded: cannot open shared object file: No such file or directory ERROR [plugin_load]: /usr/lib/audacious/General/ could not be loaded: cannot open shared object file: No such file or directory ERROR [plugin_load]: /usr/lib/audacious/General/ could not be loaded: cannot open shared object file: No such file or directory

Radioactiveman commented on 2015-04-24 21:35 (UTC)

Does it compile if you add "${GLIB_CFLAGS}" to CPPFLAGS and "${GLIB_LIBS}" to LIBS in the amidi-plug makefile?

sparse commented on 2015-04-24 21:09 (UTC)

can not build with qt enabled: fatal error: glib/gstdio.h: No such file or directory #include <glib/gstdio.h> ^ compilation terminated. ... glib2 is installed.

servimo commented on 2014-12-17 15:51 (UTC)

OK, now with version audacious-git> = 12.17.2014 everything worked.

Radioactiveman commented on 2014-12-17 15:35 (UTC)

@servimo: Do you only update AUR packages if Yourt says you should? I hope you know the purpose of git packages... If you rebuild them, the latest version gets packaged and the pkgver variable is updated.

servimo commented on 2014-12-17 00:21 (UTC)

Error: Target not found: audacious-git> = 12.15.2014

Radioactiveman commented on 2014-12-16 16:24 (UTC)

This does not help, be more specific what does not work. Also what's octopy and how is it related?

servimo commented on 2014-12-16 16:08 (UTC)

I have version "2014.12.11-1", Yaourt says I need to upgrade to "2014.12.15-1" but the it don't work. My icon in octopy is yellow. Should I wait for a solution?

Radioactiveman commented on 2014-12-15 20:05 (UTC)

I have reported this to upstream (bug report #492) and added a temporary workaround to the PKGBUILD.

Alister.Hood commented on 2014-12-14 13:12 (UTC)

Does the build fail for others like this?: Successfully compiled (plugin). /usr/lib/libc_nonshared.a(stack_chk_fail_local.oS): In function `__stack_chk_fail_local': (.text+0x10): undefined reference to `__stack_chk_fail' collect2: error: ld returned 1 exit status Failed to link! ../../ recipe for target '' failed make[5]: *** [] Error 1 ../../ recipe for target 'all' failed make[4]: *** [all] Error 2 ../ recipe for target 'gl-spectrum' failed make[3]: *** [gl-spectrum] Error 2 make[3]: *** Waiting for unfinished jobs.... Successfully compiled (plugin). Successfully compiled (plugin). Successfully compiled (plugin). Successfully linked Leaving directory ladspa. ../ recipe for target 'all' failed make[2]: *** [all] Error 2 recipe for target 'src' failed make[1]: *** [src] Error 2 recipe for target 'all' failed make: *** [all] Error 2

Radioactiveman commented on 2013-11-22 13:58 (UTC)

Added 'libbs2b' to make- and optdepends. Thanks for the suggestion.

kumquaternion commented on 2013-11-22 01:42 (UTC)

Please add libbs2b to makedepends to build the bs2b plugin.

Radioactiveman commented on 2012-01-17 17:37 (UTC)

It needs jack2 as makedepend to build the jack output plugin, if you want to use this, you need jack2 -> optdepend Everything is correct and not strange. ;) If you think jack2 should be jack, file a bugreport for the Arch package.

smoge commented on 2012-01-17 17:14 (UTC)

Hun, it needs jack2 just for build but not for running? Strange. I built here with jack1 without problems. It's up to the user to choose jack1 or jack2, they are binary compatible and they are not the same project.

Radioactiveman commented on 2012-01-16 15:31 (UTC)

But the version from [extra] also uses jack2 Do you use jack and don't want jack2 as makedependency?

smoge commented on 2012-01-16 08:28 (UTC)

Change jack2 to jack. They are binary compatible and `jack2' provides `jack'.

commented on 2011-06-24 01:40 (UTC)

Yep, fixed. :)

Radioactiveman commented on 2011-06-24 00:15 (UTC)

Try it again ->

commented on 2011-06-23 21:16 (UTC)

Radioactiveman commented on 2011-06-22 11:55 (UTC)

If you think it's an audacious bug, file a report here:

commented on 2011-06-22 11:35 (UTC)

I've done that before. On closer inspection it's from ffmpeg-git of the [nightly] Shadow Ice x64 repository; the structure has changed and evidently compiling the plugins requires deprecated code.

Radioactiveman commented on 2011-06-22 11:09 (UTC)

I just tested yaourt and it works fine. Try: # pacman -Rdd audacious-git audacious-plugins-git # yaourt -S audacious-git # yaourt -S audacious-plugins-git

commented on 2011-06-22 03:23 (UTC)

Audacious compiles fine; the plugins (this) does not. I'm going to stick with the alpha packages...

Radioactiveman commented on 2011-06-21 23:49 (UTC)

Did you compile audacious-git successfully? You need that at first to compile this package.

commented on 2011-06-21 23:36 (UTC)

"warning: cannot resolve "audacious-plugins-git>=${pkgver}", a dependency of "audacious-git""? I am using yaourt-git, btw.