Package Details: bavarder 1.0.0-2

Git Clone URL: https://aur.archlinux.org/bavarder.git (read-only, click to copy)
Package Base: bavarder
Description: Chit-Chat with AI
Upstream URL: https://bavarder.codeberg.page
Keywords: ai, chatgpt, gpt, gpt4, gui,
Licenses: GPL3
Submitter: 0xmrtt
Maintainer: WSDMatty
Last Packager: WSDMatty
Votes: 3
Popularity: 0.000903
First Submitted: 2023-05-07 22:02 (UTC)
Last Updated: 2023-12-24 02:58 (UTC)

Latest Comments

1 2 Next › Last »

MichaelARCH commented on 2023-06-06 15:12 (UTC) (edited on 2023-06-06 15:12 (UTC) by MichaelARCH)

Thank you 0xmrtt:

It's because bavarder require blueprint-compiler >=0.8.1

You were right! I have been traveling, could not check for it earlier. Thanks a lot for your work here!

WSDMatty commented on 2023-06-01 13:10 (UTC)

mmmotion: pymdown-extensions and python-markdown added to dependencies

also bumped new version

mmmotion commented on 2023-06-01 11:08 (UTC)

OK, now it compiles but somehow won't install all its python's dependencies correctly - I had to pip install 'markdown' and then it was still not launching. Had to force install 'pymdown-extensions'. This application is a hell of python dependencies, overall.

Now it works supposedly fine although the GTK interface ignores completely my GTK settings in i3, for some reason.

Also, the app UI now says there's already an update, in a pop up.

Thanks for your work @WSDMatty !!

WSDMatty commented on 2023-06-01 10:36 (UTC)

mmmotion: your problem is missing webkitgtk-6.0 dependency. That has been updated try rebuilding.

MichaelARCH: You're using an old version of blueprint-compiler. with 0.8.1 it compiled fine, with 0.6.0 it failed identically to yours.

0xmrtt commented on 2023-05-30 15:32 (UTC)

It's because bavarder require blueprint-compiler >=0.8.1

MichaelARCH commented on 2023-05-30 15:00 (UTC) (edited on 2023-05-30 15:11 (UTC) by MichaelARCH)

Thanks @WFDMatty for your work! I'm facing the similar issue as mmmotion, but the message is a bit different here:

/usr/bin/blueprint-compiler batch-compile data/ui/. ../bavarder/data/ui ../bavarder/data/ui/preferences.blp ../bavarder/data/ui/window.blp
error: Could not determine what kind of syntax is meant here
at ../bavarder/data/ui/preferences.blp line 4 column 10:
4 |template $Preferences : Adw.PreferencesWindow {
     |         ^
ninja: build stopped: subcommand failed.

mmmotion commented on 2023-05-30 09:41 (UTC)

Glad that someone took this package for maintenance.

I still can't install it on my machine though, this time is not the checksum but looks like a missing dependency?

Found ninja-1.11.1 at /usr/bin/ninja
INFO: autodetecting backend as ninja
INFO: calculating backend command to run: /usr/bin/ninja -C /home/mmmotion/.cache/yay/bavarder/src/build
ninja: Entering directory `/home/mmmotion/.cache/yay/bavarder/src/build'
[21/22] Generating data/ui/blueprints with a custom command
FAILED: data/ui
/usr/bin/blueprint-compiler batch-compile data/ui/. ../bavarder/data/ui ../bavarder/data/ui/preferences.blp ../bavarder/data/ui/window.blp
error: Namespace WebKit-6.0 could not be found
at ../bavarder/data/ui/window.blp line 3 column 7:
   3 |using WebKit 6.0;
     |      ^
hint: search path: /usr/lib/girepository-1.0

ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: bavarder-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
bavarder - exit status 4

0xmrtt commented on 2023-05-29 10:55 (UTC)

I don't have the time to maintain this package. Feel free to take it!

MichaelARCH commented on 2023-05-25 05:58 (UTC)

Same b2sums failure here, even with this checksum

Kernald commented on 2023-05-19 09:45 (UTC)

The checksum of the source seems to have changed:

==> Validating source files with b2sums...
    0.2.2.tar.gz ... FAILED