Package Details: biglybt 2.4.0.0-1

Git Clone URL: https://aur.archlinux.org/biglybt.git (read-only, click to copy)
Package Base: biglybt
Description: Feature-filled Bittorrent client based on the Azureus project
Upstream URL: https://www.biglybt.com/
Licenses: GPL3
Submitter: Det
Maintainer: mrxx
Last Packager: mrxx
Votes: 9
Popularity: 0.111794
First Submitted: 2017-12-26 15:31
Last Updated: 2020-05-21 20:19

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

kevincs commented on 2020-02-08 17:19

Works fine on armv7h (Raspberry Pi), the PKGBUILD only lists x86_64. You need to create the ~/.local/share/applications if it doesn't exist or makepkg will fail.

If you want to use it headless on a PI but want to change the biglybt options using the GUI on your computer:

Set up X forwarding : https://wiki.archlinux.org/index.php/OpenSSH#X11_forwarding

SSH into the pi with -Y ; -X didn't work for me (ssh -Y 192.168.1.32)

Since SWT on arch linux arm is compiled for aarch64 and biglybt uses the x86_64 library, you need to either compile it for armv7 or find a compiled library, you can download one from https://rpmfind.net/linux/mageia/distrib/6/armv7hl/media/core/release/eclipse-swt-4.6.3-6.mga6.armv7hl.rpm ; extract the rpm and get the swt.jar file.

Move the swt.jar file to /opt/biglybt/swt/swt-unknown.jar (unknown because uname -p returns unknown for the pi, and biglybt uses uname -p to find the arch).

Install gtk and you can now run biglybt and the GUI will be forwarded.

mrxx commented on 2019-10-07 20:49

Thank you, yochananmarqos. Added the suggested optional dependencies and set java-runtime to >=8.

yochananmarqos commented on 2019-10-07 17:43

This requires JRE8 or higher, please change the dependency to java-runtime>=8.

Please add jna & libappindicator-gtk3 as optional dependencies for tray icon support. See line 35 in the installer script:

    echo "(lib)jna-java is needed to display a status bar icon.  However, BiglyBT will run fine without it."

During installation without jna installed:

jna.jar not found. Without it there will not be a status bar icon. Install with pacman -S jna (Y/n)

jna is in the AUR, so that won't work.

Please also add ttf-dejavu to optional dependencies: See line 54 - 57 in the installer script:

        # Arch Linux with no desktop needs a font for AWT & install4j to run
        if [ "${DESKTOP_SESSION}${XDG_SESSION_DESKTOP}${XDG_CURRENT_DESKTOP}${GDMSESSION}" = "" ]; then
            PKG_JAVA="${PKG_JAVA} ttf-dejavu"
        fi

mrxx commented on 2018-12-12 00:24

Thanks a lot, Det! Typo fixed.

Det commented on 2018-12-12 00:03

Think you didn't mnean it like that? [ "_user_desktop" ]

mrxx commented on 2018-12-11 21:07

Thank you, mexican. I've updated the PKGBUILD to autodetect the name of the 'Desktop' folder in the user's locale.

If someone has an idea how to prevent the java installer to create the two .desktop files in the user's filesystem, please let me know as I'd be more than happy to be able to remove that rm stuff.

mexican commented on 2018-12-11 17:19

Thank you for fixing it!

Trying to install on Manjaro with locale ES_MX gives an error, so I had to edit PKGBUILD line 35:

from "find ~/Desktop -name $pkgname.desktop -cmin -1 -exec rm -f {} +"

to "find ~/Escritorio -name $pkgname.desktop -cmin -1 -exec rm -f {} +"

Is there a way to do this automagically? Great job with this package by the way.

Saludos.

mareke commented on 2018-04-12 15:31

I'm getting error: GitHub_BiglyBT_Installer_1.5.0.0.sh ... FAILED ERROR: One or more files did not pass the validity check!

Det commented on 2018-02-28 23:12

Because it isn't.

mbloms commented on 2018-02-28 23:12

Why don't you simply put java-environment as a makedep?