Package Details: bloop 1.4.5-1

Git Clone URL: https://aur.archlinux.org/bloop.git (read-only, click to copy)
Package Base: bloop
Description: Bloop gives you fast edit/compile/test workflows for Scala.
Upstream URL: https://scalacenter.github.io/bloop/
Keywords: build compilation developer scala server
Licenses: Apache
Submitter: TheElectronWill
Maintainer: TheElectronWill (jvican, bloopoid)
Last Packager: TheElectronWill
Votes: 11
Popularity: 0.037524
First Submitted: 2018-06-25 18:01
Last Updated: 2020-11-06 12:09

Pinned Comments

TheElectronWill commented on 2020-05-19 12:36

This official package no longer includes the systemd service since it may cause issues with Bloop clients (cf. comments on PR #1284). It is now in a separate package bloop-systemd

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

kurnevsky commented on 2020-05-12 10:10

And new version doesn't include systemd service anymore...

mrzeznicki commented on 2020-05-11 22:03

Also, running it fails miserably for me

bloop server 
/usr/bin/bloop: 4: exec: /usr/bin/.bloop.aux: not found

mrzeznicki commented on 2020-05-11 21:27

I think you got sha256 wrong. It's

sha256sum bloop-coursier.json 
1bf5f6b82f13fbccf3bfd75da59113529c95cf62b9249ed47e34e18f32dc410d  bloop-coursier.json

Musikolo commented on 2020-01-13 21:14

@japgolly, I think you should do as follows:

systemctl --user restart bloop

You can find more info at https://scalacenter.github.io/bloop/docs/server-reference

I hope it helps! :-)

japgolly commented on 2020-01-13 20:32

Doesn't work for me. 1) systemctl enable bloop doesn't work (even after daemon-reload); had to find where the unit file was being installed and systemctl enable the full path. 2) Fails to start (via systemd) and says "No such file or directory: 'java'"

02m commented on 2019-12-20 05:43

Needed to clean "yay" cache for "bloop" for the "ERROR: pkgver is not allowed to contain colons, forward slashes, hyphens or whitespace." error to go away.

bloopoid commented on 2019-12-18 22:06

Should be fixed now, thanks for reporting

nichobi commented on 2019-12-18 19:40

The new pkgver "1.4.0-RC1" is invalid due to the hyphen. Getting the following error on install: ==> ERROR: pkgver is not allowed to contain colons, forward slashes, hyphens or whitespace.

TheElectronWill commented on 2019-10-04 22:30

I've updated the PKGBUILD to rename "install.py" to a more unique (and version-dependent) name. This should force the AUR helpers to download the latest file instead of using an outdated one.

TheElectronWill commented on 2019-10-04 05:22

I disagree: https://github.com/scalacenter/bloop/releases/download/v1.3.3/install.py has hash 31da9f6fda0522b2abf6230901b60c77d38bcb215fc8a22c74e1a92f49475bbf.

The hash you've got is the one of Bloop v1.2.5, it looks like you're using old build files.