Package Details: bombono-dvd 1.2.4-4

Git Clone URL: https://aur.archlinux.org/bombono-dvd.git (read-only, click to copy)
Package Base: bombono-dvd
Description: DVD authoring program with nice and clean GUI
Upstream URL: http://www.bombono.org
Licenses: GPL
Conflicts: bombono-dvd-git
Submitter: sirocco
Maintainer: sbmomeni
Last Packager: sbmomeni
Votes: 76
Popularity: 0.000078
First Submitted: 2009-08-22 13:35
Last Updated: 2019-10-12 15:37

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

Holodoc commented on 2013-08-14 08:09

I created a fix for Bombono:

Please download the (original) tarball from this side and extract it. You will see 2 files:
PKGBuild
bombono-dvd.install


Save the following content in the same directory in file it as "fix_ffmpeg_CodecID.patch"
http://pastebin.com/phiXsUct

After that please replace the PKGBUILD with this one:
http://pastebin.com/jRrEFZRc

Now you should be able to build bombono-dvd

@sirocco: Feel free to take over the patch and PKGBUILD

Holodoc commented on 2013-08-11 10:11

Does not compile anymore:
[...]
rc/mgui/ffviewer.cpp:409:32: error: ‘CodecID’ was not declared in this scope
static std::string CodecID2Str(CodecID codec_id)
^
src/mgui/ffviewer.cpp:410:1: error: expected ‘,’ or ‘;’ before ‘{’ token
{
^
src/mgui/ffviewer.cpp: In function ‘bool OpenInfo(FFData&, const char*, FFDiagnosis&)’:
src/mgui/ffviewer.cpp:553:56: error: no match for call to ‘(std::string {aka std::basic_string<char>}) (AVCodecID&)’
std::string tag_str = CodecID2Str(dec->codec_id);
^
scons: *** [build/src/mgui/ffviewer.o] Error 1
scons: building terminated because of errors.


Hope 'outdated' is the correct state!?

javsalgar commented on 2013-01-28 01:51

Still does not work. I get the Glib:FileError problem...

sirocco commented on 2013-01-09 06:50

With gentoo patchset.

cookiecaper commented on 2012-11-26 18:40

The git version is working here, but it kindly asks if it may delete the entire contents of my home directory when I go to generate the disc. I therefore suggest avoiding the package. :)

awagner commented on 2012-11-16 16:50

Over here, the git version compiled fine today, but crashes with some Glib::FileError instance...

sirocco commented on 2012-11-16 02:46

Maybe better to try a git version, but I don't sure.
https://aur.archlinux.org/packages/bombono-dvd-git/

sirocco commented on 2012-11-16 02:38

As I read in Russian, it's upstream problem.
http://forum.bombono.org/viewtopic.php?f=2&t=12477

awagner commented on 2012-11-15 23:28

I got to compile somewhat further by using CPPFLAGS='-DBOOST_FILESYSTEM_VERSION=3' (instead of 2) in the PKGBUILD. However, due to this: http://forum.bombono.org/viewtopic.php?f=1&t=8422 it will not compile anyway.

Anonymous comment on 2012-07-18 05:00

Doesn't compile:

/usr/include/boost/filesystem/config.hpp:16:5: ошибка: #error Compiling Filesystem version 3 file with BOOST_FILESYSTEM_VERSION defined != 3
scons: *** [build/src/mgui/project/mconstructor-main.o] Error 1
scons: building terminated because of errors.