Package Details: cndrvcups-lb 3.70-1

Git Clone URL: https://aur.archlinux.org/cndrvcups-lb.git (read-only)
Package Base: cndrvcups-lb
Description: CUPS Canon UFR II LIPSLX CARPS2 printer driver for LBP iR MF ImageCLASS ImageRUNNER Laser Shot i-SENSYS ImagePRESS ADVANCE printers and copiers
Upstream URL: https://www.canon-europe.com/support/products/imagerunner/imagerunner-1730i.aspx
Keywords: Canon Printer
Licenses: custom
Conflicts: cndrvcups-lb-cpca
Submitter: Lone_Wolf
Maintainer: severach (Lone_Wolf)
Last Packager: severach
Votes: 78
Popularity: 0.002088
First Submitted: 2012-04-22 13:50
Last Updated: 2019-02-18 09:06

Dependencies (10)

Required by (0)

Sources (3)

Pinned Comments

Lone_Wolf commented on 2016-02-24 20:33

i'm not surprised pacaur (and likely any aur helper) has problems building this.

The reason for the versioned dependency on cndrvcups-common-lb is that a cndrvcups-lb version ONLY works with 1 specific cndrvcups-common-lb version .

The correct way to build them goes like this :

build new cndrvcups-common-lb
remove old cndrvcups-lb version (if present on system)
install new cndrcups-common-lb
build & install new cndrvcups-lb version

Easiest way to build this with pacaur : use 2 commands like this :
pacaur -S cndrvcups-common-lb
pacaur -S cndrvcups-lb

Lone_Wolf commented on 2012-04-22 13:54

New package for v 2.40 uploaded, switch to https://aur.archlinux.org/packages.php?ID=58701 .

Lone_Wolf commented on 2012-04-22 13:54

New package for v 2.40 uploaded, switch to https://aur.archlinux.org/packages.php?ID=58701 .

Lone_Wolf commented on 2012-04-22 13:53

package was tested by Holger Jahn using a Canon MF 4100 .
Thanks, Holger.

NOTE : x86_64 only for now.
If you use a 32-bit install and are willing to help, contact me by email.

Lone_Wolf commented on 2012-04-13 17:57

I am working on a new cndrv-lb package, and have found someone with a printer using this driver that is willing to test things.
The new package is based on the rpm spec file, as canon appears to spends most time on making that working.
A lot of things had to be adapted to the archlinux environment.

veggiemonster, thanks for your remarks, if you wish to help with testing send me an email.
(you can find my email in 1 of my uptodate aur packages).




Anonymous comment on 2012-04-13 15:16

I installed the cndrvcups-common-2.40 from AUR. Then I modified thi PKGBUILD to use the 2.40 version. I tested both on x86_64 and i686, both on usb connection and ldp network connection. No hope! I also tested with 2.30 package in AUR and I got the same result:

On x86_64: First it was complaining about the FreeType fonts which apparantly a bug which has been introduced with new release (2.4.9) of FreeType:

MF4150_Net-22 Unknown Withheld 1k Unknown completed at
Mon Apr 9 04:25:44 2012
"src = libcanon_pdlwrapper.c, line = 514, err = 0¥nGPL Ghostscript 9.05: Error: Font Renderer Plugin ( FreeType ) return code = -1"

That can be solved either by upgrading to ghostscript-svn or by downgrading FreeType to 2.4.8 and now the message is persistently is:

MF4150_Net_ppd-33 Unknown Withheld 1k Unknown completed at
Mon Apr 9 12:56:12 2012
"src = libcanon_pdlwrapper.c, line = 514, err = 0¥nError Response:ReqNo=2, SeqNo=3,opvpErrorNo=-2"

For i686, if I force it on the x86_64 machine I'll get the same result. If I installed on a i686 machine, in lpd network case, it says completed successfully while no data is transfered to the printer. In usb case, no data is sent to the printer, job status is "processing" for ever.

It's sad because on my partner's ubuntu machine I can install the network printer in a fraction of a minute and everything goes as smooth and easy as ice-cream.

Anonymous comment on 2012-04-02 20:26

You can get the latest package here.

http://support-au.canon.com.au/contents/AU/EN/0100270808.html

Anonymous comment on 2012-03-01 12:39

Are anybody going to do something?

PLEASE!!! UPDATE PACKAGE!

Lone_Wolf commented on 2012-01-28 23:23

adopted, looking into updating to v 2.40

Lone_Wolf commented on 2012-01-28 22:47

Adopted, will look into updating this to latest version.

Anonymous comment on 2011-11-19 18:24

PKGBUILD draft for 2.30: http://pastebin.com/VmG8Zu2D
DOES NOT COMPILE!
Is there anyone who is capable of understanding what's going on there?