Package Details: code-git 1.16.0.r25714.g2328356959-1

Git Clone URL: https://aur.archlinux.org/code-git.git (read-only)
Package Base: code-git
Description: The Open Source build of Visual Studio Code (vscode) editor - git latest
Upstream URL: https://github.com/Microsoft/vscode
Keywords: vscode
Licenses: MIT
Conflicts: visual-studio-code-git
Provides: visual-studio-code-git
Submitter: Zrax
Maintainer: Zrax
Last Packager: Zrax
Votes: 14
Popularity: 0.047785
First Submitted: 2017-12-18 23:10
Last Updated: 2019-04-25 22:53

Latest Comments

1 2 3 4 Next › Last »

bparsons commented on 2019-04-19 12:56

Upstream currently lists Node.JS, x64, version >= 10.15.1, < 11.0.0 in requirements. (https://github.com/Microsoft/vscode/wiki/How-to-Contribute#build-and-run)

I have been building this with nodejs-lts-dubnium as a dependency instead of nodejs-lts-carbon.

bilabila commented on 2019-04-14 08:41

Hi, I don't know why using two spaces in "Code - OSS" in product.json.

Zrax commented on 2019-04-01 04:23

@ShayBox: You'll need to convince Microsoft to make it buildable with nodejs 10.x -- currently it isn't, which is why we require building with 8.x (carbon). However, once its built, you can always go back to the normal nodejs package, so you might consider building code in a VM or chroot, if you can't on your host system.

ShayBox commented on 2019-03-31 23:23

I realize both code and code-git do this but I can't comment on code: Using nodejs-lts-carbon prevents me from installing this, it requires me replacing nodejs which would also uninstall/break a ton of packages I have installed that depend on nodejs, Either use or allow nodejs somehow, can not make this.

darkbasic commented on 2019-03-06 16:07

The build fails with the following error:

[17:05:01] Starting compile-build ... [17:05:01] Finished compile-build after 0 ms [17:05:01] Starting optimize-vscode ... [17:05:01] 'vscode-linux-x64-min' errored after 2.18 min [17:05:01] out-build/vs/workbench/services/files/node/remoteFileService.js:542 return super.updateContent(target, content.value, { encoding: content.encoding }); ^^^^^

SyntaxError: 'super' keyword unexpected here at NodeScriptLoader._loadAndEvalScript (evalmachine.<anonymous>:801:26) at evalmachine.<anonymous>:780:31 at FSReqWrap.readFileAfterClose [as oncomplete] (fs.js:511:3)

NOTE: If the build failed due to running out of file handles (EMFILE), you will need to raise your max open file limit. You can check this for more information on how to increase this limit: https://ro-che.info/articles/2017-03-26-increase-open-files-limit

bbx0 commented on 2019-01-25 16:22

The build failed for me without having 'python' installed. Please can you add 'python' to the makedepends? (python2 does not provide /usr/bin/python)

Error: /bin/sh: python: command not found

armin-mdl commented on 2019-01-12 08:52

nodejs with nodejs-lts-carbon conflicts...correct them...thanks.

Unrealrussian commented on 2018-11-07 09:52

The product_json.patch does not match with the one from master branch in Microsoft/vscode (Possible merge with other branch)

thepeko commented on 2018-10-10 15:03

@Vmeup MS Code uses as prerequisit for building Node.JS, >= 8.9.1, < 9.0.0 see https://github.com/Microsoft/vscode/wiki/How-to-Contribute#build-and-run

Vmeup commented on 2018-10-03 19:35

I have run into an installation problem where initially my installed version of Node was 10.x, so I reverted the package to Node 9.x. When trying to Install after reverting Node, I run into an issue of

'node: error while loading shared libraries: libicui18n.so.61: cannot open shared object file: No such file or directory'

Looking into my system I currently have libicui18n.so.62.1 installed... Is there a workaround for this to build MS Code? Or is it safe to revert the libicu18n package to 61 without breaking dependencies for other system funcitons?

Thanks