Package Details: etherpad-lite 1:1.6.1-1

Git Clone URL: https://aur.archlinux.org/etherpad-lite.git (read-only)
Package Base: etherpad-lite
Description: Lightweight fork of etherpad based on javascript
Upstream URL: http://etherpad.org
Licenses: GPL2
Conflicts: etherpad-lite-git
Submitter: onny
Maintainer: RubenKelevra
Last Packager: RubenKelevra
Votes: 24
Popularity: 0.077872
First Submitted: 2013-03-15 15:10
Last Updated: 2016-12-24 19:00

Latest Comments

dvzrv commented on 2017-11-04 19:55

@RubenKelevra: I have been maintaining my private PKGBUILD for this package, as I don't like the way it is packaged in /usr/share/webapps and how it is forcefully deleting files during .install and still leaves random files behind in its install directory after removal.
I found a way to facilitate systemd's DynamicUser (with StateDirectory since systemd>235) to create a static version of this package, that doesn't call run.sh (and by proxy installDeps.sh) constantly [1], which means, it doesn't create files unaccounted for (with the downside, that you can also not install plugins so easily).
For security and practicality reasons I'd like you to consider the attached PKGBUILD, which could be a good starting point to fix some issue with yours.

[1] https://github.com/ether/etherpad-lite/issues/3274#issuecomment-341924367

RubenKelevra commented on 2017-02-08 22:43

@sofchanger you can ignore this warning.

sofchanger commented on 2017-01-20 20:01

Hi, after installation, shows me this:

:: Processing package changes...
(1/1) installing etherpad-lite [############] 100%
useradd: warning: the home directory already exists.
Not copying any file from skel directory into it.

Whats happends? I not launch etherpad-lite. Please, help me! Thanks!

RubenKelevra commented on 2016-12-24 19:01

Update 1.6.1 is out, package was just updated. Merry x-mas :)

RubenKelevra commented on 2016-12-21 17:30

Good news, etherpad-lite is close to a new fixing release 1.6.1 which makes the issues obsolete :)

RubenKelevra commented on 2016-12-19 04:42

I'm sorry this package is currently not possible to build or run with all updates installed. You would need to downgrade nodejs and the dependency icu, which then breaks Pacman.

I've added a ticket to the project, until this bug is not fixed, I cannot provide a solution.

https://github.com/ether/etherpad-lite/issues/3100

If somebody has another solution I would be grateful!

schimicata commented on 2016-12-02 13:00

For sudo -u etherpad /usr/share/webapps/etherpad-lite/bin/run.sh I'll get following errors and etherpad doesn't start up.

http://pastebin.com/nT1Xc5EU

RubenKelevra commented on 2016-12-01 20:27

Just to be clear, on this update, the warnings might still appear, because the checks are done previously before upgrading.

smithinger44 commented on 2016-11-26 23:05

npm returns so many warnings during installation:
http://pastebin.com/bsCt4bJQ

PetaByteBoy commented on 2016-11-11 08:57

@RubenKelevra compatibility issues with nodejs >= 7.0
https://github.com/ether/etherpad-lite/issues/3074

All comments