Package Details: fdroidserver-git r4975.00811088-1

Git Clone URL: https://aur.archlinux.org/fdroidserver-git.git (read-only)
Package Base: fdroidserver-git
Description: F-Droid repository management tools
Upstream URL: https://gitlab.com/fdroid/fdroidserver
Licenses: GPL3
Conflicts: fdroidserver
Provides: fdroidserver
Submitter: prurigro
Maintainer: dlandau
Last Packager: dlandau
Votes: 9
Popularity: 0.117917
First Submitted: 2013-05-27 11:20
Last Updated: 2018-02-22 14:02

Dependencies (29)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

dlandau commented on 2014-11-23 09:05

Updated

Argus commented on 2014-11-22 19:25

The current version has the following two new dependencies: python2-pyasn1, python2-pyasn1-modules.

These modules are now included in update.py and 'fdroid update' won't work without them.

dlandau commented on 2014-11-09 17:11

Fixed, thanks!

neroburner commented on 2014-11-08 09:50

build fails on my PC (64bit)
/tmp/yaourt-tmp-username/aur-fdroidserver-git/./PKGBUILD: line 51: cd: fdroidserver/getsig: No such file or directory

dlandau commented on 2014-07-22 14:29

Updated as per https://github.com/daniellandau/AUR-fdroidserver-git/pull/1.

dlandau commented on 2014-06-27 10:23

Thanks @mvdan for suggestions, updated.

I only use this package to host a single user binary repo, so I am not always that well informed on what is needed/optional for what.

I set up a git repo for the PKGBUILD at https://github.com/daniellandau/AUR-fdroidserver-git, feel free to submit pull requests there or submit patches here (or just plain comments as this time are fine too).

mvdan commented on 2014-06-26 21:03

I forgot more stuff:

* Why is android-sdk-build-tools a dependency but android-sdk an optional dependency? Doesn't the former depend on the latter? I think they could both go to optdepends, since some bits of fdroidserver can be used without any of them.

* Then java-runtime also falls under optdepends, since it's only used for the getsig.java bit. And that's only needed when running a repository or when building apps and needing the JDK.

* android-sdk-platform-tools should also be in optdepends, the new command "fdroid install" uses adb.

* android-support-repository (also in the AUR) should be an optdepend since it's needed in most Maven and Gradle builds.

Thanks again for maintaining this!

mvdan commented on 2014-06-26 20:58

Hello again @dlandau!

Just a few comments to help get the PKGBUILD up to date:

* We moved to gitlab, so the repo is now at https://gitlab.com/fdroid/fdroidserver.git

* It would also be cool if you used https: instead of git: since it's encrypted (not sure what's the PKGBUILD standard on that, I guess the .git at the end is enough to let it know it's a git repo)

* Why isn't apache-ant one of the optdepends? It's at the same level as maven and gradle.

It would also be great if we could add explanations to each optdepend. For example, apache-ant could have something like "Support building apps that use Apache Ant". I can help with that - when is the AUR supposed to start using Git?

dlandau commented on 2014-05-17 08:44

That seems to have changed in upstream commit a31f4571. Thanks for letting me know!

Nidhogg commented on 2014-05-07 20:17

On line 53, I think it should be "examples/config.py", not "sampleconfigs/config.py"

Having "sampleconfigs/config.py" fails with a No such file or directory error.