Package Details: flutter 3.22.2-1

Git Clone URL: https://aur.archlinux.org/flutter.git (read-only, click to copy)
Package Base: flutter
Description: Flutter SDK component - full installation of development tool and runtime
Upstream URL: https://flutter.dev
Keywords: android fuchsia ios mobile sdk
Licenses: custom, BSD, CCPL
Groups: flutter
Conflicts: flutter
Submitter: flipflop97
Maintainer: WithTheBraid
Last Packager: WithTheBraid
Votes: 135
Popularity: 4.91
First Submitted: 2017-06-05 21:03 (UTC)
Last Updated: 2024-06-12 09:02 (UTC)

Pinned Comments

WithTheBraid commented on 2024-03-28 00:44 (UTC) (edited on 2024-05-10 11:44 (UTC) by WithTheBraid)

TL;DR

Upgrade using aur/yay might take very long and works inefficiently.

Upgrade using aur/paru requires the -d flag.

This is not my fault.


Note to the lovers of AUR helpers : It looks like dependency resolution is a complex topic. Despite all package relations being properly declared in the Flutter packages, most AUR helpers seem to have trouble resolving the dependency chain between the package bases aur/flutter and aur/flutter-artifacts-google-bin. This is not my fault and I cannot do anything about it.

It looks like the initial installation works fine using aur/paru. Sadly aur/paru does not reach at building updates for the package without additional flags. Please use paru -Syud (whereas the -d is the relevant flag) to upgrade the package.

On the other hand aur/yay properly reaches at both installing and updating this package, even though it builds the package 15 times (!!!) again and again.

If you use aur/paru, consider to simply execute pacman -R flutter && pacman -Rns flutter to clean up the previous installation of both package bases.

If you build both package bases using makepkg -sfC and later on install all build outputs using pacman -U, both the installation and the updates work like a charm.

I'm very sorry for the inconvenience, but sadly there's nothing I can do about this.

WithTheBraid commented on 2024-03-25 20:55 (UTC) (edited on 2024-05-10 11:45 (UTC) by WithTheBraid)

Huge update to the Flutter AUR package :

The previous implementation basically did a user installation of Flutter - downloaded the custom Dart SDK, CI artifacts from Chromium CI and had to be kept in user R/W access in order to have the Flutter Cache Manager working.

These times are now over - a clean and (almost) completely rewritten PKGBUILD which now uses clean dependency declarations, system Dart and Gradle and for sure no more user R/W installation directory.

This AUR entry is now a split package. Installing aur/flutter will still bundle the entire toolchain you knew from before. The other way round, if you don't need everything - e.g. when depending on Flutter as a build dependency in another package, you can choose to only depend on what you need.

The following split packages are available :

  • flutter : meta package containing all other split packages

  • flutter-common : the common files for Flutter needed for all use cases

  • flutter-devel : your option of choice as a developer - ships the Flutter tool and all required templates to e.g. create a new project

  • flutter-tool : The pure Flutter tool. Use as depends to build your package.

  • flutter-target-linux : The Flutter Linux build files. Use as depends to build your package.

  • flutter-target-web : The Flutter web build files. Use as depends to build web apps (e.g. fluffychat-web does this).

  • flutter-target-android : The Flutter Android build files. Use if you want to develop Android apps.

  • flutter-gradle : The Flutter Gradle wrapper. Populated from system Gradle.

  • flutter-intellij-patch : a tiny patch to make the IntelliJ Flutter plugin work with the new package.

  • flutter-material-fonts-google-bin : Mandatory fonts package, planned to have a system-installed drop-in replacement soon.

  • flutter-engine-common-google-bin : Shared part of the Flutter engine - downloaded from Google servers.

  • flutter-sky-engine-google-bin : Flutter sky engine - downloaded from Google servers.

  • flutter-engine-linux-google-bin : Linux part of the Flutter engine - downloaded from Google servers.

  • flutter-engine-web-google-bin : Web part of the Flutter engine - downloaded from Google servers.

  • flutter-engine-android-google-bin : Android part of the Flutter engine - downloaded from Google servers.

  • flutter-gradle-google-bin : The Flutter Gradle wrapper - downloaded from Google servers.

  • flutter-dart-google-bin : The Flutter original Dart SDK - downloaded from Google servers. This is helpful if the extra/dart package is not available in the right version on your distro or remix.

Stay tuned for non google-bin versions of the engine, they are in coming !

Since almost everything is written from scratch and heavy patches are applied to use the system packages as dependencies, there might still be bugs occurring. Please report them otherwise I can't fix them !

Latest Comments

1 2 3 4 5 6 .. 24 Next › Last »

ZhangHua commented on 2024-06-05 12:34 (UTC)

Please note that if you want to use extra/dart to build package which requires flutter SDK, you need to set FLUTTER_ROOT=/usr/lib/flutter or dart cannot find proper flutter SDK. You can try to build spotube without FLUTTER_ROOT set to prove this.

xiota commented on 2024-06-04 09:34 (UTC) (edited on 2024-06-04 09:35 (UTC) by xiota)

Is there something wrong with the dependencies?

@raevn They're too complicated. Read the pinned comments.

Also look through previous comments. If there are recent reports of errors (not confusion about depends), you may want to postpone building until the next update.

Since this package was updated a week ago, it should still be working.

raevn commented on 2024-06-04 09:12 (UTC)

$ pikaur -S flutter Reading repository package databases... Reading local package database... Resolving AUR dependencies... :: error: Can't resolve dependencies for AUR package 'flutter-target-android': :: error: Dependencies missing for flutter-target-android :: warning: Following package cannot be found in AUR: flutter-engine-android
:: Try recovering flutter-target-android? [e] edit PKGBUILD [f] skip 'check()' function of PKGBUILD [s] skip this package [A] abort

Is there something wrong with the dependencies?

xuiqzy commented on 2024-05-17 17:08 (UTC)

@WithTheBraid Hmm, neither paru, nor yay suggested to fulfill the dart dependency with aur/flutter-dart-google-bin, even when dart was too old and dart-sdk-dev was too new. Should it know that or does that only show up after building the package?

Bitals commented on 2024-05-17 13:05 (UTC) (edited on 2024-05-18 20:03 (UTC) by Bitals)

I have built the latest release against flutter-dart-google-bin and encountered ERROR: Target kernel_snapshot failed: Exception again.

WithTheBraid commented on 2024-05-17 06:06 (UTC)

@xuiqzy The extra/dart package was bumped to 3.4.0 yesterday, see https://gitlab.archlinux.org/archlinux/packaging/packages/dart/-/commit/3f50d2346959602f63f9c2bd03ac0f454a5cf297 . Additionally, the aur/flutter-dart-google-bin package provides you with exactly the binary Dart version google ships for aur/flutter-artifacts-google-bin in cases your mirrored Dart version (or your distro's Dart version) did not sync with the bump yet.

xuiqzy commented on 2024-05-17 00:46 (UTC)

Neither dart from repos nor dart-sdk-dev is fulfilling the dart dependency currently because the dart max version is exclusive, so 3.5 is not included. The dart min version is inclusive so works with >= 3.4 (but dart is on 3.3), is that intentional or should the dart max version constraint also be inclusive, i.e. <=?

leo72 commented on 2024-05-12 17:08 (UTC)

Apart from all the package conflict problems that come up, the basic problem is that every time the Flutter package is updated, a series of conflicts between different things starts again, from messages about kernel errors, package conflicts etc. There was no exit, in my opinion, so I finally decided to remove the package and solved all of my problems by installing Flutter from Snap, following this guide:

https://ubuntu.com/blog/getting-started-with-flutter-on-ubuntu

Now, EVERYTHING works like a charme

LordPax commented on 2024-05-11 22:16 (UTC)

if it still doesn't work, you can install it from the get started page of flutter : https://docs.flutter.dev/get-started/install/linux/android?tab=download

CorvetteCole commented on 2024-05-10 05:48 (UTC)

fwiw I think this is a very positive change to this package and am happy to see it. Thanks for your work!