Package Details: tachidesk-sorayomi 0.3.5-1

Git Clone URL: https://aur.archlinux.org/tachidesk-sorayomi.git (read-only, click to copy)
Package Base: tachidesk-sorayomi
Description: A free and open source manga reader to read manga from a Tachidesk-Server instance
Upstream URL: https://github.com/Suwayomi/Tachidesk-Sorayomi
Licenses: MPL2
Submitter: mahor1221
Maintainer: mahor1221 (padya1201)
Last Packager: mahor1221
Votes: 2
Popularity: 0.006577
First Submitted: 2022-03-09 10:19 (UTC)
Last Updated: 2023-01-20 16:52 (UTC)

Pinned Comments

Bitals commented on 2022-04-20 18:09 (UTC) (edited on 2022-04-20 19:00 (UTC) by Bitals)

Seems like flutter uses git under the hood to find out its own version, and git didn't like that /opt/flutter was owned by root. So in addition to adding yourself to flutterusers group one also needs to run

git config --global --add safe.directory /opt/flutter

after installing flutter-beta, or just build as root (not the best idea).

And clang needs to be mentioned as a make-dependency too, my docker environment didn't have it and failed. Though clang is just the default for cmake with standard config, I guess llvm or other C/C++ compiler should be fine. Not sure if PKGBUILD supports multiple options for dependencies and if it's not a cmake problem.

All good after that anyway.

mahor1221 commented on 2022-03-09 10:58 (UTC) (edited on 2022-03-09 11:05 (UTC) by mahor1221)

If you are getting permission errors when making this package like:

mkdir: cannot create directory '/opt/flutter/bin/cache': Permission denied

Add your user into the group flutterusers then relogin:

sudo usermod -aG flutterusers <user>

It's explained at the end of flutter AUR package installation: https://aur.archlinux.org/packages/flutter

Latest Comments

mahor1221 commented on 2022-07-20 02:43 (UTC)

@intrnl Thanks for the feedback. xdg-user-dirs has been added to the dependencies.

intrnl commented on 2022-07-18 00:54 (UTC)

Sorayomi crashes if xdg-user-dirs isn't installed.

Bitals commented on 2022-04-20 18:09 (UTC) (edited on 2022-04-20 19:00 (UTC) by Bitals)

Seems like flutter uses git under the hood to find out its own version, and git didn't like that /opt/flutter was owned by root. So in addition to adding yourself to flutterusers group one also needs to run

git config --global --add safe.directory /opt/flutter

after installing flutter-beta, or just build as root (not the best idea).

And clang needs to be mentioned as a make-dependency too, my docker environment didn't have it and failed. Though clang is just the default for cmake with standard config, I guess llvm or other C/C++ compiler should be fine. Not sure if PKGBUILD supports multiple options for dependencies and if it's not a cmake problem.

All good after that anyway.

Bitals commented on 2022-04-20 17:26 (UTC)

@mahor1221 yup, already tried locally, still the same. Pretty sure cmake and ninja already were in both of our environments as dependencies for something else anyway, they are used very widely. If somebody else needs info: https://github.com/Suwayomi/Tachidesk-Sorayomi/issues/61

mahor1221 commented on 2022-04-20 17:21 (UTC) (edited on 2022-04-20 17:35 (UTC) by mahor1221)

@Bitals thanks for the feedback. I've added cmake and ninja according to the upstream developer. Could you check if the problem still persist

About the flutter-beta package. mine works fine though. I can't reproduce the error or the version number of 0:

$ flutter --version
Flutter 2.11.0-0.1.pre • channel beta • https://github.com/flutter/flutter.git
Framework • revision b101bfe32f (9 weeks ago) • 2022-02-16 07:36:54 -0800
Engine • revision e355993572
Tools • Dart 2.17.0 (build 2.17.0-69.2.beta) • DevTools 2.10.0-dev.1

Bitals commented on 2022-04-20 09:16 (UTC) (edited on 2022-04-20 12:23 (UTC) by Bitals)

NVM again, flutter-beta is an explicit dependency of this package. It reports a version number of 0, which screws flutter dependency resolution. With flutter (stable):

ERR : Because every version of flutter_test from sdk depends on path 1.8.0 and tachidesk_sorayomi depends on path ^1.8.1, flutter_test from sdk is forbidden.
12:21:28     | So, because tachidesk_sorayomi depends on flutter_test from sdk, version solving failed.

Bitals commented on 2022-04-20 01:04 (UTC)

Nvm my stupidness, unprovisioned script built flutter-beta instead of stable.

Bitals commented on 2022-04-19 23:48 (UTC)

I get a flutter dependency error while building:

23:46:12     | Because scrollable_positioned_list 0.2.3 requires Flutter SDK version >=1.13.8 and no versions of scrollable_positioned_list match >0.2.3 <0.3.0, scrollable_positioned_list ^0.2.3 is forbidden.
23:46:12     | So, because tachidesk_sorayomi depends on scrollable_positioned_list ^0.2.3, version solving failed.
23:46:12 FINE: Exception type: SolveFailure
23:46:12 FINE: package:pub/src/solver/version_solver.dart 311:5               VersionSolver._resolveConflict
23:46:12     | package:pub/src/solver/version_solver.dart 132:27              VersionSolver._propagate
23:46:12     | package:pub/src/solver/version_solver.dart 96:11               VersionSolver.solve.<fn>
23:46:12     | ===== asynchronous gap ===========================
23:46:12     | dart:async                                                     Future.catchError
23:46:12     | package:pub/src/utils.dart 109:52                              captureErrors.wrappedCallback
23:46:12     | package:stack_trace                                            Chain.capture
23:46:12     | package:pub/src/utils.dart 122:11                              captureErrors
23:46:12     | package:pub/src/command.dart 183:13                            PubCommand.run
23:46:12     | package:args/command_runner.dart 209:27                        CommandRunner.runCommand
23:46:12     | package:pub/src/command_runner.dart 174:24                     PubCommandRunner.runCommand
23:46:12     | package:pub/src/command_runner.dart 159:20                     PubCommandRunner.run
23:46:12     | package:dartdev/dartdev.dart 45:56                             runDartdev
23:46:12     | /b/s/w/ir/cache/builder/sdk/pkg/dartdev/bin/dartdev.dart 11:9  main
23:46:12 ---- End log transcript ----

mahor1221 commented on 2022-03-09 10:58 (UTC) (edited on 2022-03-09 11:05 (UTC) by mahor1221)

If you are getting permission errors when making this package like:

mkdir: cannot create directory '/opt/flutter/bin/cache': Permission denied

Add your user into the group flutterusers then relogin:

sudo usermod -aG flutterusers <user>

It's explained at the end of flutter AUR package installation: https://aur.archlinux.org/packages/flutter