Package Details: freecad-git 2:0.18.r2576.g953b802f83-1

Git Clone URL: https://aur.archlinux.org/freecad-git.git (read-only)
Package Base: freecad-git
Description: A general purpose 3D CAD modeler - git checkout
Upstream URL: https://www.freecadweb.org/
Licenses: LGPL
Conflicts: freecad
Provides: freecad
Submitter: gborzi
Maintainer: greyltc (lonaowna)
Last Packager: lonaowna
Votes: 89
Popularity: 0.96
First Submitted: 2012-03-03 13:46
Last Updated: 2019-11-04 14:26

Latest Comments

« First ‹ Previous ... 24 25 26 27 28 29 30 31 32 33 34 ... Next › Last »

gborzi commented on 2011-04-30 21:37

Thanks for your comment Dinosaw, I've corrected the typo.

Anonymous comment on 2011-04-30 21:30

there is a stray "²" near the beginning where it checks svn revisions.

gborzi commented on 2011-04-30 13:35

The gcc 4.6.0 compilation problem has been fixed upstream (since 4465), so now it compiles cleanly. I've added libspnav to deps.

gborzi commented on 2011-04-29 14:13

Hi jwhendy,
I suspect this error comes from the recent gcc update. I had a similar problem with qt3 while compiling kdar.

jwhendy commented on 2011-04-29 02:00

Getting build errors:
,---
| /tmp/yaourt-tmp.../src/freecad-build/src/Gui/.libs/libFreeCADGui.so: undefined reference to `Gui::qInitResources_translation()'
| /tmp/yaourt-tmp.../src/Gui/.libs/libFreeCADGui.so: undefined reference to `Gui::qInitResources_resource()'
| /tmp/yaourt-tmp.../src/freecad-build/src/Gui/.libs/libFreeCADGui.so: undefined reference to `Gui::qt_x11_wait_for_window_manager(QWidget*)
`---

If this isn't sufficient here's more: http://pastebin.com/sp77WfC1

gborzi commented on 2011-04-13 16:49

Updated to rev. 4411 and fixed by removing several no longer needed fixes.

gborzi commented on 2011-04-13 08:59

Hi Archimage,
which is the svn version that is broken? Currently it is at 4409. I'll look into the problem ASAP.

Anonymous comment on 2011-04-13 01:06

Hi gborzi, I think the package is broken due to a recent update

jwhendy commented on 2011-04-09 17:26

Confirmed -- was broken (no side window for solid modeling), and now it's all good.

Anonymous comment on 2011-04-09 00:39

Thank you gborzi, it's working fine !