Package Details: gazebo 10.1.0-4

Git Clone URL: https://aur.archlinux.org/gazebo.git (read-only, click to copy)
Package Base: gazebo
Description: A multi-robot simulator for outdoor environments
Upstream URL: http://gazebosim.org/
Licenses: Apache
Submitter: None
Maintainer: billypilgrim
Last Packager: billypilgrim
Votes: 28
Popularity: 0.45
First Submitted: 2008-10-18 22:59
Last Updated: 2020-01-16 12:11

Dependencies (33)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

acxz commented on 2019-12-24 12:52

@greghab Can I ask what AUR helper you are using? In my experience quite a few AUR helpers do not properly handle dependencies, esp. considering this package. I have found success with yay. E.g. I can just do yay -Syu gazebo and the issues you mentioned do not appear for me. I know some users have had some trouble with trizen and aurutils in the past. My recommendation would be to use yay or to create a PR for whatever AUR helper you are using which fixes their dependency management.

greghab commented on 2019-12-24 11:46

Some changes need to be made: sdformat-6 ignition-math-4 ignition-transport-4 ignition-common-1 ignition-fuel_tools-1 ignition-msgs-1

These are no longer package versions, but separate packages in themselves.

You're also going to make the above changes to each package gazebo requires (the one's listed above), and one later dependency requires the change 'ignition-cmake-0'.

Update...: Looking at the current pkgbuild, it appears that it should be installing the above correct packages as is (I.E ignition-math-4), but for some reason I had to explicitly state them in all pkgbuilds otherwise it couldn't find the dependencies. IDK.

I'll leave this here if others are having issues, otherwise if its not corroborated ignore this.

julianoes commented on 2019-12-24 10:20

I ran into a new error today while doing yay -Sy --rebuildtree gazebo:

AutoMoc subprocess error
------------------------
The moc process failed to compile
  "SRC:/plugins/CessnaGUIPlugin.hh"
into
  "SRC:/build/plugins/CessnaGUIPlugin_autogen/EWIEGA46WW/moc_CessnaGUIPlugin.cpp"

Command
-------
/usr/bin/moc -DBOOST_ALL_NO_LIB -DBOOST_DATE_TIME_DYN_LINK -DBOOST_FILESYSTEM_DYN_LINK -DBOOST_IOSTREAMS_DYN_LINK -DBOOST_PROGRAM_OPTIONS_DYN_LINK -DBOOST_REGEX_DYN_LINK -DBOOST_SYSTEM_DYN_LINK -DBOOST_THREAD_DYN_LINK -DCessnaGUIPlugin_EXPORTS -DHAVE_OPENGL -DLIBBULLET_VERSION=0.0 -DQT_CORE_LIB -DQT_GUI_LIB -DQT_NO_DEBUG "-DQT_TESTCASE_BUILDDIR=\"/home/julianoes/.cache/yay/gazebo/src/gazebo-10.1.0/build\"" -DQT_TESTLIB_LIB -DQT_WIDGETS_LIB -I/home/julianoes/.cache/yay/gazebo/src/gazebo-10.1.0/test/gtest/include -I/home/julianoes/.cache/yay/gazebo/src/gazebo-10.1.0/build -I/usr/include/libusb-1.0 -I/home/julianoes/.cache/yay/gazebo/src/gazebo-10.1.0 -I/usr/include/ignition/msgs1 -I/usr/include/ignition/transport4 -I/usr/include/ignition/fuel_tools1 -I/usr/include/ignition/common1 -I/usr/include/ignition/math4 -I/usr/include/sdformat-6.2 -I/usr/include/OGRE/RTShaderSystem -I/usr/include/OGRE -I/usr/include/OGRE/Terrain -I/usr/include/OGRE/Paging -I/usr/include/OGRE/Overlay -I/usr/include/qt -I/usr/include/qt/QtCore -I/usr/lib/qt/mkspecs/linux-g++ -I/usr/include/uuid -I/usr/include/qt/QtWidgets -I/usr/include/qt/QtGui -I/usr/include/qt/QtTest -I/usr/include -I/usr/include/c++/9.2.0 -I/usr/include/c++/9.2.0/x86_64-pc-linux-gnu -I/usr/include/c++/9.2.0/backward -I/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/include -I/usr/local/include -I/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/include-fixed --include /home/julianoes/.cache/yay/gazebo/src/gazebo-10.1.0/build/plugins/CessnaGUIPlugin_autogen/moc_predefs.h -p plugins -o /home/julianoes/.cache/yay/gazebo/src/gazebo-10.1.0/build/plugins/CessnaGUIPlugin_autogen/EWIEGA46WW/moc_CessnaGUIPlugin.cpp /home/julianoes/.cache/yay/gazebo/src/gazebo-10.1.0/plugins/CessnaGUIPlugin.hh

Output
------
usr/include/tbb/tbb_profiling.:28: Parse error at "{"

make[2]: *** [plugins/CMakeFiles/CessnaGUIPlugin_autogen.dir/build.make:58: plugins/CMakeFiles/CessnaGUIPlugin_autogen] Error 1
make[1]: *** [CMakeFiles/Makefile2:8558: plugins/CMakeFiles/CessnaGUIPlugin_autogen.dir/all] Error 2

I have no idea how to debug this, any hints?

acxz commented on 2019-12-18 04:33

@lucasmazz what is the output of yay -Ss ignition-msgs and yay -Ss ignition-transport?

Maybe try uninstalling all of the ignition-* deps of gazebo and then do a clean build of gazebo via yay?

acxz commented on 2019-12-18 04:29

@billypilgrim Ayy you added the versioned deps for the ign* pacakges! Thx so much!

lucasmazz commented on 2019-12-17 22:09

Hi, I'm getting this error when I try to install gazebo from yay:

-- BUILD ERRORS: These must be resolved before compiling.
--      Missing: Ignition msgs1 library (libignition-msgs-dev).
--      Missing: Ignition Transport (libignition-transport4-dev)
-- END BUILD ERRORS

But I've already installed those libs.

leuko commented on 2019-11-30 08:35

graphviz is an additional dependency. Gazebo requires libcdt.so.5

MaEtUgR commented on 2019-10-25 03:05

The maintainer over at ignition-cmake @acxz reminded me in https://aur.archlinux.org/packages/ignition-cmake/#comment-713109 that ignition-cmake is not required for gazebo. Still in the PKGBUILD file of this AUR there's the line makedepends=('cmake' 'doxygen' 'ignition-cmake'). I just wanted to give a hint since this dependency might not be necessary (I didn't test it).

MaEtUgR commented on 2019-10-23 14:51

@acxz fixed the issue by some changes in the igntion-cmake AUR. Thanks again! More info see https://aur.archlinux.org/packages/ignition-cmake/#comment-712301

MaEtUgR commented on 2019-10-17 09:43

Thanks for all the answers, the nproc one is a nice hint, I was used to grepping /proc/cpuinfo since it works even without that binary e.g. on Android CLI.

I still have the issue on latest Manjaro fresh install: yay -S gazebo --noconfirm fails with

[ 47%] Built target component_deps_RelWithDebInfo
[ 47%] Performing test step for 'component_deps_Release'
[ 47%] Completed 'component_deps_Release'
[ 47%] Built target component_deps_Release
make: *** [Makefile:141: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
Error making: ignition-cmake

I am totally aware that adjusting the PKGBUILD is a hack but I don't know any way of telling CMake to disable build testing for ignition-cmake (-DBUILD_TESTING=OFF) from the file /etc/makepkg.conf. Setting the environmental variable BUILD_TESTING=OFF in the configuration doesn't help. It doesn't belong into any of CFLAGS/CXXFLAGS/LDFLAGS according to my understanding and also in the linked (wiki)[https://wiki.archlinux.org/index.php/Makepkg#Troubleshooting] it says if -DCMAKE_BUILD_TYPE is defined for a certain package it will ignore the /etc/makepkg.conf CMake configuration.

Would be nice if the root cause could actually get fixed since the ignition-cmake PKGBUILD defines ENABLE_TESTS_COMPILATION:BOOL=False and then CMake out put tells you that parameter doesn't exist but you need to disable testing (which ENABLE_TESTS_COMPILATION:BOOL=False previously probably did) to make the build work on Arch.

I'll also comment on the ignition-cmake AUR.