Package Details: gcc46 4.6.4-4

Git Clone URL: https://aur.archlinux.org/gcc46.git (read-only)
Package Base: gcc46
Description: The GNU Compiler Collection (4.6.x)
Upstream URL: http://gcc.gnu.org
Licenses: GPL, custom, LGPL
Provides: gcc-4.6
Submitter: anpu
Maintainer: severach
Last Packager: ftschindler
Votes: 15
Popularity: 0.000000
First Submitted: 2012-04-23 22:27
Last Updated: 2016-08-09 16:02

Latest Comments

1 2 3 4 5 6 Next › Last »

ftschindler commented on 2018-07-31 12:04

Dear all,

thanks for reporting! However, I do not require the package anymore and will give up support. Feel free to pick up!

severach commented on 2018-07-18 00:19

See texi patch in gcc46-multilib.

rafajunio commented on 2018-07-16 20:11

Hi, I can't compile anymore. Even after use this link https://crmullins.com/compiling-gcc-463-on-arch-linux.html the problem from linux-unwind.h persist. From the aur the build stop in the fallow erros (is the first errors in the link): "~/gcc46/src/gcc-4.6.4/gcc/doc/gcc.texi:89: warning: @tex should only appear at the beginning of a line ~/gcc46/src/gcc-4.6.4/gcc/doc/gcc.texi:209: no matching @end tex' ~/gcc46/src/gcc-4.6.4/gcc/doc/gcc.texi:209: no matching@end multitable' ~/gcc46/src/gcc-4.6.4/gcc/doc/gcc.texi:209: no matching `@end titlepage'"

ftschindler commented on 2017-05-22 07:07

Thank you for reporting! cloog-git seems to be a good replacement for isl15 and cloog. However, I still get an error when building the package. Did you change anything else?

ritze commented on 2017-05-19 08:27

Installing cloog-git resolved this problem.

ritze commented on 2017-05-18 10:09

pacman cannot resolve the dependencies: cloog needs isl>=0.18, but gcc46 needs isl15.

If I try to build it with current packages of isl (0.18) and cloog (0.18.5) the build process of the gcc46 package will fail.

ftschindler commented on 2015-11-16 09:49

@krnlyng: well, first of all I would investigate to obtain more information.

I think you should try to find out wether the gcc-4.6.4 package is broken (i.e. it should install to different locations or be compiled differently), or wether your application needs a newer std library.

krnlyng commented on 2015-11-09 19:57

Hi! I am trying to build an old version of android with this. But it fails like this: https://bpaste.net/show/fe27c61e12ac what can i do?

ftschindler commented on 2015-09-02 12:44

@maleadt: could you try to build the package with `export LD_PRELOAD=/usr/lib/libstdc++.so.6`, perhaps this is related?

maleadt commented on 2015-08-29 15:02

Package doesn't build because of ar using the LLVMGold.so bfd plugin (part of llvm-libs), yielding "version `GLIBCXX_3.4.21' not found". Tried rebuilding llvm-libs, but that doesn't seem the issue. Temporarily pacman -Rdd'ing llvm-libs (what could go wrong...) gets me past the error.