Package Details: gimp-git 1:3.0.r42265.ff56a3af8d-1

Git Clone URL: https://aur.archlinux.org/gimp-git.git (read-only)
Package Base: gimp-git
Description: GNU Image Manipulation Program
Upstream URL: https://www.gimp.org
Licenses: GPL, LGPL
Conflicts: gimp
Provides: gimp
Submitter: None
Maintainer: FFY00
Last Packager: FFY00
Votes: 108
Popularity: 0.170936
First Submitted: 2009-05-27 08:12
Last Updated: 2019-03-01 23:52

Dependencies (50)

Required by (147)

Sources (2)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

k3a commented on 2019-04-04 16:12

According to man PKGBUILD:

  • ./configure should be part of build()!!! Otherwise custom CFLAGS/LDFLAGS from makepkg.conf are not used.

  • prepare() should be used for sourcefiles preparations, such as patching ONLY.

bartus commented on 2019-03-03 13:27

@FFY00: yep, you can't implement this in PKGBUILD but I presumed you are going to rebuild this package daily basis, aren't you. Injecting additional piece of a script before the rebuild and automatically pushing changes to git@aur afterwards is worth the effort if the package can have properly instantiated dependencies version, isn't it.

FFY00 commented on 2019-03-02 22:29

That can't be properly implemented, you would need to have the source unpacked for that.

bartus commented on 2019-03-02 21:57

@FFY00, why removing deps pkgver? Why not probe those from configure? update.PKGBUILD (° ͜ʖ°)

FredBezies commented on 2019-02-18 09:37

Like Ionaowna reported, I've got this error:

Error: GIMP configuration failed.

  • Error: missing dependency babl >= 0.1.61
  • Error: missing dependency gegl-0.4 >= 0.4.13

lonaowna commented on 2018-12-31 17:47

Dependencies should be updated: gegl>=0.4.13, babl>=0.1.61

FFY00 commented on 2018-11-23 10:49

Oh, my mistake. I don't know where my head was, haha. Use /usr/share/blender-devel, that's what I wanted to say.

FFY00 commented on 2018-11-23 10:41

You don't need to use /opt, use /usr/share/blender-2.8 :).

FFY00 commented on 2018-11-23 10:30

That's wrong. -git packages should be the same as their non -git versions but builded from the last commit. Please refrain from doing that. If you really want a package that provides an alternative development version that doesn't conflict with the main one, you should create a -devel package. Please do this with your blender package.

there is no need to have gimp<>gimp-git conflicting until of course they have the same version.

Then what? Do we delay one of the packages? Add a sudden conflict forcing the user to remove one of the packages? Change the icon and binary names??

haawda commented on 2018-11-22 21:59

I talked about Icons, the desktop files and some more delivered by both packages. And this hhas already been dicussed earlier in this comments.