Package Details: gmusicbrowser-shimmer 1.1.16-3

Git Clone URL: https://aur.archlinux.org/gmusicbrowser-shimmer.git (read-only, click to copy)
Package Base: gmusicbrowser-shimmer
Description: An open-source jukebox for large collections of mp3/ogg/flac/mpc/ape files, written in perl with Shimmer layout
Upstream URL: http://shimmerproject.org/our-projects/shimmer-for-gmusicbrowser/
Licenses: GPL3
Conflicts: gmusicbrowser, gmusicbrowser-git
Provides: gmusicbrowser
Submitter: cippaciong
Maintainer: PhotonX
Last Packager: PhotonX
Votes: 2
Popularity: 0.000000
First Submitted: 2014-03-22 14:27 (UTC)
Last Updated: 2022-07-06 15:38 (UTC)

Dependencies (26)

Required by (0)

Sources (3)

Latest Comments

1 2 3 Next › Last »

PhotonX commented on 2022-07-07 09:45 (UTC) (edited on 2022-07-07 09:45 (UTC) by PhotonX)

Great, thanks! When setting the path to /tmp he asks for a sudo password though and then fails with

==> Installing missing dependencies... sudo: effective uid is not 0, is /usr/bin/sudo on a file system with the 'nosuid' option set or an NFS file system without root privileges? ==> ERROR: 'pacman' failed to install missing dependencies.

Did you also encounter this problem?

FabioLolix commented on 2022-07-06 15:55 (UTC)

I guess it can be used multiple times, but I have configured it to recreate the chroot every time (-c option) and to build in RAM (/tmp) since I've started using it

PhotonX commented on 2022-07-06 15:44 (UTC)

Thanks for the hints! It's highly counterintuitive that the command markdown is in a package called discount, I was sure to have no markdown on my machine, but I was wrong...

Another offtopic question: Is /var/lib/archbuild/extra-x86_64/ created by extra-x86_64-build only once and is used by subsequent extra-x86_64-build calls for other packages or is there a new clean one for each package? As it takes 1,7GB disk space and I am low on disk space already. :)

FabioLolix commented on 2022-07-06 13:59 (UTC)

Hello,

I checked and it looks like it builds just fine without markdown, so I removed it.

markdown package has been renamed to discount and is needed to build this package

==> Entering fakeroot environment...
==> Starting package()...
perl po/create_pot.pl --quiet
markdown layout_doc.mkd > layout_doc.html
/bin/sh: line 1: markdown: command not found
make: *** [Makefile:51: layout_doc.html] Error 127
make: *** Waiting for unfinished jobs....
==> ERROR: A failure occurred in package().
  • You're welcome to build in a clean chroot before uploading to ensuring needed depends and makedepends are met, for convenience using extra-x86_64-build from devtools package https://wiki.archlinux.org/title/DeveloperWiki:Building_in_a_clean_chroot
  • please rename the source with $pkgname-$pkgver.tar.gz:: to be non-conflicting (especially for users of shared source destination)
  • please use provides=(gmusicbrowser) conflicts=(gmusicbrowser)

PhotonX commented on 2022-07-06 13:47 (UTC) (edited on 2022-07-06 13:48 (UTC) by PhotonX)

Sorry for the delay. I checked and it looks like it builds just fine without markdown, so I removed the markdown makedepend. Regarding the gtk3 version, I think, this would need to be a whole new package, something like gmusicbrowser-shimmer-git. Might look into it at some point.

PhotonX commented on 2022-06-21 18:30 (UTC)

I wonder if markdown is specifically required due to the Shimmer patches, as the vanilla gmusicbrowser doesn't list this makedepend. I will check this asap. Also, I think, there is a commit making the patch work with the gtk3 version, so it might fix the build problems I had in 2020 and therefore it might be a good idea to switch to the gtk3 branch: https://github.com/shimmerproject/gmusicbrowser/commit/7a257929cddfca3a6f366eeca1dd2453b9343831

MarsSeed commented on 2022-06-21 15:39 (UTC)

Missing makedepends: markdown.

The gmusicbrowser package's direct dependencies are still available, though.

I don't know if this one is still needed or not. Maybe it could be considered for deletion.

PhotonX commented on 2020-12-24 11:58 (UTC)

Adopted and updated to 1.1.16.

I managed to apply the Shimmer patch to 1.1.99.1 (a GTK3 port) but looks like the changes are too big, some icons don't show up any more if the Shimmer patch is applied.

cippaciong commented on 2020-11-21 00:10 (UTC)

Since I don't use this package anymore I stepped down as a maintainer so that someone else can take a better care of it.

Cheers :)

cippaciong commented on 2016-08-29 11:20 (UTC)

@PhotonX Do you mean gstreamer0.10 or gst?