Package Details: gmusicbrowser 1.1.15-7

Git Clone URL: https://aur.archlinux.org/gmusicbrowser.git (read-only)
Package Base: gmusicbrowser
Description: A customizable open-source jukebox for large collections
Upstream URL: http://gmusicbrowser.org
Keywords: multimedia music
Licenses: GPL3
Conflicts: gmusicbrowser-git, gmusicbrowser-shimmer, gmusicbrowser-shimmer-git
Submitter: xyproto
Maintainer: Spike29
Last Packager: Spike29
Votes: 70
Popularity: 0.790601
First Submitted: 2011-12-14 17:03
Last Updated: 2017-06-12 16:18

Dependencies (27)

Required by (0)

Sources (2)

Latest Comments

Spike29 commented on 2017-09-22 21:24

@Salamander: Did you install perl-glib-object-introspection?
If you already had it installed, build it again, this dependency should be rebuilt after every perl update.

Salamandar commented on 2017-09-22 20:33

Hmm, i can't get the gst1.0 output to work.
Actually, in the "Audio" tab i just have gstreamer 0.10 proposed.
Any idea ?

IMBJR commented on 2017-06-12 16:28

Thanks. That did the trick.

Corax commented on 2017-06-11 23:14

@IMBJR: that's because perl-glib-object-introspection's pkgrel should have been bumped but hasn't been yet. For now just rebuild it manually and things should work just fine.

IMBJR commented on 2017-06-10 17:09

Currently getting, when running gmusicbrowser:

neither Locale::Messages, nor Locale::gettext found -> no translations
GObjectIntrospection.c: loadable library and perl binaries are mismatched (got handshake key 0xdb80080, needed 0xde00080

I've tried rebuilding gmusicbrowser and re-installing older versions of gobject-introspection and its runtime with no success.

aptx commented on 2016-07-02 19:10

Thanks, this worked. I guess gobject-introspection needs to be a build dependency of perl-glib-object-introspection. I will try to suggest this.

Spike29 commented on 2016-07-02 16:36

@aptx: Try to reinstall perl-glib-object-introspection.

I think I had to edit perl-glib-object-introspection PKGBUILD and added "gobject-introspection" as a dependency. Otherwise the build would fail.

aptx commented on 2016-07-02 16:30

Since a while ago, I get the following error when trying to execute gmusicbrowser:
GObjectIntrospection.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)
The same with gmusicbrowser-git or gmusicbrowser-shimmer. Tried uninstalling, purging pacaur cache and reinstalling, but still not working. Does anyone have any idea?

Spike29 commented on 2016-06-22 09:30

Alright, I added perl-net-dbus as a required dependency.
Thanks for reporting this issue.

Not sure why gmusicbrowser worked for me without it, though.

qs9rx commented on 2016-06-19 13:57

Installing perl-net-dbus fixed it for me too. Log here: http://pastebin.com/e5czphib

All comments