Package Details: gradle6-src 6.9.2-3

Git Clone URL: https://aur.archlinux.org/gradle6.git (read-only, click to copy)
Package Base: gradle6
Description: Powerful build system for the JVM (sources)
Upstream URL: https://gradle.org/
Keywords: automation build c++ delivery development gradle java open-source productivity python tool
Licenses: Apache
Submitter: class101
Maintainer: AmberArch
Last Packager: AmberArch
Votes: 2
Popularity: 0.037675
First Submitted: 2021-04-27 22:38 (UTC)
Last Updated: 2022-04-25 16:57 (UTC)

Dependencies (8)

Required by (0)

Sources (2)

Latest Comments

ribugent commented on 2022-04-25 06:40 (UTC)

I see this new version conflicts with gradle, after figuring out the reason why for the conflicts, I've modified the PKGBUILD to allow coexisting with gradle-docs and gradle-src

diff --git a/PKGBUILD b/PKGBUILD
index 3f08b64..028a8eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,8 @@

 pkgbase=gradle6
 pkgname=('gradle6' 'gradle6-doc' 'gradle6-src')
-conflicts=('gradle' 'gradle-doc' 'gradle-src')
 pkgver=6.9.2
-pkgrel=2
+pkgrel=3
 pkgdesc='Powerful build system for the JVM'
 url='https://gradle.org/'
 arch=('any')
@@ -69,8 +68,8 @@ package_gradle6-doc() {
   options=('!strip')

   cd ${pkgbase/6/}-${pkgver}/dist
-  install -d "${pkgdir}/usr/share/java/${pkgbase/6/}/docs"
-  cp -r docs/* "${pkgdir}/usr/share/java/${pkgbase/6/}/docs"
+  install -d "${pkgdir}/usr/share/java/${pkgbase}/docs"
+  cp -r docs/* "${pkgdir}/usr/share/java/${pkgbase}/docs"
 }

 package_gradle6-src() {
@@ -78,8 +77,8 @@ package_gradle6-src() {
   options=('!strip')

   cd ${pkgbase/6/}-${pkgver}/dist
-  install -d "${pkgdir}/usr/share/java/${pkgbase/6/}/src"
-  cp -r src/* "${pkgdir}/usr/share/java/${pkgbase/6/}/src"
+  install -d "${pkgdir}/usr/share/java/${pkgbase}/src"
+  cp -r src/* "${pkgdir}/usr/share/java/${pkgbase}/src"
 }

 # vim: ts=2 sw=2 et:

Hope this helps

class101 commented on 2021-06-09 15:01 (UTC) (edited on 2021-06-09 15:01 (UTC) by class101)

No more linked to ghidra-dev and ghidra-git since ghidra seem to support gradle v7.x well :)

class101 commented on 2021-04-27 22:41 (UTC) (edited on 2021-05-06 04:12 (UTC) by class101)

I have made this package because the ghidra official build is not compatible with gradle>=7

Nothing has been changed from the latest v6 available on the official repo, except

  • gradle.sh is no more exported into /etc/profile.d to export GRADLE_HOME
  • GRADLE_HOME is exported as a /usr/bin/gradle6 launcher script and points to gradle6 libraries

Like that the package should be installable and usable near the latest official gradle versions