Package Details: grass 7.6.0-1

Git Clone URL: https://aur.archlinux.org/grass.git (read-only)
Package Base: grass
Description: Geospatial data management and analysis, image processing, graphics/maps production, spatial modeling and visualization
Upstream URL: http://grass.osgeo.org/
Licenses: GPL
Submitter: Scimmia
Maintainer: Scimmia
Last Packager: Scimmia
Votes: 31
Popularity: 0.115183
First Submitted: 2015-09-06 15:10
Last Updated: 2019-01-22 20:08

Dependencies (26)

Required by (1)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

kikislater commented on 2016-04-28 15:49

Error in building since the update of 27/04. Please update

Finished compilation: jeu. avril 28 17:47:10 CEST 2016
Makefile:57 : la recette pour la cible « default » a échouée
make: *** [default] Erreur 1

kikislater commented on 2016-02-02 12:34

@HuMu_2013 : It works for me ! I use v.generalize with chaiken algorithm aka smooth and I have no problem.
I don't use grass under qgis

HuMu_2013 commented on 2016-02-01 10:24

I went back to 7.0.2.
Some modules were not fonctionning correctly like "smooth or simplify" under "Topology maintenance". Moreover the GRASS layers were not visible and importable any more in Qgis.

kikislater commented on 2016-01-29 09:03

@Scimmia : Thanks for the update, it works well now !
I can install and use addon written in python more easyly :D

Scimmia commented on 2016-01-25 16:17

"There is a lot of addons using python with grass, I don't want to re-write them in another language like C or C++. Grass GIS does not support python 3, so it's important to use python 2 instead of 3 until they fully support it !
If you don't have python 2 in Grass GIS at this moment, this package should be useless ..."

Which is why GRASS should be calling the script with $GRASS_PYTHON, and script authors should be using #!/usr/bin/env python2. Calling "python" specifically means that you don't care which version you get.

We have to be pragmatic, though, and work around upstream lunacy.

kikislater commented on 2016-01-21 10:58

There is a lot of addons using python with grass, I don't want to re-write them in another language like C or C++. Grass GIS does not support python 3, so it's important to use python 2 instead of 3 until they fully support it !
If you don't have python 2 in Grass GIS at this moment, this package should be useless ...

Watch :
Note: Python 3 support is still in development
Source : https://grass.osgeo.org/grass70/source/snapshot/REQUIREMENTS.html
And : https://trac.osgeo.org/grass/ticket/2708
#2708 new defect
Run GRASS with Python3
Jalon modifié de 7.0.2 à 7.0.3
Ticket retargeted after milestone closed

Also you have this in your build :
# Enabling only those features which are not enabled by default. Out of the
# usefull ones, only DWG, MySQL, FFMPEG and Motif are left disabled. LAPACK
# and BLAS are not used for anything in GRASS anyway.
But what about v.kriging ... It needs BLAS and LAPACK package. You forgot addons which is an important part of GRASS GIS. We have a limited GRASS GIS build !

Scimmia commented on 2016-01-21 10:25

kikislater, really, you shouldn't be using "python" if you specifically want python2. See http://legacy.python.org/dev/peps/pep-0394/

kikislater commented on 2016-01-18 22:51

Ok Thank you
I made a test and I saw that :

Big problem with the build. Not the good python version

GRASS 7.0.2 (DATA):~ > which python
/usr/sbin/python
[MASK raster présent]
GRASS 7.0.2 (DATA):~ > /usr/sbin/python --version
Python 3.5.1
[MASK raster présent]

cat /usr/bin/grass70 | more
#!/usr/bin/env python2
#############################################################################

Scimmia commented on 2016-01-18 22:44

Yeah, I figure I'll put the python symlink hack back in on the next release, which will be any time.

And please, figure out what "out-of-date" means.

kikislater commented on 2016-01-18 22:39

Package is buggy
If I want to launch grass addons, I have to put at the beginning of python script this :
#!/usr/bin/env python2

For example, I use v.surf.nnbathy I have to edit v.surf.nnbathy.py and nnbathy.py and add this #!/usr/bin/env python2 at the beginning of the *.py files. Same problem as described below by kuszi

Please correct the package Scimmia