Package Details: hamlib-git b2acf0b6-1

Git Clone URL: https://aur.archlinux.org/hamlib-git.git (read-only, click to copy)
Package Base: hamlib-git
Description: Ham radio equipment control libraries
Upstream URL: http://hamlib.org
Licenses: GPL, LGPL
Conflicts: hamlib
Provides: hamlib
Submitter: CarstenF
Maintainer: not_anonymous
Last Packager: not_anonymous
Votes: 5
Popularity: 0.000000
First Submitted: 2014-09-10 22:18
Last Updated: 2021-08-23 06:39

Required by (36)

Sources (1)

Latest Comments

not_anonymous commented on 2021-08-23 06:40

Updated !!

not_anonymous commented on 2021-08-18 12:44

Just adopted this (once again)....will be working on it...TIA for your patience.

grawlinson commented on 2021-08-02 22:44

Any chance of using Python 3 instead of the long-dead Python 2?

FabioLolix commented on 2021-07-25 07:44

This is missing git in makedepends and need a proper pkgver function https://wiki.archlinux.org/title/VCS_package_guidelines#Git

not_anonymous commented on 2021-06-07 22:17

Updated !

micwoj92 commented on 2021-04-22 21:26

Needs git in makedepends

hoeste commented on 2018-07-19 04:37

The build fails with the error "/bin/pacman: unrecognized option '--color never'". I thought it was a hamlib dependency that was the issue because trying to install just that gave this error too. But hamlib-git installed fine. After that, trying this build again gave the same error.

not_anonymous commented on 2018-04-21 15:19

Thanks for the "heads-up" Tom. 'autoreconf -i' was needed to generate the missing ./configure file. I also updated the perl stuff.

tom.swartz07 commented on 2018-04-03 12:41

Build seems to be broken.

They've moved from ./autogen .... to using ./configure

not_anonymous commented on 2017-02-01 00:04

New package. THREE comments;

1 - Needed as some packages (that use hamlib) are ONLY python3 programs.
2 - I felt it was useful, so I added in all the former contributors of hamlib.
3 - Fixed various depends and provides/conflicts as needed.