Package Details: hmcl-stable-bin 3.5.5-2

Git Clone URL: https://aur.archlinux.org/hmcl-stable-bin.git (read-only, click to copy)
Package Base: hmcl-stable-bin
Description: A Minecraft Launcher which is multi-functional, cross-platform and popular.
Upstream URL: https://github.com/huanghongxun/HMCL
Keywords: hmcl
Licenses: GPL3
Conflicts: hmcl
Provides: hmcl
Submitter: Bot-wxt1221
Maintainer: Bot-wxt1221
Last Packager: Bot-wxt1221
Votes: 2
Popularity: 0.35
First Submitted: 2023-09-09 08:18 (UTC)
Last Updated: 2024-02-20 07:54 (UTC)

Dependencies (2)

Required by (0)

Sources (5)

Latest Comments

Bot-wxt1221 commented on 2023-11-25 02:14 (UTC)

rzAUR Helper

望各位手动安装jave-openjfx

Bot-wxt1221 commented on 2023-11-11 12:56 (UTC)

Fixed @w568w

w568w commented on 2023-11-05 04:41 (UTC) (edited on 2023-11-05 04:52 (UTC) by w568w)

Please do not make the package depend on jre-openjdk anymore - Arch now forbids the coexistent of JRE and JDK. Anyone as a Java developer will be unable to install hmcl-stable-bin after the update.

They changed this without hesitation because the Java package guidelines has long recommended use java-runtime dependency for applications needing Java Runtime. Having a direct dependency on the JRE without a great reason is never a good practice now.

Also, please do not depend on java17-openjfx directly - HMCL runs well under newer and up-to-date Java and JavaFX. Maybe just java-openjfx or java-openjfx>=17 will be better?

plokid commented on 2023-10-25 02:14 (UTC)

启动脚本里写死是 openjdk17, 但可能并没有安装