Package Details: jaxb-api 2.3.3-1

Git Clone URL: https://aur.archlinux.org/jaxb-api.git (read-only, click to copy)
Package Base: jaxb-api
Description: Java Architecture for XML Binding (JAXB) API
Upstream URL: https://javaee.github.io/jaxb-v2/
Licenses: EDL
Submitter: ImNtReal
Maintainer: ImNtReal
Last Packager: ImNtReal
Votes: 1
Popularity: 0.28
First Submitted: 2019-02-11 22:09
Last Updated: 2020-02-11 14:40

Dependencies (4)

Required by (1)

Sources (1)

Latest Comments

a2h commented on 2020-02-07 19:46

This wasn't working for me in openjdk-13 (or anything else really). I fixed it by changing the package version in PKGBUILD to 2.3.3, running makepkg to extract. Then getting an error that it can't find jakarta.activation-api vs 1.2.2, so then I went and modified /src/jaxb-api-2.3.3/pom.xml and changed the version of jakarata.activation-api to 1.2.1, it worked after that.

arshtork commented on 2019-02-26 08:55

Seems like this is the root cause: https://stackoverflow.com/questions/49105941/intellij-maven-project-fatal-error-compiling-invalid-flag-release

<release> tag is supported for java 9+

Quick & dirty fix that worked for me (with openjdk-8):

    cd <jaxb-api build dir> # e.g. $HOME/.cache/yay/jaxb-api/jaxb-api-2.3.2
    grep -R "<release>"
    # Should output 
    # jaxb-api-test/pom.xml:                    <release>11</release>
    # jaxb-api/pom.xml:                            <release>8</release>
    # jaxb-api/pom.xml:                            <release>9</release>
    # jaxb-api/pom.xml:                            <release>9</release>
    # Remove the release tags from the files above & build again.

ImNtReal commented on 2019-02-18 14:55

So far, I've only been able to build it with java-11-openjdk. I'll check into updating the make dependencies. I think I've seen weirdness with specifying Java versions before.

aorth commented on 2019-02-13 08:02

I'm getting a build error with 2.3.2:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.0:compile (default-compile) on project jakarta.xml.bind-api: Fatal error compiling: invalid flag: --release -> [Help 1]