Package Details: jd-gui 1.6.6-2

Git Clone URL: https://aur.archlinux.org/jd-gui.git (read-only, click to copy)
Package Base: jd-gui
Description: A standalone graphical utility that displays Java source codes of .class files
Upstream URL: http://jd.benow.ca/
Licenses: GPL3
Conflicts: jd-gui-bin
Provides: jd-gui
Submitter: simon04
Maintainer: artafinde
Last Packager: artafinde
Votes: 31
Popularity: 0.020036
First Submitted: 2015-05-27 20:51 (UTC)
Last Updated: 2023-03-13 09:01 (UTC)

Dependencies (3)

Required by (0)

Sources (4)

Latest Comments

1 2 3 Next › Last »

kdh8219 commented on 2024-02-25 16:06 (UTC)

Build failure

==> Starting build()...

ERROR: JAVA_HOME is set to an invalid directory: /usr/lib/jvm/java-8-openjdk/

Please set the JAVA_HOME variable in your environment to match the
location of your Java installation.

==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: jd-gui-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
jd-gui - exit status 4
> echo $JAVA_HOME                       
/usr/lib/jvm/zulu-21/

can PKGBUILD be better?

jusw85 commented on 2021-06-12 12:18 (UTC)

Build failure

> Could not find method runtime() for arguments [project ':services'] on object of type org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler.

Deprecated Gradle features were used in this build, making it incompatible with Gradle 8.0.

DarkShadow44 commented on 2019-11-29 18:50 (UTC)

@simon04 Works fine, thanks!

simon04 commented on 2019-11-29 09:50 (UTC)

@DarkShadow44: Gradle 6.0 build should be fixed in jd-gui 1.6.5-2

DarkShadow44 commented on 2019-11-28 20:31 (UTC)

Doesn't work with gradle-6.0.1 for me. I needed to downgrade to gradle-5.6.4, then it builds fine.

simon04 commented on 2019-08-03 08:51 (UTC)

@z3ntu: Back then I switched to ./gradlew due to incompatibilities with the newest community/gradle. Those issues seem to be resolved. Now, 1.6.3-2 uses community/gradle again.

z3ntu commented on 2019-07-03 11:27 (UTC)

How about making the package use gradle from [community] instead of using ./gradlew?

simon04 commented on 2019-03-29 20:46 (UTC)

@wlritchi: Version 1.4.1 added real Java 9/10/11 support, so the hack of distinguishing Java versions is no longer needed, luckily.

wlritchi commented on 2019-02-19 17:42 (UTC)

Could the start script check the Java version using "java -version" instead of "archlinux-java get"? The latter doesn't work with other implementations of Java that are still 1.8 or below, and trying to add a case for every Java implementation in the repos and AUR feels like it would be the wrong approach.