Package Details: jekyll 3.8.5-2

Git Clone URL: (read-only)
Package Base: jekyll
Description: A simple, blog aware, static site generator.
Upstream URL:
Keywords: jekyll ruby
Licenses: MIT
Conflicts: ruby-jekyll
Provides: jekyll=3.8.5, ruby-jekyll
Replaces: ruby-jekyll
Submitter: SilverRainZ
Maintainer: SilverRainZ (bjo)
Last Packager: bjo
Votes: 71
Popularity: 0.004030
First Submitted: 2017-11-20 05:56
Last Updated: 2019-01-21 16:03

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

SilverRainZ commented on 2018-01-16 04:06

Jekyll has updated to 3.7.0, User can replace ruby-listen-3-0 with ruby-listen now.

cc @jonathon

SilverRainZ commented on 2018-01-15 05:01

@jonathon, all dependencies has satisfied except ruby-jekyll-watch. I have to wait for the maintainer update to 2.0.0 to let jekyll works.

jonathon commented on 2018-01-14 17:26

It looks like jekyll=3.6.2 has a dep on ruby-listen (< 3.1, ~> 3.0) [1] (though this may be due to another installed gem). This version requirement should be resolvable with an update to jekyll=3.7.0 but the PKGBUILD may still need the dep to be added.


SilverRainZ commented on 2017-11-23 05:47

I have changed the dependency constraint from 1.7 < ruby-rouge < 3 to ruby-rouge-1, now this package can be installed smoothly. But it still doesn't work now.

When you install ruby-jekll-watch from AUR, your aur helper may install a wrong version of ruby-listen (3.1.5) package for you. To let jekyll works, Please remove ruby-listen and install ruby-listen-3-0 (3.0.8) instead.

If you want to get pre-built package of jekyll, please considering use:

SilverRainZ commented on 2017-11-21 04:41

Hi patrick.luehne

> but the dependency to ruby-rouge can’t be found when attempting to build Jekyll without any Ruby dependencies installed

Yes, I reproduced it. There is three version of rough on AUR & community: community/ruby-rouge 3.0.0-1, aur/ruby-rouge-1 1.11.1-2 and aur/ruby-rouge-2.0 2.0.7-2, the last one package actually meet the requirement 1.7 <= ruby-rouge < 3, I don't know while my aur helper(yaourt) can not find the dependency :-(.

> The official gemspec file shows that ruby-rouge >= 1.7 and < 4 is okay

Here is 3.6.2 but not git master, so I think we should follow jekyll's page[1] on


patrick.luehne commented on 2017-11-20 17:42

@SilverRainZ: Thanks for taking over :)! You’re probably already aware of this, but the dependency to ruby-rouge can’t be found when attempting to build Jekyll without any Ruby dependencies installed. Should we create a new ruby-rouge (without version number suffix in the name) package for that?

Also, I think that the dependency to ruby-rouge < 3 isn’t needed. The official gemspec file shows that ruby-rouge >= 1.7 and < 4 is okay [1], if I read that correctly.


patrick.luehne commented on 2017-11-17 14:07

Aside from the fact that this PKGBUILD is still broken, I believe that the package name should be “jekyll” and not “ruby-jekyll,” according to the Arch Ruby Gem packaging guidelines [1]. The prefix “ruby-” appears to be used only for libraries and not applications such as Jekyll.


SilverRainZ commented on 2017-11-10 03:04

Please don't update the version without fix dependencies.
This package is still *BROKEN*.

patrick.luehne commented on 2017-10-10 22:30

Please fix the dependency to liquid ≥ 4.0.0 in the PKGBUILD.

Concerning the Liquid dependency, I added an AUR package called ruby-liquid containing the required version (4.0.0).

I believe the dependencies should now read:

depends=('ruby' 'ruby-addressable>=2.4' 'ruby-colorator>=1.0' 'ruby-jekyll-sass-converter>=1.0' 'ruby-jekyll-watch>=1.1' 'ruby-kramdown>=1.14' 'ruby-liquid>=4.0' 'ruby-mercenary>=0.3.3' 'ruby-pathutil>=0.9' 'ruby-rouge-2.0' 'ruby-safe_yaml>=1.0')

Let me know if I can be of any help :). Thanks!

patrick.luehne commented on 2017-10-03 23:17

Dear maintainers,

Jekyll as of version 3.6.0 has multiple dependencies that are currently not met by this package [1].

The following dependencies are missing or outdated:

* ruby-kramdown (1.14 required but only 1.10 in the AUR, I already contacted the maintainers)
* ruby-liquid (4.0 required but only 3.0.6 in the AUR, a new package might be necessary)

I suggest adding the required minimal versions to the PKGBUILD dependencies exactly as listed in the gemspec [1]. Concerning liquid 4, I’m not sure whether it should be a package separate from ruby-liquid-3, or whether there should be only one ruby-liquid package at some point. What do you think?

Best wishes,