Package Details: jekyll 4.2.1-1

Git Clone URL: https://aur.archlinux.org/jekyll.git (read-only, click to copy)
Package Base: jekyll
Description: A simple, blog aware, static site generator.
Upstream URL: https://github.com/jekyll/jekyll
Keywords: jekyll ruby
Licenses: MIT
Conflicts: ruby-jekyll
Provides: jekyll=4.2.1, ruby-jekyll
Replaces: ruby-jekyll
Submitter: SilverRainZ
Maintainer: SilverRainZ (bertptrs)
Last Packager: bertptrs
Votes: 87
Popularity: 0.80
First Submitted: 2017-11-20 05:56
Last Updated: 2021-10-03 11:39

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

whynothugo commented on 2015-08-24 22:45

I uninstalled every single ruby package and reinstalled them. Looks like jekyll-sass was missing from the dependency tree.

kitarek commented on 2015-08-24 19:37

@hobarrera - Thanks very much. `jekyll serve` is still reporting for me missing `RedCloth-4.2.9` dependency.

I'm not sure if it's related to some packages not rebuilt today on my side. I have rebuilt `rebu-jekyll` (and its new deps) as well as `ruby-jekyll-watch` (deps: -listen).

Thanks a lot!

whynothugo commented on 2015-08-24 17:39

I've updated this package and several of its dependencies.

Thanks for all the detailed messages. I hope I didn't miss uploading anything (it's kinda hard to keep track of what's uploaded and what's not).

mschu commented on 2015-08-17 23:13

celluloid needs to be version 16 as well: https://talk.jekyllrb.com/t/error-while-trying-to-run-jekyll-serve/933/8

sorry for spamming you so much, let me know if you need help fixing the deps :-)

mschu commented on 2015-08-17 23:05

And further celluloid, rspec-logsplit, hitimes, timers, celluloid-extras, celluloid-fsm, celluloid-pool, celluloid-supervision, celluloid-essentials, bundler, nenv, dotenv, rb-fsevent, ffi, rb-inotify.

And community/nodejs or another JS framework as ItachiSan pointed out.

mschu commented on 2015-08-17 22:51

I still get an error message when running Jekyll in my page directory:

/usr/lib/ruby/2.2.0/rubygems/dependency.rb:315:in `to_specs': Could not find 'jekyll-sass-converter' (~> 1.0) among 30 total gem(s) (Gem::LoadError)

Seems to need a depends on ruby-jekyll-sass-converter. And ruby-jekyll-watch, which is missing ruby-listen (there is already a comment on the package).

whynothugo commented on 2015-08-14 02:20

Just pushed ruby-kramdown. Thanks for the heads up.

mschu commented on 2015-08-09 22:00

This is missing at least the ruby-kramdown dependency in AUR4.

ItachiSan commented on 2015-07-24 15:14

And also a JavaScript environment, else Jekyll won't run. Actually, 'nodejs' from community works fine.

ItachiSan commented on 2015-07-24 15:04

You should add 'ruby-jekyll-sass-converter' as a dependency.