Package Details: jekyll 3.8.5-2

Git Clone URL: https://aur.archlinux.org/jekyll.git (read-only)
Package Base: jekyll
Description: A simple, blog aware, static site generator.
Upstream URL: https://github.com/jekyll/jekyll
Keywords: jekyll ruby
Licenses: MIT
Conflicts: ruby-jekyll
Provides: jekyll=3.8.5, ruby-jekyll
Replaces: ruby-jekyll
Submitter: SilverRainZ
Maintainer: SilverRainZ (bjo)
Last Packager: bjo
Votes: 72
Popularity: 0.921814
First Submitted: 2017-11-20 05:56
Last Updated: 2019-01-21 16:03

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

jplatte commented on 2017-09-21 18:04

Yes, the 'jekyll new' template uses bundler to install the minima theme. But jekyll can be used without themes nevertheless.

yair commented on 2017-09-21 12:19

seems bundler is a requirement, also mentioned in the jekyll quick start page

```➜ jekyll new blog
Dependency Error: Yikes! It looks like you don't have bundler or one of its dependencies installed. In order to use Jekyll as currently configured, you'll need to install this gem.
```

jplatte commented on 2017-08-29 16:25

ber532k: Are you using a theme / plugin? I think jekyll uses bundler to download (and build?) themes and/or plugins. But I'm pretty sure that it's not a hard dependency.

seifferth commented on 2017-08-29 10:47

I just had an issue after installing this package via pacaur. Something about bundler-something not found. Installing ruby-bundler from community (and reinstalling ruby-jekyll) apparently fixed that, so you might consider adding ruby-bundler as a dependency.

CarstenF commented on 2017-04-01 11:00

@andybz and @imrehg: ruby-rouge-1 dependency is fixed now. an ruby-jekyll is update to 3.4.3.

andybz commented on 2017-04-01 03:57

You can fix the error Could not find 'rouge' (~> 1.7) - did find: [rouge-2.0.7] (Gem::MissingSpecVersionError) by installing ruby-rouge-1, but would be great if the maintainer could change the dependency until https://github.com/jekyll/jekyll/pull/5230 is merged.

imrehg commented on 2017-03-26 10:09

Wrong version of rouge is pulled in currently:

/usr/lib/ruby/2.4.0/rubygems/dependency.rb:310:in `to_specs': Could not find 'rouge' (~> 1.7) - did find: [rouge-2.0.7] (Gem::MissingSpecVersionError)

zasdfgbnm commented on 2016-08-11 17:24

Please update the dependency list
See:
https://rubygems.org/gems/jekyll

jleclanche commented on 2016-07-31 19:05

Edit: Ruby-colorator dependency seems broken. It's not finding it.

CarstenF commented on 2016-04-01 14:16

@fusion809, Thanks for your report. I have changed the url and updated to the new version.