Package Details: jekyll 4.2.1-1

Git Clone URL: (read-only, click to copy)
Package Base: jekyll
Description: A simple, blog aware, static site generator.
Upstream URL:
Keywords: jekyll ruby
Licenses: MIT
Conflicts: ruby-jekyll
Provides: jekyll=4.2.1, ruby-jekyll
Replaces: ruby-jekyll
Submitter: SilverRainZ
Maintainer: SilverRainZ (bertptrs)
Last Packager: bertptrs
Votes: 87
Popularity: 0.80
First Submitted: 2017-11-20 05:56
Last Updated: 2021-10-03 11:39

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

SilverRainZ commented on 2018-04-19 18:27

Jekyll updated to 3.8.0

SilverRainZ commented on 2018-01-19 05:03

@zertyz, Sorry for misleading, ruby-listen is a AUR package and not yet in [community]. ruby-ruby_dep is a dependency of ruby-listen but ruby-listen does not require it, I have notified the maintainer and add ruby-ruby_dep as jekyll's dependency temporarily.

zertyz commented on 2018-01-18 14:28

Thank you for the package.

could not find ruby-listen in [community]. I'm facing an error after installing and running jekyll:

/usr/lib/ruby/2.5.0/rubygems/dependency.rb:310:in to_specs': Could not find 'ruby_dep' (~> 1.2) among 65 total gem(s) (Gem::MissingSpecError) Checked in 'GEM_PATH=/home/luiz/.gem/ruby/2.5.0:/usr/lib/ruby/gems/2.5.0', executegem env` for more information

Installing the package 'ruby-ruby_dep' from AUR solved the issue. Please, add it as a dependency.

SilverRainZ commented on 2018-01-16 04:06

Jekyll has updated to 3.7.0, User can replace ruby-listen-3-0 with ruby-listen now.

cc @jonathon

SilverRainZ commented on 2018-01-15 05:01

@jonathon, all dependencies has satisfied except ruby-jekyll-watch. I have to wait for the maintainer update to 2.0.0 to let jekyll works.

jonathon commented on 2018-01-14 17:26

It looks like jekyll=3.6.2 has a dep on ruby-listen (< 3.1, ~> 3.0) [1] (though this may be due to another installed gem). This version requirement should be resolvable with an update to jekyll=3.7.0 but the PKGBUILD may still need the dep to be added.


SilverRainZ commented on 2017-11-23 05:47

I have changed the dependency constraint from 1.7 < ruby-rouge < 3 to ruby-rouge-1, now this package can be installed smoothly. But it still doesn't work now.

When you install ruby-jekll-watch from AUR, your aur helper may install a wrong version of ruby-listen (3.1.5) package for you. To let jekyll works, Please remove ruby-listen and install ruby-listen-3-0 (3.0.8) instead.

If you want to get pre-built package of jekyll, please considering use:

SilverRainZ commented on 2017-11-21 04:41

Hi patrick.luehne

> but the dependency to ruby-rouge can’t be found when attempting to build Jekyll without any Ruby dependencies installed

Yes, I reproduced it. There is three version of rough on AUR & community: community/ruby-rouge 3.0.0-1, aur/ruby-rouge-1 1.11.1-2 and aur/ruby-rouge-2.0 2.0.7-2, the last one package actually meet the requirement 1.7 <= ruby-rouge < 3, I don't know while my aur helper(yaourt) can not find the dependency :-(.

> The official gemspec file shows that ruby-rouge >= 1.7 and < 4 is okay

Here is 3.6.2 but not git master, so I think we should follow jekyll's page[1] on


patrick.luehne commented on 2017-11-20 17:42

@SilverRainZ: Thanks for taking over :)! You’re probably already aware of this, but the dependency to ruby-rouge can’t be found when attempting to build Jekyll without any Ruby dependencies installed. Should we create a new ruby-rouge (without version number suffix in the name) package for that?

Also, I think that the dependency to ruby-rouge < 3 isn’t needed. The official gemspec file shows that ruby-rouge >= 1.7 and < 4 is okay [1], if I read that correctly.


patrick.luehne commented on 2017-11-17 14:07

Aside from the fact that this PKGBUILD is still broken, I believe that the package name should be “jekyll” and not “ruby-jekyll,” according to the Arch Ruby Gem packaging guidelines [1]. The prefix “ruby-” appears to be used only for libraries and not applications such as Jekyll.