Package Details: lib32-libheif 1.17.6-1

Git Clone URL: https://aur.archlinux.org/lib32-libheif.git (read-only, click to copy)
Package Base: lib32-libheif
Description: HEIF file format decoder and encoder (32-bit)
Upstream URL: https://github.com/strukturag/libheif
Licenses: GPL3
Provides: libheif.so
Submitter: rodrigo21
Maintainer: sl1pkn07
Last Packager: sl1pkn07
Votes: 5
Popularity: 0.000211
First Submitted: 2018-09-03 23:49 (UTC)
Last Updated: 2023-12-20 19:08 (UTC)

Latest Comments

1 2 Next › Last »

sl1pkn07 commented on 2023-12-23 21:32 (UTC)

libheif=1.17.5

you systerm is out of date

nothing to do

korimitsu commented on 2023-12-23 20:22 (UTC)

Does not build anymore:

pamac build lib32-libheif lib32-svt-av1
Preparing...
Checking lib32-svt-av1 dependencies...
Checking lib32-libheif dependencies...
Checking svt-av1-git dependencies...
Checking libheif-git dependencies...
Resolving dependencies...
Warning: cannot resolve "svt-av1=1.7.0", a dependency of "lib32-svt-av1"
Warning: cannot resolve "libheif=1.17.5", a dependency of "lib32-libheif"
Warning: cannot resolve "svt-av1=1.7.0", a dependency of "lib32-svt-av1"
Warning: cannot resolve "lib32-svt-av1", a dependency of "lib32-libheif"
Error: Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency 'svt-av1=1.7.0' required by lib32-svt-av1
- unable to satisfy dependency 'libheif=1.17.5' required by lib32-libheif
- unable to satisfy dependency 'lib32-svt-av1' required by lib32-libheif



Edit build files : [e] 
Apply transaction ? [e/y/N] Y

Transaction cancelled.

nmdZ3701 commented on 2023-10-19 14:53 (UTC)

thanks for the fix @discobeez woked great for me will update my aliases to ignore this until its gone!

discobeez commented on 2023-05-28 18:20 (UTC) (edited on 2023-05-28 18:21 (UTC) by discobeez)

When trying to update my Arch installation today, I got this error message:

$ yay -Syu
:: Synchronizing package databases...
core 134.1 KiB 272 KiB/s 00:00 [##############################] 100%
extra 8.3 MiB 6.90 MiB/s 00:01 [##############################] 100%
community is up to date
multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing libheif (1.16.2-1) breaks dependency 'libheif=1.16.1' required by lib32-libheif
:: installing rav1e (0.6.6-1) breaks dependency 'rav1e=0.6.3' required by lib32-rav1e
-> error refreshing databases - exit status 1

Telling pacman to ignore the two packages for upgrading makes the system upgrade work:

$  yay -Syu --ignore libheif,rav1e

freitafr commented on 2023-05-11 06:52 (UTC)

Hi,

I believe cmake should be part of the dependencies. It’s in extra and was not installed on my system, resulting in:

.cache/pikaur/build/lib32-libheif/PKGBUILD: line 48: cmake: command not found

RockyCott commented on 2023-05-09 15:06 (UTC)

I've following problem when I try to upgrade with yay -Syyu in Manjaro 6.1.26-1:

:: Searching for updates in AUR...
 -> No AUR package found for libheif=1.16.1
:: Checking for updates in the repositories...
 -> manjaro-hello: local (0.7.0-6) is newer than extra (0.7.0-5)
 -> Packages not in AUR: manjaro-documentation-en  manjaro-firmware  systemd-fsck-silent
 -> Orphan (unmaintained) AUR Packages: lib32-gd  lib32-libraqm
 -> AUR packages marked as out-of-date: lib32-libdav1d  lib32-libxpm  responsively
:: 3 Packages to upgrade/install.
2  aur/lib32-libheif  1.14.2-1 -> 1.16.1-2
1  aur/lib32-rav1e             -> 0.6.3-1
   (Make Dependency of lib32-libheif)
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" o repository name)
 -> Excluding packages may cause partial upgrades and break systems
==> 
 -> could not find all required packages: libheif =1.16.1

papavlos commented on 2023-05-07 22:15 (UTC)

Thank you for fixing.

korimitsu commented on 2023-05-07 15:53 (UTC)

works now good job!

sl1pkn07 commented on 2023-05-07 12:45 (UTC)

try again

korimitsu commented on 2023-05-07 11:48 (UTC)

Also

loading packages...
resolving dependencies...
warning: cannot resolve "libaom.so=3-32", a dependency of "lib32-libheif"
:: The following package cannot be upgraded due to unresolvable dependencies:
      lib32-libheif

:: Do you want to skip the above package for this upgrade? [y/N] 
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libaom.so=3-32' required by lib32-libheif