Package Details: libportal-inputcapture-gtk3 0.7.1+r8+g1add346-2

Git Clone URL: https://aur.archlinux.org/libportal-inputcapture.git (read-only, click to copy)
Package Base: libportal-inputcapture
Description: GIO-style async APIs for most Flatpak portals with patches to support input capture for input-leap - GTK 3 backend
Upstream URL: https://github.com/flatpak/libportal
Licenses: LGPL3
Conflicts: libportal-gtk3
Provides: libportal-gtk3, libportal-gtk3.so
Replaces: libportal-gtk3
Submitter: luciferin
Maintainer: luciferin
Last Packager: luciferin
Votes: 0
Popularity: 0.000000
First Submitted: 2023-10-10 12:58 (UTC)
Last Updated: 2023-11-22 15:42 (UTC)

Sources (1)

Latest Comments

benm commented on 2023-11-22 16:53 (UTC)

This most recent change was successful

luciferin commented on 2023-11-22 15:45 (UTC)

Interesting, I so far can't reproduce that error on my system. For now I've submitted an new PKGBUILD here that disables the new qt6 portal, since I don't believe we install files for it anyway. I'm not 100% certain if it will cause errors. It might be a better solution for me to use cherry pick to build and older version, but for now I kind of want to stick with a true git release to capture any new commits.

Anyway, let me know if any new errors crop up on your system. qt6-base should not longer be required now.

benm commented on 2023-11-22 14:56 (UTC)

-- Could NOT find Qt6LinguistTools (missing: Qt6LinguistTools_DIR)
CMake Error at src/gui/CMakeLists.txt:3 (find_package):
  Found package configuration file:

    /usr/lib/cmake/Qt6/Qt6Config.cmake

  but it set Qt6_FOUND to FALSE so package "Qt6" is considered to be NOT
  FOUND.  Reason given by package:

  Failed to find required Qt component "LinguistTools".

  Expected Config file at
  "/usr/lib/cmake/Qt6LinguistTools/Qt6LinguistToolsConfig.cmake" does NOT
  exist



  Configuring with --debug-find-pkg=Qt6LinguistTools might reveal details why
  the package was not found.

  Configuring with -DQT_DEBUG_FIND_PACKAGE=ON will print the values of some
  of the path variables that find_package uses to try and find the package.



-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().
    Aborting...
 -> Failed to install layer, rolling up to next layer.error:error making: input-leap-inputcapture - exit status 4

luciferin commented on 2023-10-10 13:00 (UTC) (edited on 2023-10-10 13:01 (UTC) by luciferin)

Initial publication for inputcapture support in libportal. This requires input-leap to be rebuilt from source with "-D INPUTLEAP_BUILD_LIBEI=TRUE" AFTER these packages are installed. There are existing known bugs, like you can not share your input device if you have multi-monitor.