Package Details: lxqt-qtplugin-git 0.10.0.8.g411f696-1

Git Clone URL: https://aur.archlinux.org/lxqt-qtplugin-git.git (read-only)
Package Base: lxqt-qtplugin-git
Description: LXQt platform integration for Qt
Upstream URL: http://lxqt.org
Licenses: GPL2
Conflicts: lxqt-qtplugin
Provides: lxqt-qtplugin
Submitter: jleclanche
Maintainer: jleclanche
Last Packager: jleclanche
Votes: 34
Popularity: 0.816493
First Submitted: 2014-03-23 13:37
Last Updated: 2016-08-07 20:09

Latest Comments

pmattern commented on 2016-09-06 15:32

@jdarnold
No. Basically libqtxdg-git is pulled as dependency of liblxqt-git. So this problem boils down to the fact that AUR packages aren't rebuilt automatically when changes regarding their dependencies would actually require rebuilding.
But this is a problem of AUR as a whole which its users have to be aware of, not a problem of the particular packages we're discussing here.

jdarnold commented on 2016-08-25 16:46

If that's the case, shouldn't libqtxdg-git be a dependency?

c-korn commented on 2016-08-08 17:20

@ArthurBorsboom You have to update libqtxdg-git

ArthurBorsboom commented on 2016-08-08 13:18

aur-lxqt-qtplugin-git/src/lxqt-qtplugin/src/lxqtplatformtheme.cpp:47:51: fatal error: private/xdgiconloader/xdgiconloader_p.h: No such file or directory

yan12125 commented on 2016-08-03 17:14

As @pmattern said, libdbusmenu-qt5 is necessary.

wgnm commented on 2016-07-04 13:32

I got this compiler error and had to install libqtxdg-git too (libqtxdg 1.3.0-3 was installed before):

[ 45%] Building CXX object src/CMakeFiles/qtlxqt.dir/lxqtplatformtheme.cpp.o
In file included from /var/abs/local/lxqt-qtplugin-git/src/lxqt-qtplugin/src/lxqtplatformtheme.cpp:47:0:
/var/abs/local/lxqt-qtplugin-git/src/lxqt-qtplugin/src/private/xdgiconloader/xdgiconloader_p.h:51:34: fatal error: xdgiconloader_export.h: No such file or directory
#include <xdgiconloader_export.h>
^
compilation terminated.
make[2]: *** [src/CMakeFiles/qtlxqt.dir/build.make:98: src/CMakeFiles/qtlxqt.dir/lxqtplatformtheme.cpp.o] Error 1

pmattern commented on 2015-11-30 23:59

As of debe49f the package needs to depend on libdbusmenu-qt5.

vri commented on 2015-02-12 09:29

the package version in PKGBUILD is pkgver=0.9.0.2.gf1a0712. After running makepkg, it is set to 0.9.0, which seems to be older; hence, an AUR helper such as pacaur keeps believing that it should update this package.

Ilya87 commented on 2014-06-29 17:01

In order to make plugin work you should change line 20 in lxqt-qtplugin/qt5/CMakeLists.txt to set(QT_PLUGINS_DIR ${QT_PLUGINS_DIR}/qt/plugins) because Arch Linux uses /usr/lib/qt, not /usr/lib/qt5 folder.

dobo commented on 2013-12-13 23:50

Renamed, thanks.

All comments