Package Details: megasync 4.3.7.0-1

Git Clone URL: https://aur.archlinux.org/megasync.git (read-only, click to copy)
Package Base: megasync
Description: Easy automated syncing between your computers and your MEGA cloud drive
Upstream URL: https://github.com/meganz/MEGAsync
Licenses: custom:MEGA LIMITED CODE REVIEW LICENCE
Submitter: son_link
Maintainer: Kozeid
Last Packager: Kozeid
Votes: 358
Popularity: 4.81
First Submitted: 2014-09-01 18:12
Last Updated: 2020-11-27 18:50

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

teacher4711 commented on 2020-07-27 21:40

@FabioLolix

OK, thank you. I rebuilt the package and now it starts.

Now only the version upgrade to 4.3.3 has to be done.

Thanks!

FabioLolix commented on 2020-07-27 19:31

@teacher4711 you need to rebuild megasync against libraw new version

Palanthis commented on 2020-07-27 19:25

Quick bandaid for the libraw error: sudo ln -sf /usr/lib/libraw.so.20 /usr/lib/libraw.so.19

teacher4711 commented on 2020-07-27 16:09

The latest libraw 0.20.0-1 prevents megasync from starting (megasync: error while loading shared libraries: libraw.so.19: cannot open shared object file: No such file or directory) Reverting back to libraw 0.19.5-3 fixes the issue.

tinywrkb commented on 2020-07-27 15:38

I haven't built the PKGBUILD as I'm using Flatpak but the latest 4.3.3.0 seems to need something like this: "QMAKE_INCDIR+=$PWD/MEGASync/mega/include" "QMAKE_INCDIR+=$PWD/MEGASync/mega/bindings/qt"

And I had to drop pdfium.patch as it broke sdk.pri. I just disabled pdfium.

attila123 commented on 2020-06-29 10:42

Hi, does not build for me (with Manjaro package base at least).Eg. "gui/MegaSpeedGraph.h:31:18: error: field ‘linePath’ has incomplete type ‘QPainterPath’", and the same error from other source files.

tinywrkb commented on 2020-06-18 20:17

@Kozeid, the package is missing xdg-utils and xorg-xrdb. The app runs fine without them but will complain, just start it from the command line in a clean chroot.
I would add xdg-utils to depends and xorg-xrdb to optdepnds.
There a bug report regarding the xrdb dependency so you probably want to subscribe to it.

I plan to open a bug report about the linking against libstc++fs.a static lib that is needed for <std::experimental::filesystem>.
If you look at src/MEGASync/mega/src/autocomplete.cpp you'll see that it has a test for cpp17 and it uses <std::filesystem> instead if true.
Tthis means it doesn't really need libstc++fs.a which I confirmed by patching the lib linking out, building in a clean chroot, and it seems to work fine without needing to force -std=c++17 cxxflag, but just keep this cxxflag in mind.
This libstc++fs.a static linking is a non-issue for Arch but quite a problem with Flatpak which is why I'm reporting it.

edit: megasync libstdc++fs bug report

u666sa commented on 2020-06-07 11:14

@Kozeid edit PKGBUILD change libpdfium to libpdfium-nojs, otherwise it doesn't build, says can't satisfy dependencies.

ava1ar commented on 2020-06-02 16:29

Tiny patch is required to fix build with QT 5.15+: https://pastebin.com/cJb5MG1a

DanielRichtmann commented on 2020-05-12 11:40

For anyone seeing a segfault, see https://github.com/meganz/MEGAsync/issues/443.