Package Details: megasync 4.3.7.0-1

Git Clone URL: https://aur.archlinux.org/megasync.git (read-only, click to copy)
Package Base: megasync
Description: Easy automated syncing between your computers and your MEGA cloud drive
Upstream URL: https://github.com/meganz/MEGAsync
Licenses: custom:MEGA LIMITED CODE REVIEW LICENCE
Submitter: son_link
Maintainer: Kozeid
Last Packager: Kozeid
Votes: 359
Popularity: 5.18
First Submitted: 2014-09-01 18:12
Last Updated: 2020-11-27 18:50

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

bartus commented on 2020-03-06 08:29

@michaldybczak: I've stripped the pdfium dep, try this one

bartus commented on 2020-03-06 08:02

@michaldybczak: Sadly it looks like this is a required, not optional component: `include/mega.h

#if defined(REQUIRE_HAVE_PDFIUM) && !defined(HAVE_PDFIUM)
#error compilation with HAVE_PDFIUM is requir

michaldybczak commented on 2020-03-05 22:28

libpdfium is now considered a dependency! Is it really? I could only get it through AUR (libpdfium-nojs) which tells me that this is some obscure package and there should be some better alternative. I needed to download over 400MB to install it! This looks ridiculous.

radu commented on 2020-03-05 14:08

Cannot build megasync 4.2.5.4 I tried updating PKGBUILD with -fpermissive and still doesn't build.

WARNING: Project ERROR: Unknown module(s) in QT: macextras winextras
lprodump error: Cannot open ~/.cache/yay/megasync/src/MEGAsync/src/jkIoBR.json for writing.
==> ERROR: A failure occurred in build().

strobelite commented on 2020-03-01 18:11

For those on GNOME wondering how to run MEGAsync in the background (you may get a notification on startup that it can't find a system tray,) I used the GNOME extension called Tray Icons. Install that, then restart MEGAsync, and now it will run in the background the way it was supposed to.

ix5231 commented on 2019-10-15 10:33

Workaround: Add -fpermissive to QMAKE_CXXFLAGS

For the AUR PKGBUILD:

diff --git a/PKGBUILD b/PKGBUILD
index 38d9165..0947609 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,7 +55,7 @@ build() {

     # build megasync
     cd "../.."
-    qmake-qt5 "CONFIG += FULLREQUIREMENTS" MEGA.pro
+    qmake-qt5 "CONFIG += FULLREQUIREMENTS" "QMAKE_CXXFLAGS += -fpermissive" MEGA.pro
     lrelease-qt5 MEGASync/MEGASync.pro
     make
 }

Stane1983 commented on 2019-10-08 16:48

Error while building on gcc 9.2.0:

google_breakpad/client/linux/handler/exception_handler.cc:107:12: error: 'int tgkill(pid_t, pid_t, int)' was declared 'extern' and later 'static' [-fpermissive] 107 | static int tgkill(pid_t tgid, pid_t tid, int sig) { | ^~~~~~

dnmodder commented on 2019-10-03 20:11

Can you change the source for tar.gz? yay marks it to me as a devel package and I think it's due to that.

alfa8my commented on 2019-09-05 06:03

I am trying to update this, but the package cannot be downloaded: "HTTP server doesn't seem to support byte ranges. Cannot resume."

Kozeid commented on 2019-08-03 17:22

Expired signatures are only used by packages from MEGA's official repositories. This AUR package is not affected.