Package Details: mintstick 1.5.7-1

Git Clone URL: (read-only, click to copy)
Package Base: mintstick
Description: A graphical tool that allows you to format USB sticks and create bootable USB sticks.
Upstream URL:
Licenses: GPL
Conflicts: mintstick-git
Submitter: Sam-Burgos
Maintainer: Sam-Burgos
Last Packager: Sam-Burgos
Votes: 14
Popularity: 0.000060
First Submitted: 2018-06-27 17:23 (UTC)
Last Updated: 2023-11-30 19:58 (UTC)

Latest Comments

1 2 Next › Last »

willemw commented on 2022-10-15 13:48 (UTC)

conflicts=(mintstick-git) should be removed. Conflicts should only be defined in other mintstick package(s).

Sam-Burgos commented on 2022-08-18 16:32 (UTC)

@zelimir: thanks for the comment, please remember that if you notice that a new version of a package exists, please flag the package as out-of-date and don't leave comments, since the package has been updated please delete your comment

zelimir commented on 2022-08-12 06:48 (UTC)

There is no 1.4.9 version anymore on Mint packages, the latest is 1.5.0. Can you update aur package?

yochananmarqos commented on 2021-05-27 16:41 (UTC)

For v1.4.5, the was not updated to match the new filenames. For now, this can be added to prepare():

  sed -i 's||com.linuxmint.mintstick|g'
  sed -i 's||mintstick.ui|g'

Comodin commented on 2021-04-27 03:23 (UTC)

Before install mintstick install this package to solved dependencies.

m8D2 commented on 2021-03-10 00:42 (UTC) (edited on 2021-03-10 18:22 (UTC) by m8D2)

Oh I figured it out. The AUR python-pyparted is outdated, and it has to be updated to the latest upstream version.

Here's how:

  1. Create an empty directory

  2. inside it, create a text file named PKGBUILD

  3. Copy and paste the following content to this PKGBUILD file and save (as you may discover, only pkgrel, pkgver and sha512sum() are updated from v3.11.6, nothing malicious, don't trust me (or anyone else), please verify it yourself):

# Maintainer: Nikos Skalkotos <skalkoto at gmail dot com>
# Contributor: Christian Hesse <>
# Contributor: Dennis Værum <dennis.vaerum (at) gmail (dot) com> 
# Contributor: Achilleas Pipinellis <axilleas archlinux info>
# Contributor: Stéphane Gaudreault <>
# Contributor: kfgz <kfgz at interia pl>
# Contributor: Gökmen Görgen <gkmngrgn at gmail dot com>
# Contributor: Baurzhan Muftakhidinov <baurthefirst (at) gmail (dot) com>

pkgdesc="Python module for GNU parted"
arch=('i686' 'x86_64')
makedepends=('pkg-config' 'python>=3.5' 'parted>=3.0')

build() {
  cd "${srcdir}/${_pkgname}-${pkgver}"
  python build

package() {
  depends=('python' 'parted>=3.0')

  cd "${srcdir}/${_pkgname}-${pkgver}"
  python install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
  install -Dm755 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
  install -Dm755 AUTHORS "${pkgdir}/usr/share/doc/${pkgname}/AUTHORS"
  install -Dm755 TODO "${pkgdir}/usr/share/doc/${pkgname}/TODO"
  install -Dm755 README "${pkgdir}/usr/share/doc/${pkgname}/README"

use your commandline to navigate to this directory and make a new package:

$ makepkg -siC

It'll update the python-pyparted package, and that's it.

The python-pyparted AUR package maintainer isn't responding to update request right now, and basically this is how you would now updating it by yourself.

m8D2 commented on 2021-03-10 00:28 (UTC)


I recently have this error, the GUI will report "An error occurred."

If run in cmdline, it'll have this:

$ sudo mintstick -m format -u /dev/sda
Traceback (most recent call last):
  File "/usr/lib/mintstick/", line 7, in <module>
    import parted
ModuleNotFoundError: No module named 'parted'
An error occurred.

yochananmarqos commented on 2020-12-03 05:55 (UTC) (edited on 2020-12-05 15:46 (UTC) by yochananmarqos)

@Sam-Burgos: The icons and man page are missing (edited):

package() {
  cd ${pkgname}

  ## Creating the directories to copy the files
  install -d "$pkgdir/usr/bin"
  install -d "$pkgdir/usr/share/applications"
  install -d "$pkgdir/usr/share/polkit-1/actions"
  cp -rp share/{icons,nemo} "$pkgdir/usr/share"

  ## script is the one who contains all the installation process

  ## Install man page
  install -Dm644 "debian/$pkgname.1" -t "$pkgdir/usr/share/man/man1"

Sam-Burgos commented on 2020-05-26 13:54 (UTC)

@asasione: the issue was with the package "python-pyparted", which was updated recently, I have tried to reinstall and now it works (you might have to clean the cache on your AUR helper in case you tried to install it previously)

asasione commented on 2020-05-26 08:31 (UTC)

This package won't install because of python-pyparted since the recent GCC 10 update, I'm getting a gcc failed error