Package Details: mve-git r1232.97241fb-1

Git Clone URL: https://aur.archlinux.org/mve-git.git (read-only)
Package Base: mve-git
Description: Image-based geometry reconstruction pipeline, structure-from-motion, (shading-aware) multi-view-stereo, surface-reconstruction, texturing,
Upstream URL: http://www.gcc.tu-darmstadt.de/home/proj/mve/
Keywords: multi-view-stereo structure-from-motion surface-reconstruction texturing
Licenses: GPL, BSD
Submitter: bartus
Maintainer: bartus
Last Packager: bartus
Votes: 0
Popularity: 0.000000
First Submitted: 2016-10-17 23:13
Last Updated: 2018-05-21 12:15

Latest Comments

ph1r3ph0x commented on 2018-05-10 10:01

makepkg fails with an error in check()

gtest_scene.cc:532:5: Fehler: der Typ »const {anonymous}::bundle_cameras_match(mve::Bundle::Ptr, mve::Bundle::ConstPtr)::<lambda(float, float)>« der »constexpr«-Variable »match« ist kein Literal };

Did anyone experience the same problem?

bartus commented on 2018-04-03 19:36

@Harvie: Can't reproduce the issue... I tried both working os and chroot. Could you try clean rebuild package? _mm_maskstore_ps is defined by gcc.

grep -RI _mm_maskstore_ps /usr/lib/gcc/

/usr/lib/gcc/x86_64-pc-linux-gnu/5.5.0/include/avxintrin.h:_mm_maskstore_ps (float *__P, __m128i __M, __m128 __A)
/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.1/include/avxintrin.h:_mm_maskstore_ps (float *__P, __m128i __M, __m128 __A)
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.4/include/avxintrin.h:_mm_maskstore_ps (float *__P, __m128i __M, __m128 __A)
/usr/lib/gcc/x86_64-pc-linux-gnu/7.3.1/include/avxintrin.h:_mm_maskstore_ps (float *__P, __m128i __M, __m128 __A)

Harvie commented on 2018-03-31 11:42

In file included from /tmp/yaourt-tmp-harvie/aur-mve-git/src/mvs-texturing/elibs/mapmap/mapmap/header/vector_math.h:354:0,

/tmp/yaourt-tmp-harvie/aur-mve-git/src/mvs-texturing/elibs/mapmap/mapmap/source/vector_math.impl.h:1049:9: error: ‘_mm_maskstore_ps’ was not declared in this scope

bartus commented on 2017-06-05 09:29

@gmueller Yep, opengl.patch pull request got accepted ;)

gmueller commented on 2017-06-05 06:09

Hi,

gcc5 and the umve.opengl.patch are not needed anymore.