Package Details: neo4j-community 4.3.2-1

Git Clone URL: https://aur.archlinux.org/neo4j-community.git (read-only, click to copy)
Package Base: neo4j-community
Description: A fully transactional graph database implemented in Java
Upstream URL: http://neo4j.org/
Licenses: custom
Conflicts: neo4j-enterprise
Submitter: tucho
Maintainer: hakami1024
Last Packager: hakami1024
Votes: 63
Popularity: 0.20
First Submitted: 2015-12-30 05:23 (UTC)
Last Updated: 2021-08-04 06:28 (UTC)

Latest Comments

MichaelSx commented on 2022-01-15 10:21 (UTC)

I have adapted the PKGBUILD, feel free to test and change to your needs or give suggestions for improvement. I can at least run it via systemctl on my system now, not quite sure if I missed something specific to my config: https://github.com/michaelsx/aur_neo4j-community

dalu commented on 2021-11-08 06:07 (UTC)

Your upstream url is also using some tracking link shortener that returns a 404

dalu commented on 2021-11-08 06:03 (UTC) (edited on 2021-11-08 06:03 (UTC) by dalu)

systemctl start neo4j.service fails with the same error

Nov 08 06:46:26 hostname neo4j[7710]: Error: Could not find or load main class org.neo4j.server.startup.Neo4jCommand
Nov 08 06:46:26 hostname neo4j[7710]: Caused by: java.lang.ClassNotFoundException: org.neo4j.server.startup.Neo4jCommand
Nov 08 06:46:26 hostname systemd[1]: neo4j.service: Control process exited, code=exited, status=1/FAILURE
Nov 08 06:46:26 hostname systemd[1]: neo4j.service: Failed with result 'exit-code'.

amael commented on 2021-10-30 23:20 (UTC) (edited on 2021-10-30 23:20 (UTC) by amael)

diff --git a/PKGBUILD b/PKGBUILD
index d272282..a2bd7b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,7 +55,7 @@ package() {
   [[ $(ls -A logs/* 2>/dev/null) ]] && cp -r logs/* $pkgdir/$LOG_DIR

   # Copy JARs in lib and plugins
-  LIB_DIR=usr/share/java/neo4j/lib
+  LIB_DIR=usr/share/neo4j/lib
   install -dm755 $pkgdir/$LIB_DIR
   [[ $(ls -A lib/* 2>/dev/null) ]] && cp -r lib/* $pkgdir/$LIB_DIR

CravateRouge commented on 2021-08-23 13:50 (UTC)

@GI_Jack the neo4j JARS are installed in /usr/share/java/neo4j/lib but the bash script /bin/neo4j adds /usr/share/neo4j/lib/ instead. A quick hack is to add /usr/share/java/neo4j/lib/ in the classpath before the java call but in my opinion, the best would be to change the lib installation location.

GI_Jack commented on 2021-08-16 00:11 (UTC)

any ideas?

Error: Could not find or load main class org.neo4j.server.startup.Neo4jCommand
Caused by: java.lang.ClassNotFoundException: org.neo4j.server.startup.Neo4jCommand

hakami1024 commented on 2021-08-01 03:21 (UTC)

@cvelteren, should work with systemd: systemctl start neo4j

cvelteren commented on 2021-05-01 10:21 (UTC) (edited on 2021-05-01 10:21 (UTC) by cvelteren)

Is this package still maintained? It does not run out of the box.

Running sudo NEO4J_HOME=/usr/share/java/neo4j neo4j start requires making a log directory and then it complains about a missing conf file.

Powersource commented on 2020-09-05 21:01 (UTC)

Yeah I needed to follow this apparently https://wiki.archlinux.org/index.php/Java#Switching_between_JVM

ottoshmidt commented on 2020-09-03 14:21 (UTC)

@Powersource you apparently need Java 11 instead of 8.

Powersource commented on 2020-09-01 17:39 (UTC)

Getting this when running either neo4j start or neo4j-admin

ERROR! Neo4j cannot be started using java version 1.8.0_265. 
* Please use Oracle(R) Java(TM) 11, OpenJDK(TM) 11 to run Neo4j.
* Please see https://neo4j.com/docs/ for Neo4j installation instructions.

mnd999 commented on 2020-05-09 11:46 (UTC)

Have you thought about moving the jars to /usr/share/java/neo4j/lib?

I had more success getting neo4j-admin to work with the following patch:

diff --git a/PKGBUILD b/PKGBUILD
index b217852..54c40ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
 # Contributor: Marcel Campello Ferreira <marcel.campello.ferreira@gmail.com>
 pkgname=neo4j-enterprise
 pkgver=4.0.4
-pkgrel=1
+pkgrel=2
 pkgdesc='A fully transactional graph database implemented in Java'
 arch=(any)
 url=http://neo4j.org/
@@ -19,7 +19,7 @@ source=(http://dist.neo4j.org/neo4j-enterprise-$pkgver-unix.tar.gz
         neo4j.service
         neo4j-tmpfile.conf)
 sha256sums=('c511128e00abc51feceaef2029c1a4d37af53b80d78621f98a788b56d9fc51ec'
-            '40ecfbdcb843577a0e9b677e9c0cc7ab4899962309d6148ce8fcd1da35560103'
+            'db152528593b4177e047ea642d0c8d53f777266a09c1803aa4f8363336f646b1'
             'f95936abc4a519b01d2cd987cd38a253003cf4cd39bfab29948708e82d98de66'
             '4e56e56e38cfe91755adf76642972bece509a9fd3f7d1851d65715fff762b9db'
             'e1311352e05b1e698599b91883141b938ceb418abd7e6bc11cc964854f0a21e1')
@@ -47,7 +47,7 @@ package() {
   [[ $(ls -A logs/* 2>/dev/null) ]] && cp -r logs/* $pkgdir/$LOG_DIR

   # Copy JARs in lib and plugins
-  LIB_DIR=usr/share/java/neo4j
+  LIB_DIR=usr/share/java/neo4j/lib
   install -dm755 $pkgdir/$LIB_DIR
   [[ $(ls -A lib/* 2>/dev/null) ]] && cp -r lib/* $pkgdir/$LIB_DIR

diff --git a/neo4j.conf b/neo4j.conf
index ec31d54..694e900 100644
--- a/neo4j.conf
+++ b/neo4j.conf
@@ -13,7 +13,7 @@ dbms.directories.data=/var/lib/neo4j/data
 dbms.directories.plugins=/usr/share/java/neo4j/plugins
 dbms.directories.certificates=/etc/neo4j/certificates
 dbms.directories.logs=/var/log/neo4j
-dbms.directories.lib=/usr/share/java/neo4j
+dbms.directories.lib=/usr/share/java/neo4j/lib
 dbms.directories.run=/run/neo4j
 dbms.directories.metrics=/var/lib/neo4j/data

hakami1024 commented on 2020-02-22 21:44 (UTC)

Updated

Torxed commented on 2020-02-12 09:50 (UTC)

Getting it to run:

$ sudo -s     #Not sure this is fully needed, but this outdated crap is annoying)
# mkdir -p /usr/share/java/neo4j/logs/
# NEO4J_HOME=/usr/share/java/neo4j neo4j start

It'll complain that /usr/share/java/neo4j/conf/neo4j.conf doesn't exists. And if you're here for bloodhound, then simply login to the web-tool once via http://localhost:7474/ and change the password before running bloodhound. If it still doesn't work, do

# cd /usr/share/java/neo4j/data/databases/
# mv graph.db/ graph.db.orig
# cp -r /usr/share/bloodhound/BloodHoundExampleDB.graphdb/ graph.db

And you'll get the example up and running, which you can wipe.

ottoshmidt commented on 2020-01-28 11:36 (UTC)

I am unhappy that this package is vastly outdated.

roschaefer commented on 2019-02-20 11:15 (UTC) (edited on 2019-02-20 11:16 (UTC) by roschaefer)

Symlink is broken:

$ cypher-shell
find: ‘/usr/bin/../share/cypher-shell’: No such file or directory

A quickfix is to add neo4j binary folder to $PATH:

export PATH="/usr/share/neo4j/bin/:$PATH"

So the actual cypher-shell script gets called first.

hakami1024 commented on 2019-01-10 22:13 (UTC)

Thanks, oliv. Updated.

oliv commented on 2018-12-10 10:44 (UTC)

The systemd service file must be updated as neo4j java libraries are now stored in a different folder: From: Environment=NEO4J_HOME=/usr/share/neo4j

To: Environment=NEO4J_HOME=/usr/share/java/neo4j

goddessfreya commented on 2018-07-03 08:05 (UTC)

I've made a new package which uses the latest git version here: https://aur.archlinux.org/packages/neo4j-git/

It's based on the structure of the Debian package.

ryukinix commented on 2017-12-04 04:27 (UTC)

I have multiple issues with this package.

The default enviroment variables is set wrong for me, I need to change at least NEO4J_HOME and when I try execute the server I receive:

Error: Could not find or load main class org.neo4j.server.CommunityEntryPoint

scottwernervt commented on 2017-10-17 14:39 (UTC)

Running into the following error when using the neo4j bin tools: $ neo4j-import Error: Could not find or load main class org.neo4j.tooling.ImportTool $ neo4j-admin import Error: Could not find or load main class org.neo4j.commandline.admin.AdminTool https://github.com/neo4j/neo4j/issues/8347

kawzeg commented on 2017-08-19 19:43 (UTC)

Any progress on the 3.2 update? I tried my hand at modifying the PKGBUILD which seems to work on my machine, but I have no experience with that.

radio_rogal commented on 2017-07-16 16:50 (UTC)

Looks like there is stable 3.2 branch. So I will prepare next 3.2.2 not 3.0.10.

Indeed commented on 2017-04-19 08:58 (UTC)

IMO docker based deployment is most desirable for now.

Jam0864 commented on 2017-02-07 04:23 (UTC)

@wanderstudent: Use systemctl with the neo4j.service file rather than the neo4j startup script, which doesn't appear to work.

tucho commented on 2016-10-11 14:36 (UTC)

Here it is, callofdutyops. Thank you for let me know.

callofdutyops commented on 2016-10-10 12:32 (UTC)

Thanks a lot for your hard work! The new version 3.0.6 is released, please update.

wanderstudent commented on 2016-09-07 17:06 (UTC)

Hey - Im getting strange errors.... 1) the startup script tries to create the pid file in /usr/run... instead of /var/run... (why?!) - by changing a few lines of the startup script I got it to run, but now it is stuck again and /var/log/neo4j.log says: 2) "Fehler: Hauptklasse org.neo4j.server.CommunityEntryPoint konnte nicht gefunden oder geladen werden" e.g. "Error: Main class ... could not be found or loaded" What is wrong? Google couldn't help...

mister_karim commented on 2016-05-11 15:14 (UTC)

Thanks for you're hard work

tucho commented on 2016-05-04 00:48 (UTC)

Hello, fellow Archers. In this new major version, as we could expect, the Neo4j distributable changed a lot, both in its directory structure and in its admin scripts. I am taking extra care on creating this new version and because of that you'll need a little more patience. It will be ready when it will be ready, but I promise it will be soon. Thank you, Mister Karin. It was a wonderful party!!

mister_karim commented on 2016-05-03 01:34 (UTC)

Happy Birthday for her, hope you enjoyed your time

tucho commented on 2016-04-30 02:40 (UTC) (edited on 2016-04-30 02:43 (UTC) by tucho)

Merci, monsieur Karim. I'm working on it, but tomorrow (Saturday, I'm on GMT-3) is my daughter's birthday party and I'm affraid we'll have to wait until Sunday or maybe Monday for Nodes 'n Edges. It will be worth it though. Best regards

mister_karim commented on 2016-04-30 01:02 (UTC) (edited on 2016-04-30 01:04 (UTC) by mister_karim)

thanks for maintaining the package Version 3.0.0 is out

tucho commented on 2016-03-27 17:02 (UTC)

Version 2.3.3.

tucho commented on 2016-01-26 18:29 (UTC)

You are welcome, jinal. I try my best to keep it up-to-date and reliable.

jinal commented on 2016-01-26 18:12 (UTC)

Thanks tucho for the quick update! And thank you for maintaining the package. :)

tucho commented on 2016-01-26 15:47 (UTC)

Version 2.3.2.

tucho commented on 2015-12-27 00:18 (UTC)

Here it is, version 2.3.1. Sorry for my absence.

mgd commented on 2015-10-16 09:00 (UTC)

All I said about 2.2.3, 2.2.4 and 2.2.5 seems to be is still valid for 2.2.6. Kind regards, Michael

ajendrex commented on 2015-10-15 21:07 (UTC)

Hello, Is it possible to ask for an upgrade to 2.2.6? Thanks in advance, H.

mgd commented on 2015-08-28 12:51 (UTC)

Just tried this with 2.2.5 - works unchanged

mgd commented on 2015-08-27 07:57 (UTC)

FWIW I've taken the 2.2.1 patches and adjusted them for 2,2,3. These seem to work unchanged for 2.2.4. I have no idea if that is all that needs to be done. However on my system it seems to work...but then I'm only toying with it... Only changes were to bin.patch and conf.patch. Since I can't add attachments to this comment and the patches are 10k in total size - anybody interested contact me directly and I'll send them. Hope it helps somebody, regards

Dietr1ch commented on 2015-08-13 23:09 (UTC)

neo4j.com/docs/stable/ says that we should be on v2.2.4

mgd commented on 2015-04-15 16:55 (UTC)

Thanks alot ! I did not see error messages regarding the number of files. Since I'm just starting to toy with neo4j I wasn't sure this was due to me not putting real load on the server...

tucho commented on 2015-04-15 14:56 (UTC)

Version 2.2.1-1 (soon enough, right?)

tucho commented on 2015-04-15 14:23 (UTC)

Here it is , folks. Sorry for the delay. And I know, we have 2.2.1 already. Coming soon... @mgd: Thank you very much for your reports. Let me briefly explain what I did on those matters. 1) There is an undocumented property, dbms.security.auth_store.location, that tells Neo4j where to create the user auth data directory. I have put it in /etc/neo4j/neo4j-server.properties pointing to /var/lib/neo4j/data/dbms/auth, so that the owner is correctly set. 2) The max number of opened files was already been addressed by the systemd service declaration. Did you see any error messages on this? Once again, thank you.

mgd commented on 2015-04-14 14:16 (UTC)

As an afterthought: Some stuff from the neo4j manual, especially the bottom of the section "24.12 Linux Performance Guide" IMO should be mentioned during installation of the package. Namely I mean these lines: Edit /etc/security/limits.conf and add these two lines: neo4j soft nofile 40000 neo4j hard nofile 40000 Edit /etc/pam.d/su and uncomment or add the following line: session required pam_limits.so A restart is required for the settings to take effect. Kind regards

mgd commented on 2015-04-14 14:12 (UTC)

I have tried to adjust the package file for 2.1.7 to 2.2.0. With a few manual adjustments (some patches need manual tweaking) it worked and I could create a package that installed. However upon starting the server it almost instantly crashes with an exception. The server tries to create an authstore under /usr/share/java/neo4j/data. /usr/share/java/neo4j is root:root 755 and thus the process owned by neo4j can't create that directory. I assume the intention of the changed directory layout as of the ArchLinux package is that the above store should instead be created under /var/lib/neo4j (and then ./data) which is neo4j:neo4j 755 and thus would work. I have no idea how to tell the neo4j server to use that other path instead. I therefor manually created /usr/share/java/neo4j/data and made it neo4j:neo4j 755 and after that the server starts and seems to run w/o apparent issues. Any ideas how to do this properly ?

mudrii commented on 2015-01-12 10:50 (UTC)

Tucho Thank you for update I just tryed and didn't work in the first run as I needed to uninstall old version first and install new one , once done all sems to work again now. Thank you

tucho commented on 2015-01-11 13:07 (UTC)

Ion, please try this new version and tell me if we've made any progress.

mudrii commented on 2015-01-08 13:48 (UTC)

ssue still not resolved after so many months better to keep updating and installing manually then wait for maintainer to reply :(

mudrii commented on 2014-11-05 16:59 (UTC)

After Update wit new neo4j version neo4j-2.1.5-2 can't strat anymore the service sudo systemctl status neo4j.service ● neo4j.service - Neo4j Loaded: loaded (/usr/lib/systemd/system/neo4j.service; disabled) Drop-In: /etc/systemd/system/neo4j.service.d └─java_home.conf Active: failed (Result: exit-code) since Thu 2014-11-06 00:36:32 SGT; 9s ago Process: 6478 ExecStart=/usr/bin/neo4j start (code=exited, status=1/FAILURE) Nov 06 00:36:31 archPC neo4j[6478]: Using additional JVM arguments: -server -XX:+DisableExplicitGC -Dorg.neo4j.server.properties=/etc/ne... Nov 06 00:36:31 archPC neo4j[6478]: Starting Neo4j Server...WARNING: not changing user Nov 06 00:36:32 archPC neo4j[6478]: process [6595]... waiting for server to be ready.. Failed to start within 120 seconds. Nov 06 00:36:32 archPC neo4j[6478]: Neo4j Server may have failed to start, please check the logs. Nov 06 00:36:32 archPC systemd[1]: neo4j.service: control process exited, code=exited status=1 Nov 06 00:36:32 archPC systemd[1]: Failed to start Neo4j. Nov 06 00:36:32 archPC systemd[1]: Unit neo4j.service entered failed state. and sudo journalctl -xn -- Logs begin at Wed 2014-11-05 22:06:31 SGT, end at Thu 2014-11-06 00:57:31 SGT. -- Nov 06 00:57:20 archPC neo4j[6737]: Using additional JVM arguments: -server -XX:+DisableExplicitGC -Dorg.neo4j.server.properties=/etc/neo4j Nov 06 00:57:20 archPC neo4j[6737]: Starting Neo4j Server...WARNING: not changing user Nov 06 00:57:21 archPC neo4j[6737]: process [6854]... waiting for server to be ready.. Failed to start within 120 seconds. Nov 06 00:57:21 archPC neo4j[6737]: Neo4j Server may have failed to start, please check the logs. Nov 06 00:57:21 archPC systemd[1]: neo4j.service: control process exited, code=exited status=1 Nov 06 00:57:21 archPC systemd[1]: Failed to start Neo4j. -- Subject: Unit neo4j.service has failed -- Defined-By: systemd -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel -- -- Unit neo4j.service has failed. -- -- The result is failed. Nov 06 00:57:21 archPC systemd[1]: Unit neo4j.service entered failed state. Nov 06 00:57:21 archPC sudo[6734]: pam_unix(sudo:session): session closed for user root Nov 06 00:57:31 archPC sudo[6889]: user : TTY=pts/1 ; PWD=/home/user ; USER=root ; COMMAND=/usr/bin/journalctl -xn Nov 06 00:57:31 archPC sudo[6889]: pam_unix(sudo:session): session opened for user root by (uid=0)

tucho commented on 2014-10-01 01:46 (UTC)

New Neo4j version (2.1.5).

tucho commented on 2014-09-19 20:08 (UTC)

New Neo4j version (2.1.4).

tucho commented on 2014-07-30 14:12 (UTC)

New Neo4j version (2.1.3).

tucho commented on 2014-06-12 23:29 (UTC)

New Neo4j version (2.1.2).

tucho commented on 2014-06-02 03:21 (UTC)

New Neo4j version. Thank you, gegenschall, for your advice. I took a slightly different way, though.

gegenschall commented on 2014-05-23 11:10 (UTC)

Just a nitpick about neo4j.install: Best would be to encourage users to copy the .service file from /usr/lib/systemd/system over to /etc/systemd/system and change it there. Changing .service files in /usr/lib would result in them being overwritten each time this package gets updated.

tucho commented on 2014-05-23 05:02 (UTC)

New Neo4J version (2.0.3). Hope this one solve your issues, @tkh23 and @jlmr.

tucho commented on 2014-04-16 11:39 (UTC)

New Neo4J version (2.0.2). @tkh23 and @jlmr: I will address your issues in the next days, I promise. I just cannot do it right now.

commented on 2014-03-17 08:46 (UTC)

Changing the limits in /etc/security/limits.conf doesn't work, see for example: https://bugzilla.redhat.com/show_bug.cgi?id=754285. Instead add: LimitNOFILE=40000 to the [Service] section of /lib/systemd/system/neo4j.service. When I figure out how, I'll propose a change to the package :-)

tkh23 commented on 2014-02-17 04:01 (UTC)

Must use JDK7 from AUR and also adjust some files: Edit /etc/security/limits.conf and add these two lines: neo4j soft nofile 40000 neo4j hard nofile 40000 Edit /etc/pam.d/su and uncomment or add the following line: session required pam_limits.so Then systemctl start neo4j.service :) Worked for me on fresh install.

tucho commented on 2014-02-06 18:09 (UTC)

New Neo4J version (2.0.1).

tucho commented on 2014-01-13 13:20 (UTC)

New version: 2.0.0-2 - /run/neo4j is now been created by systemd; - [Install] section was missing in neo4j.service.

tucho commented on 2014-01-07 03:13 (UTC)

Although I'd tried to follow the Java Package Guideline as strictly as possible, I did choose to overlook some of its rules in this "first-order approximation" packaging: - I did not declare dependencies to other java packages besides java-runtime; - I did not rewrite the shell scripts. This is my first AUR submit, so any help in addressing these issues will be kindly accepted. I would like to express my gratitude to my friend and coworker mereghost (Marcello Rocha). Without his assistance and incentive I would be forever untarring Neo4j in /opt.

grimboy commented on 2013-11-09 18:33 (UTC)

I concur that it should probably run as a new user neo4j. I think you can probably just make sure the user exists in the pkgbuild and add [exec] user= group= to the .service file as detailed in http://www.freedesktop.org/software/systemd/man/systemd.exec.html

commented on 2013-09-29 04:50 (UTC)

Won't it be dangerous to run the daemon with root?

joshdmiller commented on 2013-09-12 00:35 (UTC)

"lsof" should be added to the "depends" or it won't start.

corecode commented on 2013-03-08 20:10 (UTC)

at least neo4j-shell has a broken CP: need lib/*: CP="/usr/share/java/neo4j/lib/*:/usr/share/java/neo4j/system/*:/usr/share/java/neo4j/plugins/*"

djpohly commented on 2012-05-26 19:23 (UTC)

1.7-2: Paths for commons-collections fixed. Thanks yscik!

yscik commented on 2012-05-26 16:12 (UTC)

neo4j.rc has a leftover from jakarta-commons-collections on line 10: CP="$CP:/usr/share/java/jakarta-commons-collections/commons-collections.jar" java-commons-collections is located at /usr/share/java/commons-collections, should be updated :)

djpohly commented on 2012-04-20 16:44 (UTC)

1.7-1: Switched from jakarta-commons-collections to java-commons-collections. No difference really, but this one follows the naming conventions better. :)

djpohly commented on 2012-03-25 15:52 (UTC)

Updated to 1.6.1. You need to set a JAVA_HOME in /etc/conf.d/neo4j now. @Markus00000: This should fix the problem - so you can get rid of that symlink now. :)

Markus00000 commented on 2012-03-25 07:18 (UTC)

1.6.1 refused to start until I created a symlink /bin/java to /usr/bin/java.

djpohly commented on 2012-01-30 16:27 (UTC)

Updated to 1.6. Note that it may refuse to start if you try to use it with an earlier version's database! If anyone knows why, or how to fix it/upgrade the database, let me know and I'll patch that in. (I'm not actively using Neo at the moment.)

djpohly commented on 2011-10-31 21:27 (UTC)

Updated to 1.4.2. There are a few dependencies which could possibly be factored out, but I don't have time to do them myself. A quick package search shows lucene, scala, groovy, java-jackson, and java-commons-lang. And java-commons-* if someone's willing to make AUR packages for them...

djpohly commented on 2011-08-03 14:33 (UTC)

1.4.1-1: Version bump. Fix in neo4j.rc to work around bug? feature? in rc.d.

djpohly commented on 2011-04-23 04:16 (UTC)

1.3-2: Factored out some packages that already exist in repos or AUR.

djpohly commented on 2011-04-23 02:44 (UTC)

1.3-1: Tried to follow Java Package Guidelines from the wiki. All I can guarantee is that this runs. It appears to work alright though. :)