Package Details: neovim-qt-git v0.2.8.r0.g6e54e82-1

Git Clone URL: https://aur.archlinux.org/neovim-qt-git.git (read-only, click to copy)
Package Base: neovim-qt-git
Description: A Qt gui for Neovim (Neovim RPC and GUI using Qt5).
Upstream URL: https://github.com/equalsraf/neovim-qt
Keywords: gui neovim qt5 vim
Licenses: custom
Conflicts: neovim-qt
Submitter: aabmass
Maintainer: aabmass
Last Packager: aabmass
Votes: 39
Popularity: 0.007725
First Submitted: 2015-08-06 01:45 (UTC)
Last Updated: 2017-09-14 06:18 (UTC)

Latest Comments

1 2 3 Next › Last »

LightQuantum commented on 2020-02-02 18:01 (UTC) (edited on 2020-02-02 18:02 (UTC) by LightQuantum)

Maybe 'qt5-svg' should be added to depends?

-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:42 (find_package):
  By not providing "FindQt5Svg.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Qt5Svg", but
  CMake did not find one.

  Could not find a package configuration file provided by "Qt5Svg" with any
  of the following names:

    Qt5SvgConfig.cmake
    qt5svg-config.cmake

  Add the installation prefix of "Qt5Svg" to CMAKE_PREFIX_PATH or set
  "Qt5Svg_DIR" to a directory containing one of the above files.  If "Qt5Svg"
  provides a separate development package or SDK, be sure it has been
  installed.


-- Configuring incomplete, errors occurred!

yourealwaysbe commented on 2018-11-16 10:53 (UTC)

Just to check, is the pkgver() as intended? If i replace it with

git describe --long | sed 's/([^-]*-g)/r\1/;s/-/./g'

from here https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git i get a much more up to date version (e.g. it contains a bug fix from June).

chicomag commented on 2017-03-17 20:58 (UTC)

It works also with the armv7h arch.

Stunts commented on 2017-03-17 10:11 (UTC)

@aabmass Confirming that the fix works, I get no more file conflicts. Thanks!

aabmass commented on 2017-03-17 04:29 (UTC)

@Stunts thanks for pointing that out, I don't think it actually caused an issue but I took care of it. Can you confirm that there is no file conflict on /usr/share/nvim/runtime/doc/tags now? Thanks again!

aabmass commented on 2017-03-17 03:30 (UTC)

@Stunts thanks for the comment, I'll look into it.

Stunts commented on 2017-03-06 15:38 (UTC)

There seems to be a problem with files conflicting with "nvim": error: failed to commit transaction (conflicting files) neovim-qt-git: /usr/share/nvim/runtime/doc/tags exists in filesystem pacman -Qo /usr/share/nvim/runtime/doc/tags /usr/share/nvim/runtime/doc/tags is owned by neovim 0.1.7-2 Shouldn't this pacakges' files go to "/usr/share/nvim-qt/..." ? Thanks for looking into it.

frenchbeard commented on 2016-10-13 11:09 (UTC)

@aabmass Nevermind my comment, I somehow had default Cmake installed but jsoncpp was not there (must have taken a wrong turn somewhere). Thanks for having checked it out anyway.

aabmass commented on 2016-10-12 04:18 (UTC)

@frenchbeard that's strange that you didn't have jsoncpp since CMake depends on it: https://www.archlinux.org/packages/extra/x86_64/cmake/ What CMake package do you have installed?

frenchbeard commented on 2016-10-11 19:38 (UTC)

Hi, Just a quick fix needed on latest version (v0.2.2.r27.g4015d8c-1) : it seems to require jsoncpp (package in extra) at least for the build (didn't have the time to check on run).